aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/Makefile1
-rw-r--r--lang/etoile-scriptkit/Makefile33
-rw-r--r--lang/etoile-scriptkit/distinfo3
-rw-r--r--lang/etoile-scriptkit/pkg-descr11
-rw-r--r--lang/etoile-scriptkit/pkg-plist22
5 files changed, 70 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 4919612ff0ab..dc9e2fcf1538 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -54,6 +54,7 @@
SUBDIR += erlang-doc
SUBDIR += erlang-lite
SUBDIR += etoile-io
+ SUBDIR += etoile-scriptkit
SUBDIR += execline
SUBDIR += expect
SUBDIR += expect-devel
diff --git a/lang/etoile-scriptkit/Makefile b/lang/etoile-scriptkit/Makefile
new file mode 100644
index 000000000000..1f38329f0bb2
--- /dev/null
+++ b/lang/etoile-scriptkit/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: etoile-scriptkit
+# Date created: 23 Nov 2008
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= scriptkit
+PORTVERSION= 0.4.0
+CATEGORIES= lang gnustep
+MASTER_SITES= http://download.gna.org/etoile/
+PKGNAMEPREFIX= etoile-
+DISTNAME= etoile-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project ScriptKit framework
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
+USE_GNUSTEP_LOCAL_LIBS+= EtoileFoundation:${FOUNDATION_PORT}
+
+DEFAULT_LIBVERSION= 0.1
+WRKSRC= ${WRKDIR}/Etoile-${PORTVERSION}
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/ScriptKit
+
+FOUNDATION_PORT?= devel/etoile-foundation
+
+.include <bsd.port.mk>
diff --git a/lang/etoile-scriptkit/distinfo b/lang/etoile-scriptkit/distinfo
new file mode 100644
index 000000000000..2c1e8a612c54
--- /dev/null
+++ b/lang/etoile-scriptkit/distinfo
@@ -0,0 +1,3 @@
+MD5 (etoile-0.4.0.tar.bz2) = 7c33baf8ec3a708d0d419b1e137452de
+SHA256 (etoile-0.4.0.tar.bz2) = 05b5f01932aaad2ae6251ae01a1ad5376d29c984ee83d9fb62688c8d4a20237a
+SIZE (etoile-0.4.0.tar.bz2) = 8225128
diff --git a/lang/etoile-scriptkit/pkg-descr b/lang/etoile-scriptkit/pkg-descr
new file mode 100644
index 000000000000..ccdd5842d52d
--- /dev/null
+++ b/lang/etoile-scriptkit/pkg-descr
@@ -0,0 +1,11 @@
+ScriptKit is a very lightweight cross-app scripting framework built on top of
+Distributed Objects. It simply exports a dictionary containing a set of named
+objects for scripting with Objective-C or any languages based on the LanguageKit
+such as Pragmatic Smalltalk.
+
+This is used for example by the hit corners and gesture recognition tool to run
+arbitrary commands in response to corner activations or mouse gestures, and by
+ScriptServices which allows arbitrary shell or Smalltalk scripts to be invoked
+on the current selection from any GNUstep or Etoile application.
+
+WWW: http://www.etoile-project.org/
diff --git a/lang/etoile-scriptkit/pkg-plist b/lang/etoile-scriptkit/pkg-plist
new file mode 100644
index 000000000000..0b10e2a56eed
--- /dev/null
+++ b/lang/etoile-scriptkit/pkg-plist
@@ -0,0 +1,22 @@
+Local/Library/Frameworks/ScriptKit.framework/Headers
+Local/Library/Frameworks/ScriptKit.framework/Resources
+Local/Library/Frameworks/ScriptKit.framework/ScriptKit
+Local/Library/Frameworks/ScriptKit.framework/ScriptKit.framework
+Local/Library/Frameworks/ScriptKit.framework/Versions/%%MAJORLIBVERSION%%/Headers/ScriptCenter.h
+Local/Library/Frameworks/ScriptKit.framework/Versions/%%MAJORLIBVERSION%%/Headers/Tell.h
+Local/Library/Frameworks/ScriptKit.framework/Versions/%%MAJORLIBVERSION%%/Resources/Info-gnustep.plist
+Local/Library/Frameworks/ScriptKit.framework/Versions/%%MAJORLIBVERSION%%/ScriptKit
+Local/Library/Frameworks/ScriptKit.framework/Versions/%%MAJORLIBVERSION%%/libScriptKit.so
+Local/Library/Frameworks/ScriptKit.framework/Versions/%%MAJORLIBVERSION%%/libScriptKit.so.%%MAJORLIBVERSION%%
+Local/Library/Frameworks/ScriptKit.framework/Versions/%%MAJORLIBVERSION%%/libScriptKit.so.%%LIBVERSION%%
+Local/Library/Frameworks/ScriptKit.framework/Versions/Current
+Local/Library/Frameworks/ScriptKit.framework/libScriptKit.so
+Local/Library/Headers/ScriptKit
+Local/Library/Libraries/libScriptKit.so
+Local/Library/Libraries/libScriptKit.so.%%MAJORLIBVERSION%%
+Local/Library/Libraries/libScriptKit.so.%%LIBVERSION%%
+@dirrm Local/Library/Frameworks/ScriptKit.framework/Versions/%%MAJORLIBVERSION%%/Resources
+@dirrm Local/Library/Frameworks/ScriptKit.framework/Versions/%%MAJORLIBVERSION%%/Headers
+@dirrm Local/Library/Frameworks/ScriptKit.framework/Versions/%%MAJORLIBVERSION%%
+@dirrm Local/Library/Frameworks/ScriptKit.framework/Versions
+@dirrm Local/Library/Frameworks/ScriptKit.framework