aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--UPDATING10
-rw-r--r--net/libdnet/Makefile37
-rw-r--r--net/libdnet/pkg-plist50
-rw-r--r--net/py-libdnet/Makefile24
-rw-r--r--net/py-libdnet/pkg-descr8
-rw-r--r--net/py-libdnet/pkg-plist1
6 files changed, 68 insertions, 62 deletions
diff --git a/UPDATING b/UPDATING
index bb09b1bb3845..985a241cc763 100644
--- a/UPDATING
+++ b/UPDATING
@@ -6,6 +6,16 @@ You should get into the habit of checking this file for changes each
time you update your ports collection, before attempting any port
upgrades.
+200704-12:
+ AFFECTS: all users of net/py-libdnet
+ AUTHOR: tmclaugh@FreeBSD.org
+
+ The py-libdnet port has been seperated out as a slave port to libdnet and
+ is now dependent on libdnet. py-libdnet now only installs the libdnet
+ python modules. Since files previously owned by py-libdnet are now owned
+ by its dependency, in order to upgrade correctly, py-libdnet must be
+ deinstall and then reinstalled manually.
+
20070205:
AFFECTS: all users of FreeBSD 4.X
AUTHOR: portmgr@FreeBSD.org
diff --git a/net/libdnet/Makefile b/net/libdnet/Makefile
index 7c928966a314..126d5ccf5855 100644
--- a/net/libdnet/Makefile
+++ b/net/libdnet/Makefile
@@ -7,50 +7,29 @@
PORTNAME= libdnet
PORTVERSION= 1.11
-CATEGORIES= net
+PORTREVISION?= 1
+CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-.if defined(BUILD_PYTHON_MODULE)
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-.endif
-MAINTAINER= onatan@gmail.com
+MAINTAINER?= onatan@gmail.com
COMMENT?= A simple interface to low level networking routines
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-SLAVE_DIRS= net/py-libdnet
-
-.if defined(BUILD_PYTHON_MODULE)
-USE_PYTHON= yes
-CONFIGURE_ARGS+= --with-python
-INSTALL_WRKSRC= ${BUILD_WRKSRC}/python
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/dnet.so
-PLIST_SUB+= MASTER="@comment "
-.else
-CONFIGURE_ARGS+= --without-python
+.if !defined(LIBDNET_SLAVE)
+CONFIGURE_ARGS+=--without-python
USE_LDCONFIG= yes
-PLIST_SUB+= MASTER=""
MAN3= dnet.3
MAN8= dnet.8
.endif
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= doesn't build on FreeBSD 4.x
-.endif
-
-pre-everything::
-.if !defined(BUILD_PYTHON_MODULE)
- @${ECHO_MSG} "===>"
- @${ECHO_MSG} "===> You can add python support with the port ${SLAVE_DIRS}."
- @${ECHO_MSG} "===>"
- @sleep 2
-.endif
+.if !defined(LIBDNET_SLAVE)
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
@@ -61,10 +40,6 @@ post-build:
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME}.so ${PREFIX}/lib/
@${LN} ${PREFIX}/lib/${PORTNAME}.so ${PREFIX}/lib/${PORTNAME}.so.1
-
-.if defined(BUILD_PYTHON_MODULE) && defined(MAINTAINER_MODE)
-test: install
- ${PYTHON_CMD} ${INSTALL_WRKSRC}/test.py
.endif
.include <bsd.port.post.mk>
diff --git a/net/libdnet/pkg-plist b/net/libdnet/pkg-plist
index a111ab699324..58d3c68913cb 100644
--- a/net/libdnet/pkg-plist
+++ b/net/libdnet/pkg-plist
@@ -1,25 +1,25 @@
-%%MASTER%%sbin/dnet
-%%MASTER%%bin/dnet-config
-%%MASTER%%lib/libdnet
-%%MASTER%%lib/libdnet.1
-%%MASTER%%lib/libdnet.a
-%%MASTER%%lib/libdnet.la
-%%MASTER%%lib/libdnet.so
-%%MASTER%%lib/libdnet.so.1
-%%MASTER%%include/dnet.h
-%%MASTER%%include/dnet/addr.h
-%%MASTER%%include/dnet/arp.h
-%%MASTER%%include/dnet/blob.h
-%%MASTER%%include/dnet/eth.h
-%%MASTER%%include/dnet/fw.h
-%%MASTER%%include/dnet/icmp.h
-%%MASTER%%include/dnet/intf.h
-%%MASTER%%include/dnet/ip.h
-%%MASTER%%include/dnet/ip6.h
-%%MASTER%%include/dnet/os.h
-%%MASTER%%include/dnet/rand.h
-%%MASTER%%include/dnet/route.h
-%%MASTER%%include/dnet/tcp.h
-%%MASTER%%include/dnet/tun.h
-%%MASTER%%include/dnet/udp.h
-%%MASTER%%@dirrm include/dnet
+sbin/dnet
+bin/dnet-config
+lib/libdnet
+lib/libdnet.1
+lib/libdnet.a
+lib/libdnet.la
+lib/libdnet.so
+lib/libdnet.so.1
+include/dnet.h
+include/dnet/addr.h
+include/dnet/arp.h
+include/dnet/blob.h
+include/dnet/eth.h
+include/dnet/fw.h
+include/dnet/icmp.h
+include/dnet/intf.h
+include/dnet/ip.h
+include/dnet/ip6.h
+include/dnet/os.h
+include/dnet/rand.h
+include/dnet/route.h
+include/dnet/tcp.h
+include/dnet/tun.h
+include/dnet/udp.h
+@dirrm include/dnet
diff --git a/net/py-libdnet/Makefile b/net/py-libdnet/Makefile
index 90a72a28d1e6..e0ac15d5e5d9 100644
--- a/net/py-libdnet/Makefile
+++ b/net/py-libdnet/Makefile
@@ -5,17 +5,29 @@
# $FreeBSD$
#
+CATEGORIES= net python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
COMMENT= Python module for libdnet
-BROKEN= Incomplete pkg-plist
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2007-04-10
+LIB_DEPENDS= dnet.1:${PORTSDIR}/net/libdnet
+
+NOT_FOR_ARCHS= ia64
+NOT_FOR_ARCHS_REASON_ia64= fails to build with internal compiler error
MASTERDIR= ${.CURDIR}/../libdnet
+INSTALL_WRKSRC= ${WRKSRC}/python
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
-BUILD_PYTHON_MODULE= yes
+LIBDNET_SLAVE= yes
-NOT_FOR_ARCHS= ia64
-NOT_FOR_ARCHS_REASON_ia64= fails to build with internal compiler error
+USE_PYTHON= yes
+CONFIGURE_ARGS= --with-python
+
+.if defined(MAINTAINER_MODE)
+regression-test: install
+ ${PYTHON_CMD} ${INSTALL_WRKSRC}/test.py
+.endif
.include "${MASTERDIR}/Makefile"
diff --git a/net/py-libdnet/pkg-descr b/net/py-libdnet/pkg-descr
new file mode 100644
index 000000000000..d2c164de959f
--- /dev/null
+++ b/net/py-libdnet/pkg-descr
@@ -0,0 +1,8 @@
+Python wrapper around libdnet which provides a simplified, portable
+interface to several low-level networking routines, including network
+address manipulation, kernel arp(4) cache and route(4) table lookup and
+manipulation, network firewalling, network interface lookup and
+manipulation, and raw IP packet and Ethernet frame transmission. It is
+intended to complement the functionality provided by pcap(3).
+
+WWW: http://libdnet.sourceforge.net/
diff --git a/net/py-libdnet/pkg-plist b/net/py-libdnet/pkg-plist
new file mode 100644
index 000000000000..517b2c4e10a4
--- /dev/null
+++ b/net/py-libdnet/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/dnet.so