aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-Tmpl/Makefile27
-rw-r--r--textproc/p5-Text-Tmpl/distinfo1
-rw-r--r--textproc/p5-Text-Tmpl/pkg-comment1
-rw-r--r--textproc/p5-Text-Tmpl/pkg-descr16
-rw-r--r--textproc/p5-Text-Tmpl/pkg-plist11
6 files changed, 57 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index df671bc84339..1847cd692d45 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -85,6 +85,7 @@
SUBDIR += p5-Text-Graphics
SUBDIR += p5-Text-Query
SUBDIR += p5-Text-Template
+ SUBDIR += p5-Text-Tmpl
SUBDIR += p5-Text-Wrapper
SUBDIR += p5-XML-DOM
SUBDIR += p5-XML-Parser
diff --git a/textproc/p5-Text-Tmpl/Makefile b/textproc/p5-Text-Tmpl/Makefile
new file mode 100644
index 000000000000..8fef0c7dbcca
--- /dev/null
+++ b/textproc/p5-Text-Tmpl/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: textproc/p5-Text-Tmpl
+# Date created: 31 December 2000
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Tmpl
+PORTVERSION= 0.23
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= template_syntax.3 Text::Tmpl.3 template_extend.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+pre-patch:
+ @${PERL} -pi -e '/OPTIMIZE|libtmpl.pod/ and $$_=""' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Tmpl/distinfo b/textproc/p5-Text-Tmpl/distinfo
new file mode 100644
index 000000000000..df2da1c6a9c2
--- /dev/null
+++ b/textproc/p5-Text-Tmpl/distinfo
@@ -0,0 +1 @@
+MD5 (Text-Tmpl-0.23.tar.gz) = 5314f8074b0c17322f808b8c70684425
diff --git a/textproc/p5-Text-Tmpl/pkg-comment b/textproc/p5-Text-Tmpl/pkg-comment
new file mode 100644
index 000000000000..e55654c2c169
--- /dev/null
+++ b/textproc/p5-Text-Tmpl/pkg-comment
@@ -0,0 +1 @@
+Templating system perl library
diff --git a/textproc/p5-Text-Tmpl/pkg-descr b/textproc/p5-Text-Tmpl/pkg-descr
new file mode 100644
index 000000000000..55983bff5e4e
--- /dev/null
+++ b/textproc/p5-Text-Tmpl/pkg-descr
@@ -0,0 +1,16 @@
+Text::Tmpl is a module for very fast templating. There are dozens of
+templating modules on CPAN, each only a tiny bit different from the
+others. This one is no different - what sets it aside is speed. The
+entire module is implemented as a C library, with only a thin XS/Perl
+layer to make the calls available from Perl. The same templates, then,
+can be used from either Perl or C/C++ programs.
+
+This was originally designed to completely isolate HTML programmers from
+module/CGI programmers, or at least completely separate logic from
+content in dynamic web applications. It is syntactically based on a
+similar system written by a friend of mine, Neil Mix, which was
+proprietary and exclusively written in Perl. It shares no code in common
+with this system, or any other.
+
+-Anton
+<tobez@tobez.org>
diff --git a/textproc/p5-Text-Tmpl/pkg-plist b/textproc/p5-Text-Tmpl/pkg-plist
new file mode 100644
index 000000000000..b5e5dfe0a172
--- /dev/null
+++ b/textproc/p5-Text-Tmpl/pkg-plist
@@ -0,0 +1,11 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Tmpl/Tmpl.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Tmpl/Tmpl.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Tmpl/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Tmpl/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Text/template_syntax.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Text/libtmpl.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Text/template_extend.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Text/Tmpl.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Tmpl
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Text 2>/dev/null || true