aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/shoutcast/Makefile8
-rw-r--r--audio/shoutcast/distinfo3
-rw-r--r--dns/dualserver/Makefile5
-rw-r--r--dns/dualserver/files/extra-patch-dualserver.cpp59
-rw-r--r--dns/dualserver/files/extra-patch-dualserver.h11
-rw-r--r--security/amavisd-new/Makefile7
-rw-r--r--textproc/gsed/Makefile6
-rw-r--r--textproc/gsed/files/extrapatch-lib-regexec.c43
8 files changed, 2 insertions, 140 deletions
diff --git a/audio/shoutcast/Makefile b/audio/shoutcast/Makefile
index 82c96a9f20bd..50e472f9c30a 100644
--- a/audio/shoutcast/Makefile
+++ b/audio/shoutcast/Makefile
@@ -9,6 +9,7 @@ PORTVERSION= 1.9.7
PORTREVISION= 1
CATEGORIES= audio net
MASTER_SITES= http://www.shoutcast.com/downloads/sc1-9-7/
+DISTNAME= ${PORTNAME}-1-9-7-freebsd5-elf
MAINTAINER= gabor@FreeBSD.org
COMMENT= Nullsoft's streaming audio server (binary port)
@@ -25,16 +26,9 @@ WRKSRC= ${WRKDIR}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500000
-DISTNAME= ${PORTNAME}-1-9-7-freebsd5-elf
.if ${OSVERSION} >= 600000
LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
.endif
-.elif ${OSVERSION} >= 400000
-DISTNAME= ${PORTNAME}-1-9-7-freebsd4-elf
-.else
-BROKEN= unsupported FreeBSD version
-.endif
post-patch:
@${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' \
diff --git a/audio/shoutcast/distinfo b/audio/shoutcast/distinfo
index c89ff0673014..27bdca3ab578 100644
--- a/audio/shoutcast/distinfo
+++ b/audio/shoutcast/distinfo
@@ -1,6 +1,3 @@
-MD5 (shoutcast-1-9-7-freebsd4-elf.tar.gz) = c695a0fd706bb1045d54dcb1b3048fee
-SHA256 (shoutcast-1-9-7-freebsd4-elf.tar.gz) = 5005e8c9b9197b1729f565b1a933466727a6290c1b6d5add023b072f694c8a19
-SIZE (shoutcast-1-9-7-freebsd4-elf.tar.gz) = 57218
MD5 (shoutcast-1-9-7-freebsd5-elf.tar.gz) = c25f3abcf6bd9d76d71fdc7f22d7332a
SHA256 (shoutcast-1-9-7-freebsd5-elf.tar.gz) = 6650e9877e85cee2502b67ad5402a79018eb32be993a35f444754516c55a69df
SIZE (shoutcast-1-9-7-freebsd5-elf.tar.gz) = 62833
diff --git a/dns/dualserver/Makefile b/dns/dualserver/Makefile
index f34b8333cd90..1096ed751e8b 100644
--- a/dns/dualserver/Makefile
+++ b/dns/dualserver/Makefile
@@ -20,11 +20,6 @@ PLIST_FILES= sbin/dualserver etc/dualserver.conf.sample
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-dualserver.h \
- ${FILESDIR}/extra-patch-dualserver.cpp
-.endif
-
pre-patch:
${REINPLACE_CMD} 's|/etc/dualserver.ini|${PREFIX}/etc/dualserver.conf|' ${WRKSRC}/dualserver.cpp
${REINPLACE_CMD} 's|/etc/dualserver.state|/var/run/dualserver.state|' ${WRKSRC}/dualserver.cpp
diff --git a/dns/dualserver/files/extra-patch-dualserver.cpp b/dns/dualserver/files/extra-patch-dualserver.cpp
deleted file mode 100644
index dff2330641ee..000000000000
--- a/dns/dualserver/files/extra-patch-dualserver.cpp
+++ /dev/null
@@ -1,59 +0,0 @@
---- dualserver.cpp.orig Mon Jun 5 16:08:44 2006
-+++ dualserver.cpp Mon Jun 5 16:09:14 2006
-@@ -501,15 +501,15 @@
- if (!req->rtype)
- {
- req->dnsp.header.ancount = 0;
-- req->dnsp.header.rcode = 3;
-- req->dnsp.header.ra = 0;
-+ req->dnsp.header.flags.rcode = 3;
-+ req->dnsp.header.flags.ra = 0;
- }
-
- req->dnsp.header.nscount = 0;
- req->dnsp.header.adcount = 0;
-- req->dnsp.header.qr = 1;
-- req->dnsp.header.aa = 1;
--
-+ req->dnsp.header.flags.qr = 1;
-+ req->dnsp.header.flags.aa = 1;
-+
- char *raw = req->dnsp.data;
-
- for (int i = 1; i <= ntohs(req->dnsp.header.qdcount); i++)
-@@ -701,7 +701,7 @@
- time_t currentTime = time(NULL);
- req->lease = cfig->lease;
-
-- if (ntohs(req->dnsp.header.qdcount) == 1 && ntohs(req->dnsp.header.opcode) == 0)
-+ if (ntohs(req->dnsp.header.qdcount) == 1 && ntohs(req->dnsp.header.flags.opcode) == 0)
- {
- char *raw = req->dnsp.data;
- raw += fQu(req->query, &req->dnsp, raw);
-@@ -721,7 +721,7 @@
- {
- if (!checkLocal(req, cfig))
- {
-- if (!req->dnsp.header.rd)
-+ if (!req->dnsp.header.flags.rd)
- return genMess(req, cfig);
- else
- return 0;
-@@ -1127,7 +1127,7 @@
- if (!found)
- req->bytes = 0;
-
-- req->dnsp.header.aa = 0;
-+ req->dnsp.header.flags.aa = 0;
- return req->bytes;
- }
-
-@@ -2216,7 +2216,7 @@
-
- mess.header.xid = 6;
- mess.header.qdcount = htons(1);
-- mess.header.rd = 1;
-+ mess.header.flags.rd = 1;
- char *raw = mess.data;
- raw += pQu(raw, "1.0.0.127.in-addr.arpa");
- raw += pShort(raw, DNS_TYPE_PTR);
diff --git a/dns/dualserver/files/extra-patch-dualserver.h b/dns/dualserver/files/extra-patch-dualserver.h
deleted file mode 100644
index f1d0cf494f95..000000000000
--- a/dns/dualserver/files/extra-patch-dualserver.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- dualserver.h.orig Sun Apr 30 11:33:14 2006
-+++ dualserver.h Sun Apr 30 11:33:37 2006
-@@ -98,7 +98,7 @@
- BYTE rcode: 4;
- BYTE z: 3;
- BYTE ra: 1;
-- };
-+ } flags;
- };
- union {
- WORD zcount;
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index 0e3ca7509401..30fae139b723 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -43,6 +43,7 @@ AMAVISUSER?= vscan
AMAVISGROUP?= vscan
AMAVISDIR?= /var/amavis
AMAVISQUARANTINE?= /var/virusmails
+DAEMON?= /usr/sbin/daemon -p
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\.p.+//}
@@ -85,12 +86,6 @@ PLIST_SUB+= AMAVIS_NOAMAVIS=${AMAVIS_NOAMAVIS} \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-DAEMON=/usr/sbin/daemon
-.else
-DAEMON=/usr/sbin/daemon -p
-.endif
-
USE_RC_SUBR+= amavisd.sh
.if !defined(WITH_MILTER) || (!exists(/usr/lib/libmilter.a) && !exists(${PREFIX}/lib/libmilter.a))
diff --git a/textproc/gsed/Makefile b/textproc/gsed/Makefile
index 5ff12ce98072..c5d6426984a8 100644
--- a/textproc/gsed/Makefile
+++ b/textproc/gsed/Makefile
@@ -35,12 +35,6 @@ DOCSDIR= ${TARGETDIR}/share/doc/${PKGBASE}
.include <bsd.port.pre.mk>
-# Required for gcc 2.95 since it is pre-C99
-# and doesn't handle the 'bool' datatype properly.
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES= ${FILESDIR}/extrapatch-lib-regexec.c
-.endif
-
post-patch:
@${REINPLACE_CMD} 's,^\* sed:,* GNU sed:,' \
${WRKSRC}/doc/config.texi
diff --git a/textproc/gsed/files/extrapatch-lib-regexec.c b/textproc/gsed/files/extrapatch-lib-regexec.c
deleted file mode 100644
index a7842dc994e8..000000000000
--- a/textproc/gsed/files/extrapatch-lib-regexec.c
+++ /dev/null
@@ -1,43 +0,0 @@
-#
-# Required for gcc 2.95 since it is pre-C99
-# and doesn't handle the 'bool' datatype properly.
-#
---- lib/regexec.c.orig Sat Apr 15 20:53:36 2006
-+++ lib/regexec.c Sat Apr 15 21:17:03 2006
-@@ -3296,8 +3296,7 @@
- reg_errcode_t err;
- int i, j, ch, need_word_trtable = 0;
- bitset_word_t elem, mask;
-- bool dests_node_malloced = false;
-- bool dest_states_malloced = false;
-+ int dests_node_malloced = 0, dest_states_malloced = 0;
- int ndests; /* Number of the destination states from `state'. */
- re_dfastate_t **trtable;
- re_dfastate_t **dest_states = NULL, **dest_states_word, **dest_states_nl;
-@@ -3322,7 +3321,7 @@
- dests_alloc = re_malloc (struct dests_alloc, 1);
- if (BE (dests_alloc == NULL, 0))
- return 0;
-- dests_node_malloced = true;
-+ dests_node_malloced = 1;
- }
- dests_node = dests_alloc->dests_node;
- dests_ch = dests_alloc->dests_ch;
-@@ -3371,7 +3370,7 @@
- free (dests_alloc);
- return 0;
- }
-- dest_states_malloced = true;
-+ dest_states_malloced = 1;
- }
- dest_states_word = dest_states + ndests;
- dest_states_nl = dest_states_word + ndests;
-@@ -3576,7 +3575,7 @@
- {
- if (constraint & NEXT_NEWLINE_CONSTRAINT)
- {
-- bool accepts_newline = bitset_contain (accepts, NEWLINE_CHAR);
-+ int accepts_newline = bitset_contain (accepts, NEWLINE_CHAR);
- bitset_empty (accepts);
- if (accepts_newline)
- bitset_set (accepts, NEWLINE_CHAR);