aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/last-cmus/Makefile34
-rw-r--r--audio/last-cmus/distinfo3
-rw-r--r--audio/last-cmus/files/pkg-message.in11
-rw-r--r--audio/last-cmus/pkg-descr5
5 files changed, 54 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 57c198b07263..2fc23edd2187 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -335,6 +335,7 @@
SUBDIR += ladspa
SUBDIR += lame
SUBDIR += lash
+ SUBDIR += last-cmus
SUBDIR += last.fm
SUBDIR += laudio
SUBDIR += liba52
diff --git a/audio/last-cmus/Makefile b/audio/last-cmus/Makefile
new file mode 100644
index 000000000000..23c3880fb113
--- /dev/null
+++ b/audio/last-cmus/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: last-cmus
+# Date created: 30 November 2008
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= last
+PORTVERSION= 1.0
+CATEGORIES= audio
+MASTER_SITES= http://last-cmus.googlecode.com/files/ \
+ http://mirror.mcx2.org/
+PKGNAMESUFFIX= -cmus
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}.py
+EXTRACT_SUFX= # none
+
+MAINTAINER= adox@mcx2.org
+COMMENT= Cmus plugin for submitting songs into last.fm
+
+USE_PYTHON= yes
+SUB_FILES= pkg-message
+NO_BUILD= yes
+PLIST_FILES= bin/${DISTNAME}
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${_DISTDIR}/last-cmus.py ${WRKSRC}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/
+ @${CHMOD} +x ${PREFIX}/bin/${DISTNAME}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/audio/last-cmus/distinfo b/audio/last-cmus/distinfo
new file mode 100644
index 000000000000..0caa39a4018b
--- /dev/null
+++ b/audio/last-cmus/distinfo
@@ -0,0 +1,3 @@
+MD5 (last-cmus.py) = c2165a1d62e0bd051a4db5e78233f701
+SHA256 (last-cmus.py) = c0db2a250c997e7b3a4f1dbbe997a1b2ec41de02c338c9fc5cbfdaea80a38cf9
+SIZE (last-cmus.py) = 12439
diff --git a/audio/last-cmus/files/pkg-message.in b/audio/last-cmus/files/pkg-message.in
new file mode 100644
index 000000000000..d7a5502580c6
--- /dev/null
+++ b/audio/last-cmus/files/pkg-message.in
@@ -0,0 +1,11 @@
+=====================================================================
+
+To start using last-cmus.py, please complete the following steps:
+
+1. Edit the %%PREFIX%%/bin/last-cmus.py file with right
+ username and password.
+
+2. Enable it by appending this setting to your ~/.cmus/rc:
+ set status_display_program=%%PREFIX%%/bin/last-cmus.py
+
+=====================================================================
diff --git a/audio/last-cmus/pkg-descr b/audio/last-cmus/pkg-descr
new file mode 100644
index 000000000000..b0d4881e88ed
--- /dev/null
+++ b/audio/last-cmus/pkg-descr
@@ -0,0 +1,5 @@
+This is a last.fm plugin for the CMUS
+ncurses based music-player. Written in
+Python.
+
+WWW: http://code.google.com/p/last-cmus/