aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/thunderbird-devel/Makefile1
-rw-r--r--mail/thunderbird-devel/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in17
-rw-r--r--mail/thunderbird-esr/Makefile1
-rw-r--r--mail/thunderbird-esr/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in17
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--mail/thunderbird/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in17
-rw-r--r--mail/thunderbird3/Makefile1
-rw-r--r--mail/thunderbird3/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in17
-rw-r--r--www/firefox-devel/Makefile1
-rw-r--r--www/firefox-devel/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in17
-rw-r--r--www/firefox-esr/Makefile1
-rw-r--r--www/firefox-esr/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in17
-rw-r--r--www/firefox/Makefile1
-rw-r--r--www/firefox/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in17
-rw-r--r--www/firefox10/Makefile1
-rw-r--r--www/firefox10/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in17
-rw-r--r--www/firefox15/Makefile1
-rw-r--r--www/firefox15/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in17
-rw-r--r--www/firefox3-devel/Makefile1
-rw-r--r--www/firefox3-devel/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in17
-rw-r--r--www/firefox35/Makefile1
-rw-r--r--www/firefox35/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in17
-rw-r--r--www/firefox36/Makefile1
-rw-r--r--www/firefox36/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in17
-rw-r--r--www/flock/Makefile1
-rw-r--r--www/flock/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in17
26 files changed, 234 insertions, 0 deletions
diff --git a/mail/thunderbird-devel/Makefile b/mail/thunderbird-devel/Makefile
index 7afad8bd8a46..f4b5a113c490 100644
--- a/mail/thunderbird-devel/Makefile
+++ b/mail/thunderbird-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= thunderbird
PORTVERSION= 0.7.2
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= thunderbird/releases/${PORTVERSION}
diff --git a/mail/thunderbird-devel/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in b/mail/thunderbird-devel/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
new file mode 100644
index 000000000000..feffd2c6344f
--- /dev/null
+++ b/mail/thunderbird-devel/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
@@ -0,0 +1,17 @@
+--- toolkit/mozapps/extensions/src/nsExtensionManager.js.in.orig Tue Jul 27 15:35:12 2004
++++ toolkit/mozapps/extensions/src/nsExtensionManager.js.in Tue Jul 27 15:36:02 2004
+@@ -1568,9 +1568,14 @@
+
+ _checkForGlobalInstalls: function (aPath, aItemType)
+ {
++ var fPrefix = "file://";
+ // First see if the path supplied is a file path
+ var file = Components.classes["@mozilla.org/file/local;1"]
+ .createInstance(Components.interfaces.nsILocalFile);
++ if (aPath.substr(0, fPrefix.length) == fPrefix) {
++ // Strip out the file:// prefix if it exists
++ aPath = aPath.substr(fPrefix.length, aPath.length);
++ }
+ try {
+ file.initWithPath(aPath);
+ }
diff --git a/mail/thunderbird-esr/Makefile b/mail/thunderbird-esr/Makefile
index 7afad8bd8a46..f4b5a113c490 100644
--- a/mail/thunderbird-esr/Makefile
+++ b/mail/thunderbird-esr/Makefile
@@ -7,6 +7,7 @@
PORTNAME= thunderbird
PORTVERSION= 0.7.2
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= thunderbird/releases/${PORTVERSION}
diff --git a/mail/thunderbird-esr/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in b/mail/thunderbird-esr/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
new file mode 100644
index 000000000000..feffd2c6344f
--- /dev/null
+++ b/mail/thunderbird-esr/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
@@ -0,0 +1,17 @@
+--- toolkit/mozapps/extensions/src/nsExtensionManager.js.in.orig Tue Jul 27 15:35:12 2004
++++ toolkit/mozapps/extensions/src/nsExtensionManager.js.in Tue Jul 27 15:36:02 2004
+@@ -1568,9 +1568,14 @@
+
+ _checkForGlobalInstalls: function (aPath, aItemType)
+ {
++ var fPrefix = "file://";
+ // First see if the path supplied is a file path
+ var file = Components.classes["@mozilla.org/file/local;1"]
+ .createInstance(Components.interfaces.nsILocalFile);
++ if (aPath.substr(0, fPrefix.length) == fPrefix) {
++ // Strip out the file:// prefix if it exists
++ aPath = aPath.substr(fPrefix.length, aPath.length);
++ }
+ try {
+ file.initWithPath(aPath);
+ }
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 7afad8bd8a46..f4b5a113c490 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -7,6 +7,7 @@
PORTNAME= thunderbird
PORTVERSION= 0.7.2
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= thunderbird/releases/${PORTVERSION}
diff --git a/mail/thunderbird/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in b/mail/thunderbird/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
new file mode 100644
index 000000000000..feffd2c6344f
--- /dev/null
+++ b/mail/thunderbird/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
@@ -0,0 +1,17 @@
+--- toolkit/mozapps/extensions/src/nsExtensionManager.js.in.orig Tue Jul 27 15:35:12 2004
++++ toolkit/mozapps/extensions/src/nsExtensionManager.js.in Tue Jul 27 15:36:02 2004
+@@ -1568,9 +1568,14 @@
+
+ _checkForGlobalInstalls: function (aPath, aItemType)
+ {
++ var fPrefix = "file://";
+ // First see if the path supplied is a file path
+ var file = Components.classes["@mozilla.org/file/local;1"]
+ .createInstance(Components.interfaces.nsILocalFile);
++ if (aPath.substr(0, fPrefix.length) == fPrefix) {
++ // Strip out the file:// prefix if it exists
++ aPath = aPath.substr(fPrefix.length, aPath.length);
++ }
+ try {
+ file.initWithPath(aPath);
+ }
diff --git a/mail/thunderbird3/Makefile b/mail/thunderbird3/Makefile
index 7afad8bd8a46..f4b5a113c490 100644
--- a/mail/thunderbird3/Makefile
+++ b/mail/thunderbird3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= thunderbird
PORTVERSION= 0.7.2
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= thunderbird/releases/${PORTVERSION}
diff --git a/mail/thunderbird3/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in b/mail/thunderbird3/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
new file mode 100644
index 000000000000..feffd2c6344f
--- /dev/null
+++ b/mail/thunderbird3/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
@@ -0,0 +1,17 @@
+--- toolkit/mozapps/extensions/src/nsExtensionManager.js.in.orig Tue Jul 27 15:35:12 2004
++++ toolkit/mozapps/extensions/src/nsExtensionManager.js.in Tue Jul 27 15:36:02 2004
+@@ -1568,9 +1568,14 @@
+
+ _checkForGlobalInstalls: function (aPath, aItemType)
+ {
++ var fPrefix = "file://";
+ // First see if the path supplied is a file path
+ var file = Components.classes["@mozilla.org/file/local;1"]
+ .createInstance(Components.interfaces.nsILocalFile);
++ if (aPath.substr(0, fPrefix.length) == fPrefix) {
++ // Strip out the file:// prefix if it exists
++ aPath = aPath.substr(fPrefix.length, aPath.length);
++ }
+ try {
+ file.initWithPath(aPath);
+ }
diff --git a/www/firefox-devel/Makefile b/www/firefox-devel/Makefile
index faee9ffb4148..5eeeb7b36085 100644
--- a/www/firefox-devel/Makefile
+++ b/www/firefox-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
diff --git a/www/firefox-devel/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in b/www/firefox-devel/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
new file mode 100644
index 000000000000..feffd2c6344f
--- /dev/null
+++ b/www/firefox-devel/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
@@ -0,0 +1,17 @@
+--- toolkit/mozapps/extensions/src/nsExtensionManager.js.in.orig Tue Jul 27 15:35:12 2004
++++ toolkit/mozapps/extensions/src/nsExtensionManager.js.in Tue Jul 27 15:36:02 2004
+@@ -1568,9 +1568,14 @@
+
+ _checkForGlobalInstalls: function (aPath, aItemType)
+ {
++ var fPrefix = "file://";
+ // First see if the path supplied is a file path
+ var file = Components.classes["@mozilla.org/file/local;1"]
+ .createInstance(Components.interfaces.nsILocalFile);
++ if (aPath.substr(0, fPrefix.length) == fPrefix) {
++ // Strip out the file:// prefix if it exists
++ aPath = aPath.substr(fPrefix.length, aPath.length);
++ }
+ try {
+ file.initWithPath(aPath);
+ }
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index faee9ffb4148..5eeeb7b36085 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
diff --git a/www/firefox-esr/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in b/www/firefox-esr/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
new file mode 100644
index 000000000000..feffd2c6344f
--- /dev/null
+++ b/www/firefox-esr/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
@@ -0,0 +1,17 @@
+--- toolkit/mozapps/extensions/src/nsExtensionManager.js.in.orig Tue Jul 27 15:35:12 2004
++++ toolkit/mozapps/extensions/src/nsExtensionManager.js.in Tue Jul 27 15:36:02 2004
+@@ -1568,9 +1568,14 @@
+
+ _checkForGlobalInstalls: function (aPath, aItemType)
+ {
++ var fPrefix = "file://";
+ // First see if the path supplied is a file path
+ var file = Components.classes["@mozilla.org/file/local;1"]
+ .createInstance(Components.interfaces.nsILocalFile);
++ if (aPath.substr(0, fPrefix.length) == fPrefix) {
++ // Strip out the file:// prefix if it exists
++ aPath = aPath.substr(fPrefix.length, aPath.length);
++ }
+ try {
+ file.initWithPath(aPath);
+ }
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index faee9ffb4148..5eeeb7b36085 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
diff --git a/www/firefox/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in b/www/firefox/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
new file mode 100644
index 000000000000..feffd2c6344f
--- /dev/null
+++ b/www/firefox/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
@@ -0,0 +1,17 @@
+--- toolkit/mozapps/extensions/src/nsExtensionManager.js.in.orig Tue Jul 27 15:35:12 2004
++++ toolkit/mozapps/extensions/src/nsExtensionManager.js.in Tue Jul 27 15:36:02 2004
+@@ -1568,9 +1568,14 @@
+
+ _checkForGlobalInstalls: function (aPath, aItemType)
+ {
++ var fPrefix = "file://";
+ // First see if the path supplied is a file path
+ var file = Components.classes["@mozilla.org/file/local;1"]
+ .createInstance(Components.interfaces.nsILocalFile);
++ if (aPath.substr(0, fPrefix.length) == fPrefix) {
++ // Strip out the file:// prefix if it exists
++ aPath = aPath.substr(fPrefix.length, aPath.length);
++ }
+ try {
+ file.initWithPath(aPath);
+ }
diff --git a/www/firefox10/Makefile b/www/firefox10/Makefile
index faee9ffb4148..5eeeb7b36085 100644
--- a/www/firefox10/Makefile
+++ b/www/firefox10/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
diff --git a/www/firefox10/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in b/www/firefox10/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
new file mode 100644
index 000000000000..feffd2c6344f
--- /dev/null
+++ b/www/firefox10/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
@@ -0,0 +1,17 @@
+--- toolkit/mozapps/extensions/src/nsExtensionManager.js.in.orig Tue Jul 27 15:35:12 2004
++++ toolkit/mozapps/extensions/src/nsExtensionManager.js.in Tue Jul 27 15:36:02 2004
+@@ -1568,9 +1568,14 @@
+
+ _checkForGlobalInstalls: function (aPath, aItemType)
+ {
++ var fPrefix = "file://";
+ // First see if the path supplied is a file path
+ var file = Components.classes["@mozilla.org/file/local;1"]
+ .createInstance(Components.interfaces.nsILocalFile);
++ if (aPath.substr(0, fPrefix.length) == fPrefix) {
++ // Strip out the file:// prefix if it exists
++ aPath = aPath.substr(fPrefix.length, aPath.length);
++ }
+ try {
+ file.initWithPath(aPath);
+ }
diff --git a/www/firefox15/Makefile b/www/firefox15/Makefile
index faee9ffb4148..5eeeb7b36085 100644
--- a/www/firefox15/Makefile
+++ b/www/firefox15/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
diff --git a/www/firefox15/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in b/www/firefox15/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
new file mode 100644
index 000000000000..feffd2c6344f
--- /dev/null
+++ b/www/firefox15/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
@@ -0,0 +1,17 @@
+--- toolkit/mozapps/extensions/src/nsExtensionManager.js.in.orig Tue Jul 27 15:35:12 2004
++++ toolkit/mozapps/extensions/src/nsExtensionManager.js.in Tue Jul 27 15:36:02 2004
+@@ -1568,9 +1568,14 @@
+
+ _checkForGlobalInstalls: function (aPath, aItemType)
+ {
++ var fPrefix = "file://";
+ // First see if the path supplied is a file path
+ var file = Components.classes["@mozilla.org/file/local;1"]
+ .createInstance(Components.interfaces.nsILocalFile);
++ if (aPath.substr(0, fPrefix.length) == fPrefix) {
++ // Strip out the file:// prefix if it exists
++ aPath = aPath.substr(fPrefix.length, aPath.length);
++ }
+ try {
+ file.initWithPath(aPath);
+ }
diff --git a/www/firefox3-devel/Makefile b/www/firefox3-devel/Makefile
index faee9ffb4148..5eeeb7b36085 100644
--- a/www/firefox3-devel/Makefile
+++ b/www/firefox3-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
diff --git a/www/firefox3-devel/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in b/www/firefox3-devel/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
new file mode 100644
index 000000000000..feffd2c6344f
--- /dev/null
+++ b/www/firefox3-devel/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
@@ -0,0 +1,17 @@
+--- toolkit/mozapps/extensions/src/nsExtensionManager.js.in.orig Tue Jul 27 15:35:12 2004
++++ toolkit/mozapps/extensions/src/nsExtensionManager.js.in Tue Jul 27 15:36:02 2004
+@@ -1568,9 +1568,14 @@
+
+ _checkForGlobalInstalls: function (aPath, aItemType)
+ {
++ var fPrefix = "file://";
+ // First see if the path supplied is a file path
+ var file = Components.classes["@mozilla.org/file/local;1"]
+ .createInstance(Components.interfaces.nsILocalFile);
++ if (aPath.substr(0, fPrefix.length) == fPrefix) {
++ // Strip out the file:// prefix if it exists
++ aPath = aPath.substr(fPrefix.length, aPath.length);
++ }
+ try {
+ file.initWithPath(aPath);
+ }
diff --git a/www/firefox35/Makefile b/www/firefox35/Makefile
index faee9ffb4148..5eeeb7b36085 100644
--- a/www/firefox35/Makefile
+++ b/www/firefox35/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
diff --git a/www/firefox35/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in b/www/firefox35/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
new file mode 100644
index 000000000000..feffd2c6344f
--- /dev/null
+++ b/www/firefox35/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
@@ -0,0 +1,17 @@
+--- toolkit/mozapps/extensions/src/nsExtensionManager.js.in.orig Tue Jul 27 15:35:12 2004
++++ toolkit/mozapps/extensions/src/nsExtensionManager.js.in Tue Jul 27 15:36:02 2004
+@@ -1568,9 +1568,14 @@
+
+ _checkForGlobalInstalls: function (aPath, aItemType)
+ {
++ var fPrefix = "file://";
+ // First see if the path supplied is a file path
+ var file = Components.classes["@mozilla.org/file/local;1"]
+ .createInstance(Components.interfaces.nsILocalFile);
++ if (aPath.substr(0, fPrefix.length) == fPrefix) {
++ // Strip out the file:// prefix if it exists
++ aPath = aPath.substr(fPrefix.length, aPath.length);
++ }
+ try {
+ file.initWithPath(aPath);
+ }
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index faee9ffb4148..5eeeb7b36085 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
diff --git a/www/firefox36/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in b/www/firefox36/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
new file mode 100644
index 000000000000..feffd2c6344f
--- /dev/null
+++ b/www/firefox36/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
@@ -0,0 +1,17 @@
+--- toolkit/mozapps/extensions/src/nsExtensionManager.js.in.orig Tue Jul 27 15:35:12 2004
++++ toolkit/mozapps/extensions/src/nsExtensionManager.js.in Tue Jul 27 15:36:02 2004
+@@ -1568,9 +1568,14 @@
+
+ _checkForGlobalInstalls: function (aPath, aItemType)
+ {
++ var fPrefix = "file://";
+ // First see if the path supplied is a file path
+ var file = Components.classes["@mozilla.org/file/local;1"]
+ .createInstance(Components.interfaces.nsILocalFile);
++ if (aPath.substr(0, fPrefix.length) == fPrefix) {
++ // Strip out the file:// prefix if it exists
++ aPath = aPath.substr(fPrefix.length, aPath.length);
++ }
+ try {
+ file.initWithPath(aPath);
+ }
diff --git a/www/flock/Makefile b/www/flock/Makefile
index faee9ffb4148..5eeeb7b36085 100644
--- a/www/flock/Makefile
+++ b/www/flock/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= ${PORTNAME}/releases/${PORTVERSION}
diff --git a/www/flock/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in b/www/flock/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
new file mode 100644
index 000000000000..feffd2c6344f
--- /dev/null
+++ b/www/flock/files/patch-toolkit_mozapps_extensions_src_nsExtensionManager.js.in
@@ -0,0 +1,17 @@
+--- toolkit/mozapps/extensions/src/nsExtensionManager.js.in.orig Tue Jul 27 15:35:12 2004
++++ toolkit/mozapps/extensions/src/nsExtensionManager.js.in Tue Jul 27 15:36:02 2004
+@@ -1568,9 +1568,14 @@
+
+ _checkForGlobalInstalls: function (aPath, aItemType)
+ {
++ var fPrefix = "file://";
+ // First see if the path supplied is a file path
+ var file = Components.classes["@mozilla.org/file/local;1"]
+ .createInstance(Components.interfaces.nsILocalFile);
++ if (aPath.substr(0, fPrefix.length) == fPrefix) {
++ // Strip out the file:// prefix if it exists
++ aPath = aPath.substr(fPrefix.length, aPath.length);
++ }
+ try {
+ file.initWithPath(aPath);
+ }