aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-Quoted/Makefile32
-rw-r--r--textproc/p5-Text-Quoted/distinfo1
-rw-r--r--textproc/p5-Text-Quoted/pkg-descr5
-rw-r--r--textproc/p5-Text-Quoted/pkg-plist4
5 files changed, 43 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index a22d7816d9ec..e98a2353708a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -228,6 +228,7 @@
SUBDIR += p5-Text-Graphics
SUBDIR += p5-Text-Metaphone
SUBDIR += p5-Text-Query
+ SUBDIR += p5-Text-Quoted
SUBDIR += p5-Text-Reflow
SUBDIR += p5-Text-Repository
SUBDIR += p5-Text-SimpleTemplate
diff --git a/textproc/p5-Text-Quoted/Makefile b/textproc/p5-Text-Quoted/Makefile
new file mode 100644
index 000000000000..78bfe7b14d7c
--- /dev/null
+++ b/textproc/p5-Text-Quoted/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Text-Quoted
+# Date created: Mon April 14th, 2003
+# Whom: Erwin Lansing <erwin@lansing.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Quoted
+PORTVERSION= 1.2
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@lansing.dk
+COMMENT= Text::Quoted - Extract the structure of a quoted mail message
+
+BUILD_DEPENDS= ${SITE_PERL}/Text/Autoformat.pm:${PORTSDIR}/textproc/p5-Text-Autoformat \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::Quoted.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Text-Quoted/distinfo b/textproc/p5-Text-Quoted/distinfo
new file mode 100644
index 000000000000..ec54f8403139
--- /dev/null
+++ b/textproc/p5-Text-Quoted/distinfo
@@ -0,0 +1 @@
+MD5 (Text-Quoted-1.2.tar.gz) = cec22ff657590d1e3dbf89ad17f3f94a
diff --git a/textproc/p5-Text-Quoted/pkg-descr b/textproc/p5-Text-Quoted/pkg-descr
new file mode 100644
index 000000000000..d6351645cc19
--- /dev/null
+++ b/textproc/p5-Text-Quoted/pkg-descr
@@ -0,0 +1,5 @@
+Text::Quoted examines the structure of some text which
+may contain multiple different levels of quoting, and
+turns the text into a nested data structure.
+
+WWW: http://search.cpan.org/dist/Text-Quoted/
diff --git a/textproc/p5-Text-Quoted/pkg-plist b/textproc/p5-Text-Quoted/pkg-plist
new file mode 100644
index 000000000000..b05e25a5112f
--- /dev/null
+++ b/textproc/p5-Text-Quoted/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/mach/auto/Text/Quoted/.packlist
+%%SITE_PERL%%/Text/Quoted.pm
+@dirrm %%SITE_PERL%%/mach/auto/Text/Quoted
+@unexec rmdir %D/%%SITE_PERL%%/Text 2>/dev/null || true