aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ftp/curl/Makefile3
-rw-r--r--ftp/curl/distinfo4
-rw-r--r--ftp/curl/files/patch-configure8
-rw-r--r--ftp/curl/files/patch-lib::hostip.c14
4 files changed, 14 insertions, 15 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index a53f0cff9640..6dd00da8d155 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= curl
-PORTVERSION= 7.11.0
-PORTREVISION= 1
+PORTVERSION= 7.11.1
CATEGORIES= ftp ipv6 www
MASTER_SITES= http://curl.haxx.se/download/ \
${MASTER_SITE_SOURCEFORGE} \
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index 437ce1638d6c..3f0cb1855263 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1,2 +1,2 @@
-MD5 (curl-7.11.0.tar.bz2) = cf511e78eb12fbb1efc6c4e0ca4e5120
-SIZE (curl-7.11.0.tar.bz2) = 1073493
+MD5 (curl-7.11.1.tar.bz2) = c2af7c3364a1a8839516f74961b6bd11
+SIZE (curl-7.11.1.tar.bz2) = 1130097
diff --git a/ftp/curl/files/patch-configure b/ftp/curl/files/patch-configure
index 47ebc57b8ef6..cdee47ca403f 100644
--- a/ftp/curl/files/patch-configure
+++ b/ftp/curl/files/patch-configure
@@ -1,11 +1,11 @@
---- configure.curl Mon Jun 24 17:23:46 2002
-+++ configure Mon Jun 24 17:24:10 2002
-@@ -9868,8 +9868,10 @@
+--- configure.orig Fri Apr 9 14:00:52 2004
++++ configure Fri Apr 9 14:01:29 2004
+@@ -24123,8 +24123,10 @@
EXTRA_SSL= ;;
*)
EXTRA_SSL=$OPT_SSL
+ if [ ! "$EXTRA_SSL" = "/usr" ]; then
- LDFLAGS="$LDFLAGS -L$EXTRA_SSL/lib"
+ LDFLAGS="$LDFLAGS -L$EXTRA_SSL/lib$libsuff"
CPPFLAGS="$CPPFLAGS -I$EXTRA_SSL/include/openssl -I$EXTRA_SSL/include"
+ fi
;;
diff --git a/ftp/curl/files/patch-lib::hostip.c b/ftp/curl/files/patch-lib::hostip.c
index d913c91b37e4..4c15c91a7222 100644
--- a/ftp/curl/files/patch-lib::hostip.c
+++ b/ftp/curl/files/patch-lib::hostip.c
@@ -1,16 +1,16 @@
---- lib/hostip.c.orig Tue May 13 05:12:17 2003
-+++ lib/hostip.c Sun Jun 15 18:44:13 2003
-@@ -497,11 +497,11 @@
+--- lib/hostip.c.orig Fri Apr 9 14:28:07 2004
++++ lib/hostip.c Fri Apr 9 14:29:12 2004
+@@ -887,11 +887,11 @@
/* now, shrink the allocated buffer to the size we actually need, which
most often is only a fraction of the original alloc */
-- newbuf=(char *)realloc(*buf, (int)bufptr-(int)(*buf));
-+ newbuf=(char *)realloc(*buf, (int)(bufptr-*buf));
+- newbuf=(char *)realloc(*buf, (long)bufptr-(long)(*buf));
++ newbuf=(char *)realloc(*buf, (long)(bufptr-*buf));
/* if the alloc moved, we need to adjust things again */
if(newbuf != *buf)
-- hostcache_fixoffset((struct hostent*)newbuf, (int)newbuf-(int)*buf);
-+ hostcache_fixoffset((struct hostent*)newbuf, (int)(newbuf-*buf));
+- hostcache_fixoffset((struct hostent*)newbuf, (long)newbuf-(long)*buf);
++ hostcache_fixoffset((struct hostent*)newbuf, (long)(newbuf-*buf));
/* setup the return */
*buf = newbuf;