aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/mule-common/Makefile45
-rw-r--r--editors/mule-common/files/dir39
-rw-r--r--editors/mule-common/pkg-comment1
-rw-r--r--editors/mule-common/pkg-descr19
-rw-r--r--editors/mule-common/pkg-plist29
-rw-r--r--editors/mule/Makefile45
-rw-r--r--editors/mule/pkg-comment1
-rw-r--r--editors/mule/pkg-descr19
-rw-r--r--editors/mule/pkg-plist29
-rw-r--r--japanese/mule-canna/Makefile45
-rw-r--r--japanese/mule-canna/pkg-comment1
-rw-r--r--japanese/mule-canna/pkg-descr19
-rw-r--r--japanese/mule-freewnn/Makefile45
-rw-r--r--japanese/mule-freewnn/pkg-comment1
-rw-r--r--japanese/mule-freewnn/pkg-descr19
-rw-r--r--japanese/mule-wnn6/Makefile45
-rw-r--r--japanese/mule-wnn6/pkg-comment1
-rw-r--r--japanese/mule-wnn6/pkg-descr19
-rw-r--r--japanese/mule-wnn7/Makefile45
-rw-r--r--japanese/mule-wnn7/pkg-comment1
-rw-r--r--japanese/mule-wnn7/pkg-descr19
-rw-r--r--textproc/coco/Makefile45
-rw-r--r--textproc/coco/files/dir39
-rw-r--r--textproc/coco/pkg-comment1
-rw-r--r--textproc/coco/pkg-descr19
-rw-r--r--textproc/coco/pkg-plist29
26 files changed, 620 insertions, 0 deletions
diff --git a/editors/mule-common/Makefile b/editors/mule-common/Makefile
new file mode 100644
index 000000000000..613504736343
--- /dev/null
+++ b/editors/mule-common/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: mule
+# Version required: 2.1
+# Date created: 22 November 1994
+# Whom: Satoshi Asami (asami)
+#
+# $Id: $
+#
+
+DISTNAME= mule-2.1
+DISTFILES= emacs-19.27.tar.gz
+MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
+ --wnn --wnn-libraries=/usr/X11R6/lib \
+ --wnn-includes=/usr/X11R6/include/wnn --terminal-face
+WRKSRC= ${WRKDIR}/emacs-19.27
+PATCHFILES= diff-19.27-2.1.gz
+PATCHSITE= sh.wide.ad.jp:/JAPAN/mule/
+DEPENDS= ${PORTSDIR}/utils/Wnn
+
+pre-fetch:
+ @if [ ! -d ${DISTDIR} ]; then mkdir -p ${DISTDIR}; fi
+ @for file in ${PATCHFILES}; do \
+ if [ ! -f ${DISTDIR}/$$file ]; then \
+ echo ">> Fetching patch $$file from remote site..."; \
+ ${NCFTP} ${NCFTPFLAGS} ${PATCHSITE}$$file \
+ && mv $$file ${DISTDIR}; \
+ fi \
+ done
+
+pre-patch:
+ /bin/rm -f ${WRKSRC}/src/unexsunos4.c ${WRKSRC}/src/s/freebsd.h
+# I took these two files from emacs-19.28 and added -lcrypt
+ cp ${FILESDIR}/unexsunos4.c ${WRKSRC}/src
+ cp ${FILESDIR}/freebsd.h ${WRKSRC}/src/s
+ @echo "===> Applying emacs -> mule patch"
+ @for file in ${PATCHFILES}; do \
+ gzip -c -d ${DISTDIR}/$$file | patch -d ${WRKSRC} -p1 -s; \
+ done
+
+pre-build:
+ find ${WRKSRC} -name \*.orig -exec /bin/rm -f \{} \;
+
+.include <bsd.port.mk>
diff --git a/editors/mule-common/files/dir b/editors/mule-common/files/dir
new file mode 100644
index 000000000000..8478445ba8a7
--- /dev/null
+++ b/editors/mule-common/files/dir
@@ -0,0 +1,39 @@
+-*- Text -*-
+This is the file .../info/dir, which contains the topmost node of the
+Info hierarchy. The first time you invoke Info you start off
+looking at that node, which is (dir)Top.
+
+File: dir Node: Top This is the top of the INFO tree
+ This (the Directory node) gives a menu of major topics.
+ Typing "d" returns here, "q" exits, "?" lists all INFO commands, "h"
+ gives a primer for first-timers, "mTexinfo<Return>" visits Texinfo topic,
+ etc.
+ Or click mouse button 2 on a menu item or cross reference to select it.
+ --- PLEASE ADD DOCUMENTATION TO THIS TREE. (See INFO topic first.) ---
+
+* Menu: The list of major topics begins on the next line.
+
+* Info: (info). Documentation browsing system.
+* Emacs: (emacs). The extensible self-documenting text editor.
+* VIP: (vip). A VI-emulation for Emacs.
+* Forms: (forms). Emacs package for editing data bases
+ by filling in forms.
+* GNUS: (gnus). The news reader GNUS.
+* CL: (cl). Partial Common Lisp support for Emacs Lisp.
+* SC: (sc). Supercite lets you cite parts of messages you're
+ replying to, in hairy ways.
+* Dired-X: (dired-x). Dired Extra Features.
+
+ MULE
+
+* Antenews-jp: (antenews-jp). (japanese).
+* Canna-jp: (canna-jp). Kana to Kanji translation (japanese).
+* Egg: (egg). Japanese/Chinese inputting.
+* Egg-jp: (egg-jp). Japanese/Chinese inputting (japanese).
+* Kbd-trans: (kbd-trans). Redefining keyboard layout for languages.
+* Languages: (languages). Using Asian and European languages under Mule.
+* M2PS: (m2ps). Translating Multi-language docs to postscript.
+* Mule: (mule). Mule (v2.1).
+* Mule-jp: (mule-jp). Mule (v2.1) (japanese).
+* Quail: (quail). Multilanguage inputting.
+* Terminology: (terminology). Overview of multilanguage inputting methods.
diff --git a/editors/mule-common/pkg-comment b/editors/mule-common/pkg-comment
new file mode 100644
index 000000000000..a5e877d4bcae
--- /dev/null
+++ b/editors/mule-common/pkg-comment
@@ -0,0 +1 @@
+mule-2.1, a multilingual emacs
diff --git a/editors/mule-common/pkg-descr b/editors/mule-common/pkg-descr
new file mode 100644
index 000000000000..31dcabd5deb9
--- /dev/null
+++ b/editors/mule-common/pkg-descr
@@ -0,0 +1,19 @@
+This is mule-2.1, a multilingual editor based on emacs-19.27.
+
+This package is built with Japanese support, using Wnn, as default. I
+don't use other language/input methods. People are welcome to test
+other configurations and report their results.
+
+This package is designed *not* to clobber any existing emacs
+installation. In particular, the executables and man pages of
+etags/ctags are not installed, and the info pages that come with the
+original emacs don't get installed too. Remove the file
+patches/patch-ab if you want this package to stand on its own.
+
+A "dir" file is supplied in the files/ subdirectory of the ports
+package. Copy it into your /usr/local/info to read mule info pages,
+but also make sure you also add everything that may have been added to
+that file!
+
+- Satoshi
+asami@cs.berkeley.edu
diff --git a/editors/mule-common/pkg-plist b/editors/mule-common/pkg-plist
new file mode 100644
index 000000000000..ead1e59ed12a
--- /dev/null
+++ b/editors/mule-common/pkg-plist
@@ -0,0 +1,29 @@
+@cwd /usr/local
+@exec mkdir -p %D/lib/mule/site-lisp
+@exec mkdir -p %D/lib/mule/lock
+@exec chmod 777 %D/lib/mule/lock
+bin/mule
+bin/m2ps
+lib/mule/19.27
+man/man1/mule.1
+man/man1/m2ps.1
+info/CCL
+info/ISO2022
+info/R2L
+info/XFONT
+info/antenews-jp
+info/canna-jp
+info/egg
+info/egg-jp
+info/egg-jp-1
+info/egg-jp-2
+info/kbd-trans
+info/languages
+info/m2ps
+info/mule
+info/mule-jp
+info/mule-jp-1
+info/mule-jp-2
+info/mule-jp-3
+info/quail
+info/terminology
diff --git a/editors/mule/Makefile b/editors/mule/Makefile
new file mode 100644
index 000000000000..613504736343
--- /dev/null
+++ b/editors/mule/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: mule
+# Version required: 2.1
+# Date created: 22 November 1994
+# Whom: Satoshi Asami (asami)
+#
+# $Id: $
+#
+
+DISTNAME= mule-2.1
+DISTFILES= emacs-19.27.tar.gz
+MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
+ --wnn --wnn-libraries=/usr/X11R6/lib \
+ --wnn-includes=/usr/X11R6/include/wnn --terminal-face
+WRKSRC= ${WRKDIR}/emacs-19.27
+PATCHFILES= diff-19.27-2.1.gz
+PATCHSITE= sh.wide.ad.jp:/JAPAN/mule/
+DEPENDS= ${PORTSDIR}/utils/Wnn
+
+pre-fetch:
+ @if [ ! -d ${DISTDIR} ]; then mkdir -p ${DISTDIR}; fi
+ @for file in ${PATCHFILES}; do \
+ if [ ! -f ${DISTDIR}/$$file ]; then \
+ echo ">> Fetching patch $$file from remote site..."; \
+ ${NCFTP} ${NCFTPFLAGS} ${PATCHSITE}$$file \
+ && mv $$file ${DISTDIR}; \
+ fi \
+ done
+
+pre-patch:
+ /bin/rm -f ${WRKSRC}/src/unexsunos4.c ${WRKSRC}/src/s/freebsd.h
+# I took these two files from emacs-19.28 and added -lcrypt
+ cp ${FILESDIR}/unexsunos4.c ${WRKSRC}/src
+ cp ${FILESDIR}/freebsd.h ${WRKSRC}/src/s
+ @echo "===> Applying emacs -> mule patch"
+ @for file in ${PATCHFILES}; do \
+ gzip -c -d ${DISTDIR}/$$file | patch -d ${WRKSRC} -p1 -s; \
+ done
+
+pre-build:
+ find ${WRKSRC} -name \*.orig -exec /bin/rm -f \{} \;
+
+.include <bsd.port.mk>
diff --git a/editors/mule/pkg-comment b/editors/mule/pkg-comment
new file mode 100644
index 000000000000..a5e877d4bcae
--- /dev/null
+++ b/editors/mule/pkg-comment
@@ -0,0 +1 @@
+mule-2.1, a multilingual emacs
diff --git a/editors/mule/pkg-descr b/editors/mule/pkg-descr
new file mode 100644
index 000000000000..31dcabd5deb9
--- /dev/null
+++ b/editors/mule/pkg-descr
@@ -0,0 +1,19 @@
+This is mule-2.1, a multilingual editor based on emacs-19.27.
+
+This package is built with Japanese support, using Wnn, as default. I
+don't use other language/input methods. People are welcome to test
+other configurations and report their results.
+
+This package is designed *not* to clobber any existing emacs
+installation. In particular, the executables and man pages of
+etags/ctags are not installed, and the info pages that come with the
+original emacs don't get installed too. Remove the file
+patches/patch-ab if you want this package to stand on its own.
+
+A "dir" file is supplied in the files/ subdirectory of the ports
+package. Copy it into your /usr/local/info to read mule info pages,
+but also make sure you also add everything that may have been added to
+that file!
+
+- Satoshi
+asami@cs.berkeley.edu
diff --git a/editors/mule/pkg-plist b/editors/mule/pkg-plist
new file mode 100644
index 000000000000..ead1e59ed12a
--- /dev/null
+++ b/editors/mule/pkg-plist
@@ -0,0 +1,29 @@
+@cwd /usr/local
+@exec mkdir -p %D/lib/mule/site-lisp
+@exec mkdir -p %D/lib/mule/lock
+@exec chmod 777 %D/lib/mule/lock
+bin/mule
+bin/m2ps
+lib/mule/19.27
+man/man1/mule.1
+man/man1/m2ps.1
+info/CCL
+info/ISO2022
+info/R2L
+info/XFONT
+info/antenews-jp
+info/canna-jp
+info/egg
+info/egg-jp
+info/egg-jp-1
+info/egg-jp-2
+info/kbd-trans
+info/languages
+info/m2ps
+info/mule
+info/mule-jp
+info/mule-jp-1
+info/mule-jp-2
+info/mule-jp-3
+info/quail
+info/terminology
diff --git a/japanese/mule-canna/Makefile b/japanese/mule-canna/Makefile
new file mode 100644
index 000000000000..613504736343
--- /dev/null
+++ b/japanese/mule-canna/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: mule
+# Version required: 2.1
+# Date created: 22 November 1994
+# Whom: Satoshi Asami (asami)
+#
+# $Id: $
+#
+
+DISTNAME= mule-2.1
+DISTFILES= emacs-19.27.tar.gz
+MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
+ --wnn --wnn-libraries=/usr/X11R6/lib \
+ --wnn-includes=/usr/X11R6/include/wnn --terminal-face
+WRKSRC= ${WRKDIR}/emacs-19.27
+PATCHFILES= diff-19.27-2.1.gz
+PATCHSITE= sh.wide.ad.jp:/JAPAN/mule/
+DEPENDS= ${PORTSDIR}/utils/Wnn
+
+pre-fetch:
+ @if [ ! -d ${DISTDIR} ]; then mkdir -p ${DISTDIR}; fi
+ @for file in ${PATCHFILES}; do \
+ if [ ! -f ${DISTDIR}/$$file ]; then \
+ echo ">> Fetching patch $$file from remote site..."; \
+ ${NCFTP} ${NCFTPFLAGS} ${PATCHSITE}$$file \
+ && mv $$file ${DISTDIR}; \
+ fi \
+ done
+
+pre-patch:
+ /bin/rm -f ${WRKSRC}/src/unexsunos4.c ${WRKSRC}/src/s/freebsd.h
+# I took these two files from emacs-19.28 and added -lcrypt
+ cp ${FILESDIR}/unexsunos4.c ${WRKSRC}/src
+ cp ${FILESDIR}/freebsd.h ${WRKSRC}/src/s
+ @echo "===> Applying emacs -> mule patch"
+ @for file in ${PATCHFILES}; do \
+ gzip -c -d ${DISTDIR}/$$file | patch -d ${WRKSRC} -p1 -s; \
+ done
+
+pre-build:
+ find ${WRKSRC} -name \*.orig -exec /bin/rm -f \{} \;
+
+.include <bsd.port.mk>
diff --git a/japanese/mule-canna/pkg-comment b/japanese/mule-canna/pkg-comment
new file mode 100644
index 000000000000..a5e877d4bcae
--- /dev/null
+++ b/japanese/mule-canna/pkg-comment
@@ -0,0 +1 @@
+mule-2.1, a multilingual emacs
diff --git a/japanese/mule-canna/pkg-descr b/japanese/mule-canna/pkg-descr
new file mode 100644
index 000000000000..31dcabd5deb9
--- /dev/null
+++ b/japanese/mule-canna/pkg-descr
@@ -0,0 +1,19 @@
+This is mule-2.1, a multilingual editor based on emacs-19.27.
+
+This package is built with Japanese support, using Wnn, as default. I
+don't use other language/input methods. People are welcome to test
+other configurations and report their results.
+
+This package is designed *not* to clobber any existing emacs
+installation. In particular, the executables and man pages of
+etags/ctags are not installed, and the info pages that come with the
+original emacs don't get installed too. Remove the file
+patches/patch-ab if you want this package to stand on its own.
+
+A "dir" file is supplied in the files/ subdirectory of the ports
+package. Copy it into your /usr/local/info to read mule info pages,
+but also make sure you also add everything that may have been added to
+that file!
+
+- Satoshi
+asami@cs.berkeley.edu
diff --git a/japanese/mule-freewnn/Makefile b/japanese/mule-freewnn/Makefile
new file mode 100644
index 000000000000..613504736343
--- /dev/null
+++ b/japanese/mule-freewnn/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: mule
+# Version required: 2.1
+# Date created: 22 November 1994
+# Whom: Satoshi Asami (asami)
+#
+# $Id: $
+#
+
+DISTNAME= mule-2.1
+DISTFILES= emacs-19.27.tar.gz
+MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
+ --wnn --wnn-libraries=/usr/X11R6/lib \
+ --wnn-includes=/usr/X11R6/include/wnn --terminal-face
+WRKSRC= ${WRKDIR}/emacs-19.27
+PATCHFILES= diff-19.27-2.1.gz
+PATCHSITE= sh.wide.ad.jp:/JAPAN/mule/
+DEPENDS= ${PORTSDIR}/utils/Wnn
+
+pre-fetch:
+ @if [ ! -d ${DISTDIR} ]; then mkdir -p ${DISTDIR}; fi
+ @for file in ${PATCHFILES}; do \
+ if [ ! -f ${DISTDIR}/$$file ]; then \
+ echo ">> Fetching patch $$file from remote site..."; \
+ ${NCFTP} ${NCFTPFLAGS} ${PATCHSITE}$$file \
+ && mv $$file ${DISTDIR}; \
+ fi \
+ done
+
+pre-patch:
+ /bin/rm -f ${WRKSRC}/src/unexsunos4.c ${WRKSRC}/src/s/freebsd.h
+# I took these two files from emacs-19.28 and added -lcrypt
+ cp ${FILESDIR}/unexsunos4.c ${WRKSRC}/src
+ cp ${FILESDIR}/freebsd.h ${WRKSRC}/src/s
+ @echo "===> Applying emacs -> mule patch"
+ @for file in ${PATCHFILES}; do \
+ gzip -c -d ${DISTDIR}/$$file | patch -d ${WRKSRC} -p1 -s; \
+ done
+
+pre-build:
+ find ${WRKSRC} -name \*.orig -exec /bin/rm -f \{} \;
+
+.include <bsd.port.mk>
diff --git a/japanese/mule-freewnn/pkg-comment b/japanese/mule-freewnn/pkg-comment
new file mode 100644
index 000000000000..a5e877d4bcae
--- /dev/null
+++ b/japanese/mule-freewnn/pkg-comment
@@ -0,0 +1 @@
+mule-2.1, a multilingual emacs
diff --git a/japanese/mule-freewnn/pkg-descr b/japanese/mule-freewnn/pkg-descr
new file mode 100644
index 000000000000..31dcabd5deb9
--- /dev/null
+++ b/japanese/mule-freewnn/pkg-descr
@@ -0,0 +1,19 @@
+This is mule-2.1, a multilingual editor based on emacs-19.27.
+
+This package is built with Japanese support, using Wnn, as default. I
+don't use other language/input methods. People are welcome to test
+other configurations and report their results.
+
+This package is designed *not* to clobber any existing emacs
+installation. In particular, the executables and man pages of
+etags/ctags are not installed, and the info pages that come with the
+original emacs don't get installed too. Remove the file
+patches/patch-ab if you want this package to stand on its own.
+
+A "dir" file is supplied in the files/ subdirectory of the ports
+package. Copy it into your /usr/local/info to read mule info pages,
+but also make sure you also add everything that may have been added to
+that file!
+
+- Satoshi
+asami@cs.berkeley.edu
diff --git a/japanese/mule-wnn6/Makefile b/japanese/mule-wnn6/Makefile
new file mode 100644
index 000000000000..613504736343
--- /dev/null
+++ b/japanese/mule-wnn6/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: mule
+# Version required: 2.1
+# Date created: 22 November 1994
+# Whom: Satoshi Asami (asami)
+#
+# $Id: $
+#
+
+DISTNAME= mule-2.1
+DISTFILES= emacs-19.27.tar.gz
+MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
+ --wnn --wnn-libraries=/usr/X11R6/lib \
+ --wnn-includes=/usr/X11R6/include/wnn --terminal-face
+WRKSRC= ${WRKDIR}/emacs-19.27
+PATCHFILES= diff-19.27-2.1.gz
+PATCHSITE= sh.wide.ad.jp:/JAPAN/mule/
+DEPENDS= ${PORTSDIR}/utils/Wnn
+
+pre-fetch:
+ @if [ ! -d ${DISTDIR} ]; then mkdir -p ${DISTDIR}; fi
+ @for file in ${PATCHFILES}; do \
+ if [ ! -f ${DISTDIR}/$$file ]; then \
+ echo ">> Fetching patch $$file from remote site..."; \
+ ${NCFTP} ${NCFTPFLAGS} ${PATCHSITE}$$file \
+ && mv $$file ${DISTDIR}; \
+ fi \
+ done
+
+pre-patch:
+ /bin/rm -f ${WRKSRC}/src/unexsunos4.c ${WRKSRC}/src/s/freebsd.h
+# I took these two files from emacs-19.28 and added -lcrypt
+ cp ${FILESDIR}/unexsunos4.c ${WRKSRC}/src
+ cp ${FILESDIR}/freebsd.h ${WRKSRC}/src/s
+ @echo "===> Applying emacs -> mule patch"
+ @for file in ${PATCHFILES}; do \
+ gzip -c -d ${DISTDIR}/$$file | patch -d ${WRKSRC} -p1 -s; \
+ done
+
+pre-build:
+ find ${WRKSRC} -name \*.orig -exec /bin/rm -f \{} \;
+
+.include <bsd.port.mk>
diff --git a/japanese/mule-wnn6/pkg-comment b/japanese/mule-wnn6/pkg-comment
new file mode 100644
index 000000000000..a5e877d4bcae
--- /dev/null
+++ b/japanese/mule-wnn6/pkg-comment
@@ -0,0 +1 @@
+mule-2.1, a multilingual emacs
diff --git a/japanese/mule-wnn6/pkg-descr b/japanese/mule-wnn6/pkg-descr
new file mode 100644
index 000000000000..31dcabd5deb9
--- /dev/null
+++ b/japanese/mule-wnn6/pkg-descr
@@ -0,0 +1,19 @@
+This is mule-2.1, a multilingual editor based on emacs-19.27.
+
+This package is built with Japanese support, using Wnn, as default. I
+don't use other language/input methods. People are welcome to test
+other configurations and report their results.
+
+This package is designed *not* to clobber any existing emacs
+installation. In particular, the executables and man pages of
+etags/ctags are not installed, and the info pages that come with the
+original emacs don't get installed too. Remove the file
+patches/patch-ab if you want this package to stand on its own.
+
+A "dir" file is supplied in the files/ subdirectory of the ports
+package. Copy it into your /usr/local/info to read mule info pages,
+but also make sure you also add everything that may have been added to
+that file!
+
+- Satoshi
+asami@cs.berkeley.edu
diff --git a/japanese/mule-wnn7/Makefile b/japanese/mule-wnn7/Makefile
new file mode 100644
index 000000000000..613504736343
--- /dev/null
+++ b/japanese/mule-wnn7/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: mule
+# Version required: 2.1
+# Date created: 22 November 1994
+# Whom: Satoshi Asami (asami)
+#
+# $Id: $
+#
+
+DISTNAME= mule-2.1
+DISTFILES= emacs-19.27.tar.gz
+MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
+ --wnn --wnn-libraries=/usr/X11R6/lib \
+ --wnn-includes=/usr/X11R6/include/wnn --terminal-face
+WRKSRC= ${WRKDIR}/emacs-19.27
+PATCHFILES= diff-19.27-2.1.gz
+PATCHSITE= sh.wide.ad.jp:/JAPAN/mule/
+DEPENDS= ${PORTSDIR}/utils/Wnn
+
+pre-fetch:
+ @if [ ! -d ${DISTDIR} ]; then mkdir -p ${DISTDIR}; fi
+ @for file in ${PATCHFILES}; do \
+ if [ ! -f ${DISTDIR}/$$file ]; then \
+ echo ">> Fetching patch $$file from remote site..."; \
+ ${NCFTP} ${NCFTPFLAGS} ${PATCHSITE}$$file \
+ && mv $$file ${DISTDIR}; \
+ fi \
+ done
+
+pre-patch:
+ /bin/rm -f ${WRKSRC}/src/unexsunos4.c ${WRKSRC}/src/s/freebsd.h
+# I took these two files from emacs-19.28 and added -lcrypt
+ cp ${FILESDIR}/unexsunos4.c ${WRKSRC}/src
+ cp ${FILESDIR}/freebsd.h ${WRKSRC}/src/s
+ @echo "===> Applying emacs -> mule patch"
+ @for file in ${PATCHFILES}; do \
+ gzip -c -d ${DISTDIR}/$$file | patch -d ${WRKSRC} -p1 -s; \
+ done
+
+pre-build:
+ find ${WRKSRC} -name \*.orig -exec /bin/rm -f \{} \;
+
+.include <bsd.port.mk>
diff --git a/japanese/mule-wnn7/pkg-comment b/japanese/mule-wnn7/pkg-comment
new file mode 100644
index 000000000000..a5e877d4bcae
--- /dev/null
+++ b/japanese/mule-wnn7/pkg-comment
@@ -0,0 +1 @@
+mule-2.1, a multilingual emacs
diff --git a/japanese/mule-wnn7/pkg-descr b/japanese/mule-wnn7/pkg-descr
new file mode 100644
index 000000000000..31dcabd5deb9
--- /dev/null
+++ b/japanese/mule-wnn7/pkg-descr
@@ -0,0 +1,19 @@
+This is mule-2.1, a multilingual editor based on emacs-19.27.
+
+This package is built with Japanese support, using Wnn, as default. I
+don't use other language/input methods. People are welcome to test
+other configurations and report their results.
+
+This package is designed *not* to clobber any existing emacs
+installation. In particular, the executables and man pages of
+etags/ctags are not installed, and the info pages that come with the
+original emacs don't get installed too. Remove the file
+patches/patch-ab if you want this package to stand on its own.
+
+A "dir" file is supplied in the files/ subdirectory of the ports
+package. Copy it into your /usr/local/info to read mule info pages,
+but also make sure you also add everything that may have been added to
+that file!
+
+- Satoshi
+asami@cs.berkeley.edu
diff --git a/textproc/coco/Makefile b/textproc/coco/Makefile
new file mode 100644
index 000000000000..613504736343
--- /dev/null
+++ b/textproc/coco/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: mule
+# Version required: 2.1
+# Date created: 22 November 1994
+# Whom: Satoshi Asami (asami)
+#
+# $Id: $
+#
+
+DISTNAME= mule-2.1
+DISTFILES= emacs-19.27.tar.gz
+MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
+ --wnn --wnn-libraries=/usr/X11R6/lib \
+ --wnn-includes=/usr/X11R6/include/wnn --terminal-face
+WRKSRC= ${WRKDIR}/emacs-19.27
+PATCHFILES= diff-19.27-2.1.gz
+PATCHSITE= sh.wide.ad.jp:/JAPAN/mule/
+DEPENDS= ${PORTSDIR}/utils/Wnn
+
+pre-fetch:
+ @if [ ! -d ${DISTDIR} ]; then mkdir -p ${DISTDIR}; fi
+ @for file in ${PATCHFILES}; do \
+ if [ ! -f ${DISTDIR}/$$file ]; then \
+ echo ">> Fetching patch $$file from remote site..."; \
+ ${NCFTP} ${NCFTPFLAGS} ${PATCHSITE}$$file \
+ && mv $$file ${DISTDIR}; \
+ fi \
+ done
+
+pre-patch:
+ /bin/rm -f ${WRKSRC}/src/unexsunos4.c ${WRKSRC}/src/s/freebsd.h
+# I took these two files from emacs-19.28 and added -lcrypt
+ cp ${FILESDIR}/unexsunos4.c ${WRKSRC}/src
+ cp ${FILESDIR}/freebsd.h ${WRKSRC}/src/s
+ @echo "===> Applying emacs -> mule patch"
+ @for file in ${PATCHFILES}; do \
+ gzip -c -d ${DISTDIR}/$$file | patch -d ${WRKSRC} -p1 -s; \
+ done
+
+pre-build:
+ find ${WRKSRC} -name \*.orig -exec /bin/rm -f \{} \;
+
+.include <bsd.port.mk>
diff --git a/textproc/coco/files/dir b/textproc/coco/files/dir
new file mode 100644
index 000000000000..8478445ba8a7
--- /dev/null
+++ b/textproc/coco/files/dir
@@ -0,0 +1,39 @@
+-*- Text -*-
+This is the file .../info/dir, which contains the topmost node of the
+Info hierarchy. The first time you invoke Info you start off
+looking at that node, which is (dir)Top.
+
+File: dir Node: Top This is the top of the INFO tree
+ This (the Directory node) gives a menu of major topics.
+ Typing "d" returns here, "q" exits, "?" lists all INFO commands, "h"
+ gives a primer for first-timers, "mTexinfo<Return>" visits Texinfo topic,
+ etc.
+ Or click mouse button 2 on a menu item or cross reference to select it.
+ --- PLEASE ADD DOCUMENTATION TO THIS TREE. (See INFO topic first.) ---
+
+* Menu: The list of major topics begins on the next line.
+
+* Info: (info). Documentation browsing system.
+* Emacs: (emacs). The extensible self-documenting text editor.
+* VIP: (vip). A VI-emulation for Emacs.
+* Forms: (forms). Emacs package for editing data bases
+ by filling in forms.
+* GNUS: (gnus). The news reader GNUS.
+* CL: (cl). Partial Common Lisp support for Emacs Lisp.
+* SC: (sc). Supercite lets you cite parts of messages you're
+ replying to, in hairy ways.
+* Dired-X: (dired-x). Dired Extra Features.
+
+ MULE
+
+* Antenews-jp: (antenews-jp). (japanese).
+* Canna-jp: (canna-jp). Kana to Kanji translation (japanese).
+* Egg: (egg). Japanese/Chinese inputting.
+* Egg-jp: (egg-jp). Japanese/Chinese inputting (japanese).
+* Kbd-trans: (kbd-trans). Redefining keyboard layout for languages.
+* Languages: (languages). Using Asian and European languages under Mule.
+* M2PS: (m2ps). Translating Multi-language docs to postscript.
+* Mule: (mule). Mule (v2.1).
+* Mule-jp: (mule-jp). Mule (v2.1) (japanese).
+* Quail: (quail). Multilanguage inputting.
+* Terminology: (terminology). Overview of multilanguage inputting methods.
diff --git a/textproc/coco/pkg-comment b/textproc/coco/pkg-comment
new file mode 100644
index 000000000000..a5e877d4bcae
--- /dev/null
+++ b/textproc/coco/pkg-comment
@@ -0,0 +1 @@
+mule-2.1, a multilingual emacs
diff --git a/textproc/coco/pkg-descr b/textproc/coco/pkg-descr
new file mode 100644
index 000000000000..31dcabd5deb9
--- /dev/null
+++ b/textproc/coco/pkg-descr
@@ -0,0 +1,19 @@
+This is mule-2.1, a multilingual editor based on emacs-19.27.
+
+This package is built with Japanese support, using Wnn, as default. I
+don't use other language/input methods. People are welcome to test
+other configurations and report their results.
+
+This package is designed *not* to clobber any existing emacs
+installation. In particular, the executables and man pages of
+etags/ctags are not installed, and the info pages that come with the
+original emacs don't get installed too. Remove the file
+patches/patch-ab if you want this package to stand on its own.
+
+A "dir" file is supplied in the files/ subdirectory of the ports
+package. Copy it into your /usr/local/info to read mule info pages,
+but also make sure you also add everything that may have been added to
+that file!
+
+- Satoshi
+asami@cs.berkeley.edu
diff --git a/textproc/coco/pkg-plist b/textproc/coco/pkg-plist
new file mode 100644
index 000000000000..ead1e59ed12a
--- /dev/null
+++ b/textproc/coco/pkg-plist
@@ -0,0 +1,29 @@
+@cwd /usr/local
+@exec mkdir -p %D/lib/mule/site-lisp
+@exec mkdir -p %D/lib/mule/lock
+@exec chmod 777 %D/lib/mule/lock
+bin/mule
+bin/m2ps
+lib/mule/19.27
+man/man1/mule.1
+man/man1/m2ps.1
+info/CCL
+info/ISO2022
+info/R2L
+info/XFONT
+info/antenews-jp
+info/canna-jp
+info/egg
+info/egg-jp
+info/egg-jp-1
+info/egg-jp-2
+info/kbd-trans
+info/languages
+info/m2ps
+info/mule
+info/mule-jp
+info/mule-jp-1
+info/mule-jp-2
+info/mule-jp-3
+info/quail
+info/terminology