aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile2
-rw-r--r--www/netscape48-communicator/Makefile141
-rw-r--r--www/netscape48-communicator/distinfo14
-rw-r--r--www/netscape48-communicator/pkg-descr2
-rw-r--r--www/netscape48-communicator/pkg-plist223
-rw-r--r--www/netscape48-communicator/pkg-req.aout35
-rw-r--r--www/netscape48-navigator/Makefile14
-rw-r--r--www/netscape48-navigator/pkg-comment1
-rw-r--r--www/netscape48-navigator/pkg-plist158
9 files changed, 345 insertions, 245 deletions
diff --git a/www/Makefile b/www/Makefile
index 6ac1fdf46a94..c8021837a24d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -220,6 +220,8 @@
SUBDIR += netscape4-navigator
SUBDIR += netscape47-communicator
SUBDIR += netscape47-navigator
+ SUBDIR += netscape48-communicator
+ SUBDIR += netscape48-navigator
SUBDIR += netscape7
SUBDIR += npc
SUBDIR += nscache
diff --git a/www/netscape48-communicator/Makefile b/www/netscape48-communicator/Makefile
index 0124b6a90326..14545ed3db84 100644
--- a/www/netscape48-communicator/Makefile
+++ b/www/netscape48-communicator/Makefile
@@ -5,80 +5,70 @@
# $FreeBSD$
#
-PORTNAME?= netscape-${BROWSER_ARC}
-PORTVERSION?= ${BROWSER_VER}
-CATEGORIES?= www
-MASTER_SITES?= ftp://ftp.netscape.com/pub/communicator/4.08/english/unix/unsupported/freebsd/professional_edition/
-DISTFILES?= communicator-v408-export.x86-unknown-freebsd.tar.gz
-
-MAINTAINER?= sada@FreeBSD.org
+PORTNAME?= linux-netscape-${BROWSER_NAME}
+PORTVERSION= ${BROWSER_VER}
+CATEGORIES= www linux
+MASTER_SITES= ftp://ftp.netscape.com/pub/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.bu.edu/pub/mirrors/ftp.netscape.com/pub/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.cuhk.edu.hk/pub/www/netscape/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.spin.ad.jp/pub/WWW/netscape/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://sunsite.tus.ac.jp/pub/archives/WWW/netscape/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.kmitl.ac.th/pub/netscape/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.tuwien.ac.at/z134/infosys/browsers/netscape/pub/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.euronet.be/pub/mirror/ftp.netscape.com/pub/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://sunsite.cnlab-switch.ch/mirror/netscape/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.uni-heidelberg.de/pub/Netscape/pub/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.darenet.dk/mirrors/ftp2.netscape.com/pub/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.cica.es/pub5/netscape/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.calvacom.fr/pub1/browser/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.ciril.fr/pub1/netscape/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.uniroma2.it/Netscape/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.nluug.nl/vol/2/netscape/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.ntnu.no/pub/www/Netscape/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://sunsite.uio.no/pub/network/web/netscape/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.man.poznan.pl/vols/vol1/netscape/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.sunet.se/pub/www/Netscape/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.uakom.sk/pub/WWW/Netscape/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.hi.is/pub/mirrors/ftp.netscape.com/pub/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.unicamp.br/pub6/netscape/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.mox.uniandes.edu.co/pub/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.nsu.ru/pub/mirrors/ftp-de.netscape.com/pub/${NETSCAPE_DIST_SUBDIR}/ \
+ ftp://ftp.curtin.edu.au/pub/internet/netscape/${NETSCAPE_DIST_SUBDIR}/
+DISTFILES= ${BROWSER_NAME}-v${BROWSER_V}-us.${NETSCAPE_DIST_TAG}.tar.gz
+
+MAINTAINER= sada@FreeBSD.org
RUN_DEPENDS+= netscape:${PORTSDIR}/www/netscape-wrapper
-.if (!defined(BROWSER_VER) || ${PORTVERSION} == "4.76")
-FORBIDDEN= "Has a serious security hole, use 4.77 or later instead.\
- (These ports are available only for linux version and alpha arch.\
- Looks Netscape has stopped to release new FreeBSD native binary)"
-.endif
-
-.if !defined(INFILE_HEAD)
-# not included from master ports
-NO_LATEST_LINK= yes
-.endif
-
+WRKSRC= ${WRKDIR}/${BROWSER_NAME}-v${BROWSER_V}.${NETSCAPE_DIST_TAG}
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
USE_XLIB= yes
NO_BUILD= yes
NO_FILTER_SHLIBS= yes
-STRIP=
-WRKSRC?= ${WRKDIR}/${BROWSER_NAME}-v408.x86-unknown-freebsd
-PKGDIR= ${.CURDIR}
-
-AUTOADMIN?= autoadmin-v408.x86-unknown-freebsd.tar.gz
-BROWSER_NAME?= communicator
-BROWSER_ARC?= ${BROWSER_NAME}
-BROWSER_VER?= 4.08
-FORTIFY= Fortify-1.4.6-unix-x86
-NDIR= ${PREFIX}/${NSUBDIR}
-NSUBDIR?= lib/netscape
-BINDIR= ${PREFIX}/bin
-INFILE_HEAD?= 'Communicator,4.08.0.98306'
-WRAPPER_TEMPLATE= ${MASTERDIR}/files/netscape.sh
-MAILCAP?= ${MASTERDIR}/files/mailcap
-
+STRIP= # null
+#PKGDIR= ${.CURDIR}
PLIST_SUB= BROWSER=${BROWSER_ARC} BROWSER_VER=${BROWSER_VER} \
NSUBDIR=${NSUBDIR}
-.if (${BROWSER_NAME} == "communicator") && !defined(NO_AUTOADMIN)
-DISTFILES+= ${AUTOADMIN}
-.endif
-
-.if defined(WITH_128BIT) && !defined(NO_FORTIFY)
-MASTER_SITES+= ftp://ftp.fortify.net/pub/Fortify/ \
- ftp://ftp.za.freebsd.org/pub/Fortify/
-DISTFILES+= ${FORTIFY}.tar.gz
-RESTRICTED= "Contains strong cryptography"
-.endif
-
-.if !defined(_PREMKINCLUDED)
-.include <bsd.port.pre.mk>
-.endif
-
-.if ${ARCH} == "alpha"
-RUN_DEPENDS+= /compat/osf1/usr/shlib/libc.so:${PORTSDIR}/emulators/osf1_base
-.endif
-
-.if (${ARCH} == "i386") && !defined(USE_LINUX) && !defined(WITHOUT_AOUT)
-USE_AOUT_LIB= yes
-PKGREQ= ${MASTERDIR}/pkg-req.aout
-RUN_DEPENDS+= ${X11BASE}/lib/aout/libX11.so.6.1:${PORTSDIR}/x11/XFree86-aoutlibs
-.endif
-.SILENT:
-
-.if !defined(WITH_128BIT) && !defined(NO_FORTIFY)
-pre-extract:
- ${ECHO} "You can make Netscape use 128-bit encryption by defining WITH_128BIT"
+BROWSER_NAME?= communicator
+BROWSER_ARC= ${BROWSER_NAME}-linux
+BROWSER_VER?= 4.8
+BROWSER_V?= 48
+.if defined(BROWSER_NAME) && ${BROWSER_NAME} == "navigator"
+NETSCAPE_DIST_GRADE= navigator_standalone
.endif
+NETSCAPE_DIST_GRADE?= complete_install
+NETSCAPE_DIST_ARCH= supported/linux22
+NETSCAPE_DIST_SUBDIR= communicator/english/${BROWSER_VER}/unix/${NETSCAPE_DIST_ARCH}/${NETSCAPE_DIST_GRADE}
+NETSCAPE_DIST_TAG= x86-unknown-linux2.2
+NDIR= ${PREFIX}/${NSUBDIR}
+NSUBDIR= lib/netscape-linux
+BINDIR= ${PREFIX}/bin
+INFILE_HEAD= 'Communicator,4.8.0.20020722'
+WRAPPER_TEMPLATE= ${MASTERDIR}/files/netscape.sh
+MAILCAP= ${MASTERDIR}/files/mailcap
post-configure:
${SED} -e "s;@PREFIX@;${PREFIX};g" -e "s;@NSUBDIR@;${NSUBDIR};g" \
@@ -88,44 +78,25 @@ post-configure:
${CHMOD} +x ${WRKSRC}/netscape
${ECHO_CMD} -n ${INFILE_HEAD},${NDIR} >${WRKSRC}/infile
-.if defined(USE_AOUT_LIB)
-pre-install:
- PKG_PREFIX=${PREFIX} ${SH} ${PKGREQ} ${PKGNAME} INSTALL
-.endif
-
do-install:
${MKDIR} ${NDIR}/java/classes
- ${INSTALL_DATA} ${WRKSRC}/*.jar ${NDIR}/java/classes
- ${INSTALL_PROGRAM} ${WRKSRC}/vreg ${NDIR}
for i in ${WRKSRC}/*.nif; do \
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} $${i} ${EXTRACT_AFTER_ARGS} -C ${NDIR}; \
done
+ ${INSTALL_DATA} ${WRKSRC}/*.jar ${NDIR}/java/classes
+ ${INSTALL_PROGRAM} ${WRKSRC}/vreg ${NDIR}
${WRKSRC}/vreg ${NDIR}/registry ${WRKSRC}/infile
${MV} -f ${NDIR}/netscape ${NDIR}/${BROWSER_ARC}-${BROWSER_VER}.bin
- ${INSTALL_SCRIPT} ${WRKSRC}/netscape \
- ${BINDIR}/${BROWSER_ARC}-${BROWSER_VER}
+ ${INSTALL_SCRIPT} ${WRKSRC}/netscape ${BINDIR}/${BROWSER_ARC}-${BROWSER_VER}
${LN} -sf ${BROWSER_ARC}-${BROWSER_VER} ${BINDIR}/${BROWSER_ARC}-4
${LN} -sf ${BROWSER_ARC}-4 ${BINDIR}/netscape.run
if [ ! -f ${NDIR}/mailcap ] ; then \
${INSTALL_DATA} ${MAILCAP} ${NDIR}; \
fi
${RM} -rf ${NDIR}/movemail-src
-.if (${BROWSER_NAME} == "communicator") && !defined(NO_AUTOADMIN)
- tar zxf ${DISTDIR}/${AUTOADMIN} -C ${NDIR}
-.endif
-.if defined(WITH_128BIT) && !defined(NO_FORTIFY)
- cd ${WRKDIR}/${FORTIFY} \
- && (${ECHO_CMD}; ${ECHO_CMD} yes; ${ECHO_CMD} no; ${ECHO_CMD} no) \
- | ./Fortify.sh ${NDIR}/${BROWSER_ARC}-${BROWSER_VER}.bin
-.endif
${CHOWN} -R root:wheel ${NDIR}
post-install:
${CAT} ${DESCR}
-# hack to allow slave ports to include bsd.port.pre.mk and then this file
-.if defined(_PREMKINCLUDED)
-.include <bsd.port.post.mk>
-.else
.include <bsd.port.mk>
-.endif
diff --git a/www/netscape48-communicator/distinfo b/www/netscape48-communicator/distinfo
index c26bd2447262..7c799becca95 100644
--- a/www/netscape48-communicator/distinfo
+++ b/www/netscape48-communicator/distinfo
@@ -1,12 +1,2 @@
-MD5 (Fortify-1.4.6-unix-x86.tar.gz) = 93fd03a90dcfbf8d55ce0785d2a42ffc
-MD5 (autoadmin-v408.x86-unknown-freebsd.tar.gz) = 0435245b83fc5d9be6844ebfa1a242f0
-MD5 (communicator-v408-export.x86-unknown-freebsd.tar.gz) = dfe7005dd39ac900fe336d6f052acfdb
-MD5 (communicator-v475-us.x86-bsdi-bsd2.tar.gz) = 30280590f4e75bea070ec6e4f902cff0
-MD5 (communicator-v478-us.alpha-dec-osf4.0.tar.gz) = 7f1f12f4a2c1abb6b4f50739f6cdf6bd
-MD5 (communicator-v476-us.x86-unknown-freebsd.tar.gz) = 8d7d338684c5ebc69bc3e6aa80bc9f00
-MD5 (communicator-v479-us.x86-unknown-linux2.2.tar.gz) = d57e2faf8ff8c8a75d3214a268f65050
-MD5 (navigator-v408-export.x86-unknown-freebsd.tar.gz) = 63d607f8e861471f4dcd14d048e1f652
-MD5 (navigator-v475-us.x86-bsdi-bsd2.tar.gz) = 35db9c1fc5db01131d99167b6746df9f
-MD5 (navigator-v478-us.alpha-dec-osf4.0.tar.gz) = 5c4283489e79f7c2e9de6b50b97f681f
-MD5 (navigator-v476-us.x86-unknown-freebsd.tar.gz) = f03852f83fe5f9351d2e86fb86cf82db
-MD5 (navigator-v479-us.x86-unknown-linux2.2.tar.gz) = 40981cdbd2bf67eb2846e19966c0e3ec
+MD5 (communicator-v48-us.x86-unknown-linux2.2.tar.gz) = e131bf86a7ef03dc31e502a3184c9f56
+MD5 (navigator-v48-us.x86-unknown-linux2.2.tar.gz) = ec54ef40eb1be523139a5fe9fb28513f
diff --git a/www/netscape48-communicator/pkg-descr b/www/netscape48-communicator/pkg-descr
index bae98c113894..e0a83b68e9ae 100644
--- a/www/netscape48-communicator/pkg-descr
+++ b/www/netscape48-communicator/pkg-descr
@@ -6,5 +6,3 @@ Note: If Java applets fail to display. Type this as root:
/usr/X11R6/bin/mkfontdir
chmod 444 fonts.dir
And then exit and restart your X server.
-
-WWW: http://www.fortify.net/
diff --git a/www/netscape48-communicator/pkg-plist b/www/netscape48-communicator/pkg-plist
index f6efd62acb1f..53320c55ec2b 100644
--- a/www/netscape48-communicator/pkg-plist
+++ b/www/netscape48-communicator/pkg-plist
@@ -1,33 +1,14 @@
-bin/communicator-%%BROWSER_VER%%
-@exec ln -sf %f %B/communicator-4
-@exec ln -sf communicator-4 %B/netscape.run
+bin/%%BROWSER%%-%%BROWSER_VER%%
+@exec ln -sf %f %B/%%BROWSER%%-4
+@exec ln -sf %%BROWSER%%-4 %B/netscape.run
@unexec rm -f %B/netscape.run
-@unexec rm -f %B/communicator-4
-%%NSUBDIR%%/README
+@unexec rm -f %B/%%BROWSER%%-4
%%NSUBDIR%%/LICENSE
%%NSUBDIR%%/Netscape.ad
+%%NSUBDIR%%/README
%%NSUBDIR%%/XKeysymDB
-%%NSUBDIR%%/movemail
-%%NSUBDIR%%/libAutoAdmin.so
-%%NSUBDIR%%/plugins/libnullplugin.so
-%%NSUBDIR%%/libjsd.so.1.0
%%NSUBDIR%%/bookmark.htm
-%%NSUBDIR%%/java/classes/awt.properties
-%%NSUBDIR%%/java/classes/font.properties
-%%NSUBDIR%%/java/classes/font.properties.zh_TW_Big5
-%%NSUBDIR%%/java/classes/font.properties.zh_TW
-%%NSUBDIR%%/java/classes/font.properties.zh_GB2312
-%%NSUBDIR%%/java/classes/font.properties.zh
-%%NSUBDIR%%/java/classes/font.properties.tr
-%%NSUBDIR%%/java/classes/font.properties.ru
-%%NSUBDIR%%/java/classes/font.properties.pl
-%%NSUBDIR%%/java/classes/font.properties.lv
-%%NSUBDIR%%/java/classes/font.properties.lt
-%%NSUBDIR%%/java/classes/font.properties.ko
-%%NSUBDIR%%/java/classes/font.properties.ja
-%%NSUBDIR%%/java/classes/font.properties.hu
-%%NSUBDIR%%/java/classes/font.properties.el
-%%NSUBDIR%%/java/classes/font.properties.cs
+%%NSUBDIR%%/communicator-linux-4.8.bin
%%NSUBDIR%%/java/classes/aix/font.properties
%%NSUBDIR%%/java/classes/aix/font.properties.cs
%%NSUBDIR%%/java/classes/aix/font.properties.hu
@@ -37,6 +18,23 @@ bin/communicator-%%BROWSER_VER%%
%%NSUBDIR%%/java/classes/aix/font.properties.ru
%%NSUBDIR%%/java/classes/aix/font.properties.zh
%%NSUBDIR%%/java/classes/aix/font.properties.zh_TW
+%%NSUBDIR%%/java/classes/awt.properties
+%%NSUBDIR%%/java/classes/font.properties
+%%NSUBDIR%%/java/classes/font.properties.cs
+%%NSUBDIR%%/java/classes/font.properties.el
+%%NSUBDIR%%/java/classes/font.properties.hu
+%%NSUBDIR%%/java/classes/font.properties.ja
+%%NSUBDIR%%/java/classes/font.properties.ko
+%%NSUBDIR%%/java/classes/font.properties.lt
+%%NSUBDIR%%/java/classes/font.properties.lv
+%%NSUBDIR%%/java/classes/font.properties.pl
+%%NSUBDIR%%/java/classes/font.properties.ru
+%%NSUBDIR%%/java/classes/font.properties.tr
+%%NSUBDIR%%/java/classes/font.properties.zh
+%%NSUBDIR%%/java/classes/font.properties.zh_GB2312
+%%NSUBDIR%%/java/classes/font.properties.zh_TW
+%%NSUBDIR%%/java/classes/font.properties.zh_TW_Big5
+%%NSUBDIR%%/java/classes/font.properties.zh_TW_CNS11643
%%NSUBDIR%%/java/classes/hpux/font.properties
%%NSUBDIR%%/java/classes/hpux/font.properties.bg
%%NSUBDIR%%/java/classes/hpux/font.properties.cs
@@ -54,7 +52,8 @@ bin/communicator-%%BROWSER_VER%%
%%NSUBDIR%%/java/classes/hpux/font.properties.zh_GB2312
%%NSUBDIR%%/java/classes/hpux/font.properties.zh_TW_Big5
%%NSUBDIR%%/java/classes/hpux/font.properties.zh_TW_CNS11643
-%%NSUBDIR%%/java/classes/font.properties.zh_TW_CNS11643
+%%NSUBDIR%%/java/classes/ifc11.jar
+%%NSUBDIR%%/java/classes/iiop10.jar
%%NSUBDIR%%/java/classes/irix/font.properties
%%NSUBDIR%%/java/classes/irix/font.properties.cs
%%NSUBDIR%%/java/classes/irix/font.properties.el
@@ -64,103 +63,101 @@ bin/communicator-%%BROWSER_VER%%
%%NSUBDIR%%/java/classes/irix/font.properties.zh_GB2312
%%NSUBDIR%%/java/classes/irix/font.properties.zh_TW_Big5
%%NSUBDIR%%/java/classes/irix/font.properties.zh_TW_CNS11643
-%%NSUBDIR%%/java/classes/ifc11.jar
-%%NSUBDIR%%/java/classes/iiop10.jar
%%NSUBDIR%%/java/classes/jae40.jar
%%NSUBDIR%%/java/classes/java40.jar
%%NSUBDIR%%/java/classes/jio40.jar
+%%NSUBDIR%%/java/classes/joptio40.jar
%%NSUBDIR%%/java/classes/jsd10.jar
-%%NSUBDIR%%/java/classes/ldap10.jar
+%%NSUBDIR%%/java/classes/ldap40.jar
+%%NSUBDIR%%/java/classes/resource.jar
%%NSUBDIR%%/java/classes/scd10.jar
+%%NSUBDIR%%/libjsd.so
+%%NSUBDIR%%/libnullplugin-dynMotif.so
+%%NSUBDIR%%/mailcap
+%%NSUBDIR%%/movemail
%%NSUBDIR%%/nethelp/Back_dep.gif
-%%NSUBDIR%%/nethelp/Topic.js
-%%NSUBDIR%%/nethelp/System.js
-%%NSUBDIR%%/nethelp/Stack.js
-%%NSUBDIR%%/nethelp/Local-1.js
-%%NSUBDIR%%/nethelp/IdxData.js
-%%NSUBDIR%%/nethelp/Header.js
-%%NSUBDIR%%/nethelp/CntTool.js
-%%NSUBDIR%%/nethelp/CntData.js
+%%NSUBDIR%%/nethelp/Back_dis.gif
+%%NSUBDIR%%/nethelp/Back_sel.gif
+%%NSUBDIR%%/nethelp/Back_up.gif
+%%NSUBDIR%%/nethelp/Blank.htm
%%NSUBDIR%%/nethelp/Button.js
-%%NSUBDIR%%/nethelp/picsfail.jar
-%%NSUBDIR%%/nethelp/picsfail.htm
-%%NSUBDIR%%/nethelp/ToolUI.htm
-%%NSUBDIR%%/nethelp/System.htm
-%%NSUBDIR%%/nethelp/Status.htm
-%%NSUBDIR%%/nethelp/NoJSerr.htm
-%%NSUBDIR%%/nethelp/NavUI.htm
-%%NSUBDIR%%/nethelp/NSHIfrm.htm
-%%NSUBDIR%%/nethelp/IdxTopic.htm
-%%NSUBDIR%%/nethelp/IdxTool.htm
-%%NSUBDIR%%/nethelp/IdxKey.htm
-%%NSUBDIR%%/nethelp/IdxFill.htm
+%%NSUBDIR%%/nethelp/CntData.js
%%NSUBDIR%%/nethelp/CntTool.htm
-%%NSUBDIR%%/nethelp/Blank.htm
-%%NSUBDIR%%/nethelp/netwatch.gif
-%%NSUBDIR%%/nethelp/Wait.gif
-%%NSUBDIR%%/nethelp/Tool_up.gif
-%%NSUBDIR%%/nethelp/Tool_sel.gif
-%%NSUBDIR%%/nethelp/Tool_dep.gif
-%%NSUBDIR%%/nethelp/Prnt_up.gif
-%%NSUBDIR%%/nethelp/Prnt_sel.gif
-%%NSUBDIR%%/nethelp/Prnt_dep.gif
-%%NSUBDIR%%/nethelp/Forw_up.gif
-%%NSUBDIR%%/nethelp/Forw_sel.gif
-%%NSUBDIR%%/nethelp/Forw_dis.gif
-%%NSUBDIR%%/nethelp/Forw_dep.gif
-%%NSUBDIR%%/nethelp/Exit_up.gif
-%%NSUBDIR%%/nethelp/Exit_sel.gif
+%%NSUBDIR%%/nethelp/CntTool.js
%%NSUBDIR%%/nethelp/Exit_dep.gif
-%%NSUBDIR%%/nethelp/Back_up.gif
-%%NSUBDIR%%/nethelp/Back_sel.gif
-%%NSUBDIR%%/nethelp/Back_dis.gif
+%%NSUBDIR%%/nethelp/Exit_sel.gif
+%%NSUBDIR%%/nethelp/Exit_up.gif
+%%NSUBDIR%%/nethelp/Forw_dep.gif
+%%NSUBDIR%%/nethelp/Forw_dis.gif
+%%NSUBDIR%%/nethelp/Forw_sel.gif
+%%NSUBDIR%%/nethelp/Forw_up.gif
+%%NSUBDIR%%/nethelp/Header.js
+%%NSUBDIR%%/nethelp/IdxData.js
+%%NSUBDIR%%/nethelp/IdxFill.htm
+%%NSUBDIR%%/nethelp/IdxKey.htm
+%%NSUBDIR%%/nethelp/IdxTool.htm
+%%NSUBDIR%%/nethelp/IdxTopic.htm
+%%NSUBDIR%%/nethelp/Local-1.js
+%%NSUBDIR%%/nethelp/NSHIfrm.htm
+%%NSUBDIR%%/nethelp/NavUI.htm
+%%NSUBDIR%%/nethelp/NoJSerr.htm
+%%NSUBDIR%%/nethelp/Prnt_dep.gif
+%%NSUBDIR%%/nethelp/Prnt_sel.gif
+%%NSUBDIR%%/nethelp/Prnt_up.gif
+%%NSUBDIR%%/nethelp/Stack.js
+%%NSUBDIR%%/nethelp/Status.htm
+%%NSUBDIR%%/nethelp/System.htm
+%%NSUBDIR%%/nethelp/System.js
+%%NSUBDIR%%/nethelp/ToolUI.htm
+%%NSUBDIR%%/nethelp/Tool_dep.gif
+%%NSUBDIR%%/nethelp/Tool_sel.gif
+%%NSUBDIR%%/nethelp/Tool_up.gif
+%%NSUBDIR%%/nethelp/Topic.js
%%NSUBDIR%%/nethelp/Utility.js
-%%NSUBDIR%%/nethelp/netscape/collabra/collabra.gif
-%%NSUBDIR%%/nethelp/netscape/collabra/discgrps.gif
+%%NSUBDIR%%/nethelp/Wait.gif
%%NSUBDIR%%/nethelp/netscape/collabra/coll.htm
%%NSUBDIR%%/nethelp/netscape/collabra/collHdr.htm
+%%NSUBDIR%%/nethelp/netscape/collabra/collabra.gif
+%%NSUBDIR%%/nethelp/netscape/collabra/discgrps.gif
%%NSUBDIR%%/nethelp/netscape/collabra/help.hpf
+%%NSUBDIR%%/nethelp/netscape/collabra/mailbox2.gif
+%%NSUBDIR%%/nethelp/netscape/composer/comp.htm
+%%NSUBDIR%%/nethelp/netscape/composer/compHdr.htm
%%NSUBDIR%%/nethelp/netscape/composer/composer.gif
%%NSUBDIR%%/nethelp/netscape/composer/comtlbr2.gif
%%NSUBDIR%%/nethelp/netscape/composer/fmtlbr3.gif
-%%NSUBDIR%%/nethelp/netscape/composer/tagicon2.gif
-%%NSUBDIR%%/nethelp/netscape/composer/comp.htm
-%%NSUBDIR%%/nethelp/netscape/composer/compHdr.htm
%%NSUBDIR%%/nethelp/netscape/composer/help.hpf
-%%NSUBDIR%%/nethelp/netscape/confernc/brws2.gif
-%%NSUBDIR%%/nethelp/netscape/confernc/chat2.gif
-%%NSUBDIR%%/nethelp/netscape/confernc/circle2.gif
-%%NSUBDIR%%/nethelp/netscape/confernc/confernc.gif
-%%NSUBDIR%%/nethelp/netscape/confernc/eraser2.gif
-%%NSUBDIR%%/nethelp/netscape/confernc/fhndtl2.gif
-%%NSUBDIR%%/nethelp/netscape/confernc/filex2.gif
-%%NSUBDIR%%/nethelp/netscape/confernc/horline2.gif
-%%NSUBDIR%%/nethelp/netscape/confernc/line2.gif
-%%NSUBDIR%%/nethelp/netscape/confernc/pointer2.gif
-%%NSUBDIR%%/nethelp/netscape/confernc/rect2.gif
-%%NSUBDIR%%/nethelp/netscape/confernc/txttool2.gif
-%%NSUBDIR%%/nethelp/netscape/confernc/whtbd2.gif
-%%NSUBDIR%%/nethelp/netscape/confernc/conf.htm
-%%NSUBDIR%%/nethelp/netscape/confernc/confHdr.htm
-%%NSUBDIR%%/nethelp/netscape/confernc/help.hpf
+%%NSUBDIR%%/nethelp/netscape/composer/tagicon2.gif
+%%NSUBDIR%%/nethelp/netscape/home/help.hpf
%%NSUBDIR%%/nethelp/netscape/home/home.gif
%%NSUBDIR%%/nethelp/netscape/home/home.htm
%%NSUBDIR%%/nethelp/netscape/home/homeHdr.htm
-%%NSUBDIR%%/nethelp/netscape/home/help.hpf
+%%NSUBDIR%%/nethelp/netscape/messengr/abook.gif
+%%NSUBDIR%%/nethelp/netscape/messengr/compbar.gif
+%%NSUBDIR%%/nethelp/netscape/messengr/help.hpf
%%NSUBDIR%%/nethelp/netscape/messengr/mailbox.gif
-%%NSUBDIR%%/nethelp/netscape/messengr/messengr.gif
-%%NSUBDIR%%/nethelp/netscape/messengr/mpctrl.gif
+%%NSUBDIR%%/nethelp/netscape/messengr/mailbox2.gif
%%NSUBDIR%%/nethelp/netscape/messengr/mess.htm
%%NSUBDIR%%/nethelp/netscape/messengr/messHdr.htm
-%%NSUBDIR%%/nethelp/netscape/messengr/help.hpf
-%%NSUBDIR%%/nethelp/netscape/navigatr/navigatr.gif
+%%NSUBDIR%%/nethelp/netscape/messengr/messengr.gif
+%%NSUBDIR%%/nethelp/netscape/messengr/mpctrl.gif
+%%NSUBDIR%%/nethelp/netscape/messengr/newsgrp.gif
+%%NSUBDIR%%/nethelp/netscape/messengr/tabs.gif
+%%NSUBDIR%%/nethelp/netscape/navigatr/help.hpf
%%NSUBDIR%%/nethelp/netscape/navigatr/nav.htm
%%NSUBDIR%%/nethelp/netscape/navigatr/navHdr.htm
-%%NSUBDIR%%/nethelp/netscape/navigatr/help.hpf
-%%NSUBDIR%%/nethelp/netscape/netcastr/netcastr.gif
-%%NSUBDIR%%/nethelp/netscape/netcastr/net.htm
-%%NSUBDIR%%/nethelp/netscape/netcastr/netHdr.htm
-%%NSUBDIR%%/nethelp/netscape/netcastr/help.hpf
+%%NSUBDIR%%/nethelp/netscape/navigatr/navigatr.gif
+%%NSUBDIR%%/nethelp/netscape/news/abook.gif
+%%NSUBDIR%%/nethelp/netscape/news/collabra.gif
+%%NSUBDIR%%/nethelp/netscape/news/compbar.gif
+%%NSUBDIR%%/nethelp/netscape/news/discgrps.gif
+%%NSUBDIR%%/nethelp/netscape/news/help.hpf
+%%NSUBDIR%%/nethelp/netscape/news/mailbox2.gif
+%%NSUBDIR%%/nethelp/netscape/news/news.htm
+%%NSUBDIR%%/nethelp/netscape/news/newsgrp.gif
+%%NSUBDIR%%/nethelp/netscape/shared/NetHelpm.css
+%%NSUBDIR%%/nethelp/netscape/shared/NetHelpu.css
+%%NSUBDIR%%/nethelp/netscape/shared/NetHelpw.css
%%NSUBDIR%%/nethelp/netscape/shared/admnIcon.gif
%%NSUBDIR%%/nethelp/netscape/shared/calIcon.gif
%%NSUBDIR%%/nethelp/netscape/shared/collIcon.gif
@@ -171,31 +168,35 @@ bin/communicator-%%BROWSER_VER%%
%%NSUBDIR%%/nethelp/netscape/shared/messIcon.gif
%%NSUBDIR%%/nethelp/netscape/shared/navIcon.gif
%%NSUBDIR%%/nethelp/netscape/shared/netIcon.gif
-%%NSUBDIR%%/nethelp/netscape/shared/Contents.htm
-%%NSUBDIR%%/nethelp/netscape/shared/NetHelp1.css
-%%NSUBDIR%%/nethelp/netscape/nscal/index.html
-%%NSUBDIR%%/spell/pen4s324.dat
+%%NSUBDIR%%/nethelp/netscape/trouble/help.hpf
+%%NSUBDIR%%/nethelp/netscape/trouble/trouble.htm
+%%NSUBDIR%%/nethelp/netwatch.gif
+%%NSUBDIR%%/nethelp/picsfail.htm
+%%NSUBDIR%%/nethelp/picsfail.jar
+%%NSUBDIR%%/netscape-dynMotif
+%%NSUBDIR%%/plugins/ShockwaveFlash.class
+%%NSUBDIR%%/plugins/cpPack1.jar
+%%NSUBDIR%%/plugins/libflashplayer.so
+%%NSUBDIR%%/plugins/libnullplugin.so
+%%NSUBDIR%%/registry
%%NSUBDIR%%/spell/netscape.dic
+%%NSUBDIR%%/spell/pen4s324.dat
%%NSUBDIR%%/vreg
-%%NSUBDIR%%/registry
-%%NSUBDIR%%/communicator-%%BROWSER_VER%%.bin
-%%NSUBDIR%%/mailcap
-@dirrm %%NSUBDIR%%/plugins
@dirrm %%NSUBDIR%%/spell
+@dirrm %%NSUBDIR%%/plugins
+@dirrm %%NSUBDIR%%/nethelp/netscape/trouble
@dirrm %%NSUBDIR%%/nethelp/netscape/shared
-@dirrm %%NSUBDIR%%/nethelp/netscape/nscal
-@dirrm %%NSUBDIR%%/nethelp/netscape/netcastr
+@dirrm %%NSUBDIR%%/nethelp/netscape/news
@dirrm %%NSUBDIR%%/nethelp/netscape/navigatr
@dirrm %%NSUBDIR%%/nethelp/netscape/messengr
@dirrm %%NSUBDIR%%/nethelp/netscape/home
-@dirrm %%NSUBDIR%%/nethelp/netscape/confernc
@dirrm %%NSUBDIR%%/nethelp/netscape/composer
@dirrm %%NSUBDIR%%/nethelp/netscape/collabra
@dirrm %%NSUBDIR%%/nethelp/netscape
@dirrm %%NSUBDIR%%/nethelp
-@dirrm %%NSUBDIR%%/java/classes/aix
-@dirrm %%NSUBDIR%%/java/classes/hpux
@dirrm %%NSUBDIR%%/java/classes/irix
+@dirrm %%NSUBDIR%%/java/classes/hpux
+@dirrm %%NSUBDIR%%/java/classes/aix
@dirrm %%NSUBDIR%%/java/classes
@dirrm %%NSUBDIR%%/java
@unexec rmdir %D/%%NSUBDIR%% 2>/dev/null || true
diff --git a/www/netscape48-communicator/pkg-req.aout b/www/netscape48-communicator/pkg-req.aout
deleted file mode 100644
index 39ffedd926a8..000000000000
--- a/www/netscape48-communicator/pkg-req.aout
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh
-
-if [ -n "${BATCH}" -o -n "${PACKAGE_BUILDING}" ]; then
- exit 0
-fi
-
-env=/usr/bin/env
-fgrep=/usr/bin/fgrep
-ldconfig=/sbin/ldconfig
-ld_so=/usr/libexec/ld.so
-if [ x$2 = xINSTALL ]; then
- $env OBJFORMAT=aout $ldconfig -r | $fgrep -q -e '-lc.3'
- if [ $? -ne 0 -o ! -x $ld_so ]; then
- cat <<END
-++++++++++++++++++++++++++++++++++++++++++++++++++++++
-+ There are no aout libs on this machine. +
-+ 1. Install compat22 distribution, +
-+ 2. restart your system, +
-+ 3. then retry "make install" this port +
-+ or "pkg_add" this package. +
-++++++++++++++++++++++++++++++++++++++++++++++++++++++
-END
- exit 1
- fi
- $env OBJFORMAT=aout $ldconfig -r | $fgrep -q -e '-lX11.6'
- if [ $? -ne 0 ]; then
- cat <<END
-+++++++++++++++++++++++++++++++++++++++++++++
-+ There are no X aout libs on this machine. +
-+++++++++++++++++++++++++++++++++++++++++++++
-END
- exit 1
- fi
-fi
-exit 0;
diff --git a/www/netscape48-navigator/Makefile b/www/netscape48-navigator/Makefile
new file mode 100644
index 000000000000..efbd6a4217fc
--- /dev/null
+++ b/www/netscape48-navigator/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: linux-netscape48-navigator
+# Date created: 26 Aug 2002
+# Whom: sada
+#
+# $FreeBSD$
+#
+
+MASTERDIR= ${.CURDIR}/../netscape48-communicator
+COMMENT= ${.CURDIR}/pkg-comment
+PLIST= ${.CURDIR}/pkg-plist
+
+BROWSER_NAME= navigator
+
+.include "${MASTERDIR}/Makefile"
diff --git a/www/netscape48-navigator/pkg-comment b/www/netscape48-navigator/pkg-comment
new file mode 100644
index 000000000000..1cec451df9f3
--- /dev/null
+++ b/www/netscape48-navigator/pkg-comment
@@ -0,0 +1 @@
+Linux Netscape navigator web-surfboard
diff --git a/www/netscape48-navigator/pkg-plist b/www/netscape48-navigator/pkg-plist
new file mode 100644
index 000000000000..b8b6fe8c4f03
--- /dev/null
+++ b/www/netscape48-navigator/pkg-plist
@@ -0,0 +1,158 @@
+bin/%%BROWSER%%-%%BROWSER_VER%%
+@exec ln -sf %f %B/%%BROWSER%%-4
+@exec ln -sf %%BROWSER%%-4 %B/netscape.run
+@unexec rm -f %B/netscape.run
+@unexec rm -f %B/%%BROWSER%%-4
+%%NSUBDIR%%/%%BROWSER%%-%%BROWSER_VER%%.bin
+%%NSUBDIR%%/LICENSE
+%%NSUBDIR%%/Netscape.ad
+%%NSUBDIR%%/README
+%%NSUBDIR%%/XKeysymDB
+%%NSUBDIR%%/bookmark.htm
+%%NSUBDIR%%/java/classes/aix/font.properties
+%%NSUBDIR%%/java/classes/aix/font.properties.cs
+%%NSUBDIR%%/java/classes/aix/font.properties.hu
+%%NSUBDIR%%/java/classes/aix/font.properties.ja
+%%NSUBDIR%%/java/classes/aix/font.properties.ko
+%%NSUBDIR%%/java/classes/aix/font.properties.pl
+%%NSUBDIR%%/java/classes/aix/font.properties.ru
+%%NSUBDIR%%/java/classes/aix/font.properties.zh
+%%NSUBDIR%%/java/classes/aix/font.properties.zh_TW
+%%NSUBDIR%%/java/classes/awt.properties
+%%NSUBDIR%%/java/classes/font.properties
+%%NSUBDIR%%/java/classes/font.properties.cs
+%%NSUBDIR%%/java/classes/font.properties.el
+%%NSUBDIR%%/java/classes/font.properties.hu
+%%NSUBDIR%%/java/classes/font.properties.ja
+%%NSUBDIR%%/java/classes/font.properties.ko
+%%NSUBDIR%%/java/classes/font.properties.lt
+%%NSUBDIR%%/java/classes/font.properties.lv
+%%NSUBDIR%%/java/classes/font.properties.pl
+%%NSUBDIR%%/java/classes/font.properties.ru
+%%NSUBDIR%%/java/classes/font.properties.tr
+%%NSUBDIR%%/java/classes/font.properties.zh
+%%NSUBDIR%%/java/classes/font.properties.zh_GB2312
+%%NSUBDIR%%/java/classes/font.properties.zh_TW
+%%NSUBDIR%%/java/classes/font.properties.zh_TW_Big5
+%%NSUBDIR%%/java/classes/font.properties.zh_TW_CNS11643
+%%NSUBDIR%%/java/classes/hpux/font.properties
+%%NSUBDIR%%/java/classes/hpux/font.properties.bg
+%%NSUBDIR%%/java/classes/hpux/font.properties.cs
+%%NSUBDIR%%/java/classes/hpux/font.properties.el
+%%NSUBDIR%%/java/classes/hpux/font.properties.hr
+%%NSUBDIR%%/java/classes/hpux/font.properties.hu
+%%NSUBDIR%%/java/classes/hpux/font.properties.ja
+%%NSUBDIR%%/java/classes/hpux/font.properties.ko
+%%NSUBDIR%%/java/classes/hpux/font.properties.pl
+%%NSUBDIR%%/java/classes/hpux/font.properties.ro
+%%NSUBDIR%%/java/classes/hpux/font.properties.ru
+%%NSUBDIR%%/java/classes/hpux/font.properties.sk
+%%NSUBDIR%%/java/classes/hpux/font.properties.sl
+%%NSUBDIR%%/java/classes/hpux/font.properties.tr
+%%NSUBDIR%%/java/classes/hpux/font.properties.zh_GB2312
+%%NSUBDIR%%/java/classes/hpux/font.properties.zh_TW_Big5
+%%NSUBDIR%%/java/classes/hpux/font.properties.zh_TW_CNS11643
+%%NSUBDIR%%/java/classes/ifc11.jar
+%%NSUBDIR%%/java/classes/iiop10.jar
+%%NSUBDIR%%/java/classes/irix/font.properties
+%%NSUBDIR%%/java/classes/irix/font.properties.cs
+%%NSUBDIR%%/java/classes/irix/font.properties.el
+%%NSUBDIR%%/java/classes/irix/font.properties.hu
+%%NSUBDIR%%/java/classes/irix/font.properties.ja
+%%NSUBDIR%%/java/classes/irix/font.properties.ko
+%%NSUBDIR%%/java/classes/irix/font.properties.zh_GB2312
+%%NSUBDIR%%/java/classes/irix/font.properties.zh_TW_Big5
+%%NSUBDIR%%/java/classes/irix/font.properties.zh_TW_CNS11643
+%%NSUBDIR%%/java/classes/jae40.jar
+%%NSUBDIR%%/java/classes/java40.jar
+%%NSUBDIR%%/java/classes/jio40.jar
+%%NSUBDIR%%/java/classes/joptio40.jar
+%%NSUBDIR%%/java/classes/jsd10.jar
+%%NSUBDIR%%/java/classes/ldap40.jar
+%%NSUBDIR%%/java/classes/resource.jar
+%%NSUBDIR%%/java/classes/scd10.jar
+%%NSUBDIR%%/libnullplugin-dynMotif.so
+%%NSUBDIR%%/mailcap
+%%NSUBDIR%%/nethelp/Back_dep.gif
+%%NSUBDIR%%/nethelp/Back_dis.gif
+%%NSUBDIR%%/nethelp/Back_sel.gif
+%%NSUBDIR%%/nethelp/Back_up.gif
+%%NSUBDIR%%/nethelp/Blank.htm
+%%NSUBDIR%%/nethelp/Button.js
+%%NSUBDIR%%/nethelp/CntData.js
+%%NSUBDIR%%/nethelp/CntTool.htm
+%%NSUBDIR%%/nethelp/CntTool.js
+%%NSUBDIR%%/nethelp/Exit_dep.gif
+%%NSUBDIR%%/nethelp/Exit_sel.gif
+%%NSUBDIR%%/nethelp/Exit_up.gif
+%%NSUBDIR%%/nethelp/Forw_dep.gif
+%%NSUBDIR%%/nethelp/Forw_dis.gif
+%%NSUBDIR%%/nethelp/Forw_sel.gif
+%%NSUBDIR%%/nethelp/Forw_up.gif
+%%NSUBDIR%%/nethelp/Header.js
+%%NSUBDIR%%/nethelp/IdxData.js
+%%NSUBDIR%%/nethelp/IdxFill.htm
+%%NSUBDIR%%/nethelp/IdxKey.htm
+%%NSUBDIR%%/nethelp/IdxTool.htm
+%%NSUBDIR%%/nethelp/IdxTopic.htm
+%%NSUBDIR%%/nethelp/Local-1.js
+%%NSUBDIR%%/nethelp/NSHIfrm.htm
+%%NSUBDIR%%/nethelp/NavUI.htm
+%%NSUBDIR%%/nethelp/NoJSerr.htm
+%%NSUBDIR%%/nethelp/Prnt_dep.gif
+%%NSUBDIR%%/nethelp/Prnt_sel.gif
+%%NSUBDIR%%/nethelp/Prnt_up.gif
+%%NSUBDIR%%/nethelp/Stack.js
+%%NSUBDIR%%/nethelp/Status.htm
+%%NSUBDIR%%/nethelp/System.htm
+%%NSUBDIR%%/nethelp/System.js
+%%NSUBDIR%%/nethelp/ToolUI.htm
+%%NSUBDIR%%/nethelp/Tool_dep.gif
+%%NSUBDIR%%/nethelp/Tool_sel.gif
+%%NSUBDIR%%/nethelp/Tool_up.gif
+%%NSUBDIR%%/nethelp/Topic.js
+%%NSUBDIR%%/nethelp/Utility.js
+%%NSUBDIR%%/nethelp/Wait.gif
+%%NSUBDIR%%/nethelp/netscape/home/help.hpf
+%%NSUBDIR%%/nethelp/netscape/home/home.gif
+%%NSUBDIR%%/nethelp/netscape/home/home.htm
+%%NSUBDIR%%/nethelp/netscape/home/homeHdr.htm
+%%NSUBDIR%%/nethelp/netscape/navigatr/help.hpf
+%%NSUBDIR%%/nethelp/netscape/navigatr/nav.htm
+%%NSUBDIR%%/nethelp/netscape/navigatr/navHdr.htm
+%%NSUBDIR%%/nethelp/netscape/navigatr/navigatr.gif
+%%NSUBDIR%%/nethelp/netscape/shared/NetHelpm.css
+%%NSUBDIR%%/nethelp/netscape/shared/NetHelpu.css
+%%NSUBDIR%%/nethelp/netscape/shared/NetHelpw.css
+%%NSUBDIR%%/nethelp/netscape/shared/admnIcon.gif
+%%NSUBDIR%%/nethelp/netscape/shared/calIcon.gif
+%%NSUBDIR%%/nethelp/netscape/shared/collIcon.gif
+%%NSUBDIR%%/nethelp/netscape/shared/commIcon.gif
+%%NSUBDIR%%/nethelp/netscape/shared/compIcon.gif
+%%NSUBDIR%%/nethelp/netscape/shared/confIcon.gif
+%%NSUBDIR%%/nethelp/netscape/shared/ibmIcon.gif
+%%NSUBDIR%%/nethelp/netscape/shared/messIcon.gif
+%%NSUBDIR%%/nethelp/netscape/shared/navIcon.gif
+%%NSUBDIR%%/nethelp/netscape/shared/netIcon.gif
+%%NSUBDIR%%/nethelp/netwatch.gif
+%%NSUBDIR%%/nethelp/picsfail.htm
+%%NSUBDIR%%/nethelp/picsfail.jar
+%%NSUBDIR%%/netscape-dynMotif
+%%NSUBDIR%%/plugins/ShockwaveFlash.class
+%%NSUBDIR%%/plugins/cpPack1.jar
+%%NSUBDIR%%/plugins/libflashplayer.so
+%%NSUBDIR%%/plugins/libnullplugin.so
+%%NSUBDIR%%/registry
+%%NSUBDIR%%/vreg
+@dirrm %%NSUBDIR%%/java/classes/aix
+@dirrm %%NSUBDIR%%/java/classes/hpux
+@dirrm %%NSUBDIR%%/java/classes/irix
+@dirrm %%NSUBDIR%%/java/classes
+@dirrm %%NSUBDIR%%/java
+@dirrm %%NSUBDIR%%/nethelp/netscape/home
+@dirrm %%NSUBDIR%%/nethelp/netscape/navigatr
+@dirrm %%NSUBDIR%%/nethelp/netscape/shared
+@dirrm %%NSUBDIR%%/nethelp/netscape
+@dirrm %%NSUBDIR%%/nethelp
+@dirrm %%NSUBDIR%%/plugins
+@dirrm %%NSUBDIR%%