aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-cache/Makefile37
-rw-r--r--devel/ruby-cache/distinfo1
-rw-r--r--devel/ruby-cache/pkg-comment1
-rw-r--r--devel/ruby-cache/pkg-descr5
-rw-r--r--devel/ruby-cache/pkg-plist8
6 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 23bd4d6fea8f..1de59df091b8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -712,6 +712,7 @@
SUBDIR += ruby-avl
SUBDIR += ruby-bsearch
SUBDIR += ruby-byaccr
+ SUBDIR += ruby-cache
SUBDIR += ruby-calendar
SUBDIR += ruby-cvs
SUBDIR += ruby-date2
diff --git a/devel/ruby-cache/Makefile b/devel/ruby-cache/Makefile
new file mode 100644
index 000000000000..aa6e08bf197b
--- /dev/null
+++ b/devel/ruby-cache/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: Ruby/Cache
+# Date created: 22 November 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cache
+PORTVERSION= 0.2
+CATEGORIES= devel ruby
+MASTER_SITES= http://savannah.nongnu.org/download/pupa/ruby-cache.pkg/${PORTVERSION}/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+RUBY_RD_FILES= ${WRKSRC}/MANUAL.rd ${WRKSRC}/README.rd
+DOCS= ${RUBY_RD_FILES} ${RUBY_RD_HTML_FILES}
+
+post-install: doc-install
+
+.include <bsd.port.mk>
+
+doc-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${f} ${RUBY_MODDOCDIR}/
+.endfor
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample/*.rb ${RUBY_MODEXAMPLESDIR}/
+.endif
diff --git a/devel/ruby-cache/distinfo b/devel/ruby-cache/distinfo
new file mode 100644
index 000000000000..11e9aa972e4d
--- /dev/null
+++ b/devel/ruby-cache/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-cache-0.2.tar.gz) = 879c8f4ba70f84c865655a6243f4004f
diff --git a/devel/ruby-cache/pkg-comment b/devel/ruby-cache/pkg-comment
new file mode 100644
index 000000000000..2fb5ff8c9ed1
--- /dev/null
+++ b/devel/ruby-cache/pkg-comment
@@ -0,0 +1 @@
+A Ruby library for caching objects based on the LRU algorithm
diff --git a/devel/ruby-cache/pkg-descr b/devel/ruby-cache/pkg-descr
new file mode 100644
index 000000000000..e28f793e829c
--- /dev/null
+++ b/devel/ruby-cache/pkg-descr
@@ -0,0 +1,5 @@
+Ruby/Cache is a library for caching objects based on the LRU algorithm
+for Ruby.
+
+Author: Yoshinori K. Okuji <okuji@enbug.org>
+WWW: http://www.nongnu.org/pupa/ruby-cache.html
diff --git a/devel/ruby-cache/pkg-plist b/devel/ruby-cache/pkg-plist
new file mode 100644
index 000000000000..512f6a0d6ebb
--- /dev/null
+++ b/devel/ruby-cache/pkg-plist
@@ -0,0 +1,8 @@
+%%RUBY_SITELIBDIR%%/cache.rb
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/MANUAL.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/MANUAL.rd
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.rd
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/filecache.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%