aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Lingua-EN-Nickname/Makefile22
-rw-r--r--textproc/p5-Lingua-EN-Nickname/distinfo1
-rw-r--r--textproc/p5-Lingua-EN-Nickname/pkg-comment1
-rw-r--r--textproc/p5-Lingua-EN-Nickname/pkg-descr8
-rw-r--r--textproc/p5-Lingua-EN-Nickname/pkg-plist8
6 files changed, 41 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 78797fceefb7..fb4c94482ce4 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -112,6 +112,7 @@
SUBDIR += p5-Lingua-EN-Gender
SUBDIR += p5-Lingua-EN-Infinitive
SUBDIR += p5-Lingua-EN-Inflect
+ SUBDIR += p5-Lingua-EN-Nickname
SUBDIR += p5-Lingua-EN-Numbers-Ordinate
SUBDIR += p5-Lingua-EN-Sentence
SUBDIR += p5-Lingua-Ispell
diff --git a/textproc/p5-Lingua-EN-Nickname/Makefile b/textproc/p5-Lingua-EN-Nickname/Makefile
new file mode 100644
index 000000000000..07259575fd17
--- /dev/null
+++ b/textproc/p5-Lingua-EN-Nickname/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Lingua::EN::Nickname
+# Date created: 30 Dec 2001
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Lingua-EN-Nickname
+PORTVERSION= 1.1
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Lingua
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+PERL_CONFIGURE= yes
+
+MAN3= Lingua::EN::Nickname.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Lingua-EN-Nickname/distinfo b/textproc/p5-Lingua-EN-Nickname/distinfo
new file mode 100644
index 000000000000..aa4c32662bfc
--- /dev/null
+++ b/textproc/p5-Lingua-EN-Nickname/distinfo
@@ -0,0 +1 @@
+MD5 (Lingua-EN-Nickname-1.1.tar.gz) = 6000b6d5dc727a0dde052b96243b7054
diff --git a/textproc/p5-Lingua-EN-Nickname/pkg-comment b/textproc/p5-Lingua-EN-Nickname/pkg-comment
new file mode 100644
index 000000000000..cea90b611596
--- /dev/null
+++ b/textproc/p5-Lingua-EN-Nickname/pkg-comment
@@ -0,0 +1 @@
+Genealogical nickname matching (Liz=Beth)
diff --git a/textproc/p5-Lingua-EN-Nickname/pkg-descr b/textproc/p5-Lingua-EN-Nickname/pkg-descr
new file mode 100644
index 000000000000..87a78f3a87bb
--- /dev/null
+++ b/textproc/p5-Lingua-EN-Nickname/pkg-descr
@@ -0,0 +1,8 @@
+Nicknames, alternate spellings, and alternate etymological derivations
+make checking first name equivalence nearly impossible. This module
+will tell you that 'Maggie', 'Peg', and 'Margaret' are all probably
+the same name.
+
+WWW: http://search.cpan.org/search?dist=Lingua-EN-Nickname
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/textproc/p5-Lingua-EN-Nickname/pkg-plist b/textproc/p5-Lingua-EN-Nickname/pkg-plist
new file mode 100644
index 000000000000..984986de941f
--- /dev/null
+++ b/textproc/p5-Lingua-EN-Nickname/pkg-plist
@@ -0,0 +1,8 @@
+lib/perl5/site_perl/%%PERL_VER%%/Lingua/EN/Nickname.pm
+lib/perl5/site_perl/%%PERL_VER%%/Lingua/EN/nickhash.pl
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Lingua/EN/Nickname/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Lingua/EN/Nickname
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Lingua/EN 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Lingua 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Lingua/EN
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Lingua 2>/dev/null || true