aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/gkrellm-helium/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/misc/gkrellm-helium/Makefile b/misc/gkrellm-helium/Makefile
index 8f373706ad6d..83f77a701990 100644
--- a/misc/gkrellm-helium/Makefile
+++ b/misc/gkrellm-helium/Makefile
@@ -22,7 +22,8 @@ USE_REINPLACE= yes
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|/usr/local/lib/gkrellm2/plugins|${PREFIX}/libexec/gkrellm2/plugins|' ${WRKSRC}/Makefile
+ s|/usr/local/lib/gkrellm2/plugins|${PREFIX}/libexec/gkrellm2/plugins| ; \
+ s|gcc -c|gcc -c -fPIC|g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|ulong|u_long|' ${WRKSRC}/*.c
.include <bsd.port.mk>