aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/contact-lookup-applet/Makefile31
-rw-r--r--mail/contact-lookup-applet/distinfo2
-rw-r--r--mail/contact-lookup-applet/pkg-descr4
-rw-r--r--mail/contact-lookup-applet/pkg-plist14
5 files changed, 52 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index ea9e9db9af54..b4338e0a6c74 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -36,6 +36,7 @@
SUBDIR += chk4mail
SUBDIR += cmail
SUBDIR += cone
+ SUBDIR += contact-lookup-applet
SUBDIR += coolmail
SUBDIR += courier
SUBDIR += courier-imap
diff --git a/mail/contact-lookup-applet/Makefile b/mail/contact-lookup-applet/Makefile
new file mode 100644
index 000000000000..eaa59a92d92f
--- /dev/null
+++ b/mail/contact-lookup-applet/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: contact lookup applet
+# Date created: 22 January 2004
+# Whom: kwm@rainbow-runner.nl
+#
+# $FreeBSD$
+#
+
+PORTNAME= contact
+PORTVERSION= 0.10
+CATEGORIES= mail gnome
+MASTER_SITES= http://www.burtonini.com/computing/
+PKGNAMESUFFIX= -lookup-applet
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Gnome panel applet for easy Evolution contact book access
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_GNOME= gnomehier gnomeprefix gnomehack gnomepanel \
+ evolutiondataserver gal2
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|mkdir}"|mkdir} -p"|g' \
+ ${WRKSRC}/install-sh
+
+.include <bsd.port.mk>
diff --git a/mail/contact-lookup-applet/distinfo b/mail/contact-lookup-applet/distinfo
new file mode 100644
index 000000000000..226e9c77de3b
--- /dev/null
+++ b/mail/contact-lookup-applet/distinfo
@@ -0,0 +1,2 @@
+MD5 (contact-lookup-applet-0.10.tar.gz) = d0a14459676a0f64e871d28dd334f5f8
+SIZE (contact-lookup-applet-0.10.tar.gz) = 134980
diff --git a/mail/contact-lookup-applet/pkg-descr b/mail/contact-lookup-applet/pkg-descr
new file mode 100644
index 000000000000..71e405abb52d
--- /dev/null
+++ b/mail/contact-lookup-applet/pkg-descr
@@ -0,0 +1,4 @@
+Contact Lookup Applet is a gnome panel tool to look up people using the
+Evolution data server backend.
+
+WWW: http://www.burtonini.com/
diff --git a/mail/contact-lookup-applet/pkg-plist b/mail/contact-lookup-applet/pkg-plist
new file mode 100644
index 000000000000..b6a5b01b7fed
--- /dev/null
+++ b/mail/contact-lookup-applet/pkg-plist
@@ -0,0 +1,14 @@
+libdata/bonobo/servers/GNOME_ContactLookupApplet.server
+libexec/contact-lookup-applet
+share/gnome/lookup-applet/GNOME_ContactLookupApplet.xml
+share/gnome/lookup-applet/contact-lookup-applet.glade
+share/locale/cs/LC_MESSAGES/contact-lookup-applet.mo
+share/locale/de/LC_MESSAGES/contact-lookup-applet.mo
+share/locale/en_CA/LC_MESSAGES/contact-lookup-applet.mo
+share/locale/eu/LC_MESSAGES/contact-lookup-applet.mo
+share/locale/hu/LC_MESSAGES/contact-lookup-applet.mo
+share/locale/pa/LC_MESSAGES/contact-lookup-applet.mo
+share/locale/pt_BR/LC_MESSAGES/contact-lookup-applet.mo
+share/locale/sk/LC_MESSAGES/contact-lookup-applet.mo
+share/locale/sv/LC_MESSAGES/contact-lookup-applet.mo
+@dirrm share/gnome/lookup-applet