aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/uartlirc/Makefile1
-rw-r--r--comms/uartlirc/files/patch-uartlirc_lircdev.c20
2 files changed, 21 insertions, 0 deletions
diff --git a/comms/uartlirc/Makefile b/comms/uartlirc/Makefile
index a49d5b00ab03..2d8f55c8ff1c 100644
--- a/comms/uartlirc/Makefile
+++ b/comms/uartlirc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= uartlirc
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= comms kld
MASTER_SITES= LOCAL/nox \
http://people.freebsd.org/~nox/tmp/
diff --git a/comms/uartlirc/files/patch-uartlirc_lircdev.c b/comms/uartlirc/files/patch-uartlirc_lircdev.c
new file mode 100644
index 000000000000..851486e3b0e2
--- /dev/null
+++ b/comms/uartlirc/files/patch-uartlirc_lircdev.c
@@ -0,0 +1,20 @@
+--- uartlirc_lircdev.c.orig
++++ uartlirc_lircdev.c
+@@ -33,6 +33,7 @@ __FBSDID("$FreeBSD$");
+ #include <sys/conf.h>
+ #include <sys/cons.h>
+ #include <sys/fcntl.h>
++#include <sys/filio.h>
+ #include <sys/interrupt.h>
+ #include <sys/kernel.h>
+ #include <sys/malloc.h>
+@@ -117,6 +118,9 @@ uartlirc_lircdev_ioctl(struct cdev *dev,
+ case LIRC_GET_FEATURES:
+ *arg = LIRC_CAN_REC_MODE2;
+ return (0);
++ case FIONBIO:
++ case FIOASYNC:
++ return (0);
+ default:
+ return ENOTTY;
+ }