aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--benchmarks/iozone/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/benchmarks/iozone/Makefile b/benchmarks/iozone/Makefile
index 221ced1a880d..69dbfebb5646 100644
--- a/benchmarks/iozone/Makefile
+++ b/benchmarks/iozone/Makefile
@@ -7,7 +7,7 @@
PORTNAME= iozone
PORTVERSION= 3.283
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= benchmarks
MASTER_SITES= http://www.iozone.org/src/current/
DISTNAME= ${PORTNAME}${PORTVERSION:S/./_/}
@@ -27,7 +27,8 @@ ALL_TARGET=
MAN1= iozone.1
PLIST_FILES= bin/iozone
-OPTIONS= THREADS "Enable threading (uses pthreads)" on
+OPTIONS= THREADS "Enable threading (uses pthreads)" on \
+ SSH "Use ssh in distributed measurement" on
.include <bsd.port.pre.mk>
@@ -38,6 +39,9 @@ MAKE_ENV= LDFLAGS=${PTHREAD_LIBS}
CFLAGS+=-DNO_THREADS
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|shell\,\"rsh\"|shell\,\"ssh\"|' ${WRKSRC}/iozone.c
+
do-install:
${STRIP_CMD} ${WRKSRC}/iozone
${INSTALL_PROGRAM} ${WRKSRC}/iozone ${PREFIX}/bin