aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--benchmarks/sysbench/Makefile2
-rw-r--r--databases/ip4r/Makefile2
-rw-r--r--databases/mysql-administrator/Makefile2
-rw-r--r--databases/mysql-connector-odbc/Makefile2
-rw-r--r--databases/mysql-query-browser/Makefile2
-rw-r--r--databases/mysqlcc/Makefile2
-rw-r--r--databases/pecl-paradox/Makefile2
-rw-r--r--databases/pgadmin3/Makefile4
-rw-r--r--deskutils/phprojekt/Makefile2
-rw-r--r--devel/bugzilla/Makefile2
-rw-r--r--devel/bugzilla2/Makefile2
-rw-r--r--devel/bugzilla3/Makefile2
-rw-r--r--devel/pear-PHPUnit2/Makefile2
-rw-r--r--devel/pear-PHPUnit3/Makefile2
-rw-r--r--devel/pear-PHP_Beautifier/Makefile2
-rw-r--r--devel/pecl-operator/Makefile2
-rw-r--r--graphics/jpgraph/Makefile2
-rw-r--r--lang/php4-extensions/Makefile2
-rw-r--r--lang/php5-extensions/Makefile2
-rw-r--r--net-p2p/torrentflux/Makefile2
-rw-r--r--net/phpldapadmin/Makefile2
-rw-r--r--print/phppdflib/Makefile2
-rw-r--r--security/pecl-filter/Makefile2
-rw-r--r--security/pfw/Makefile2
-rw-r--r--security/php4-cryptopp/Makefile2
-rw-r--r--shells/bush/Makefile2
-rw-r--r--sysutils/dtc/Makefile2
-rw-r--r--www/abcache/Makefile2
-rw-r--r--www/autoindex/Makefile2
-rw-r--r--www/autoindex2/Makefile2
-rw-r--r--www/campsite/Makefile2
-rw-r--r--www/fluxcms/Makefile1
-rw-r--r--www/mod_auth_cookie_mysql/Makefile2
-rw-r--r--www/mod_auth_cookie_mysql2/Makefile2
-rw-r--r--www/php-dyn/Makefile2
-rw-r--r--www/php-screw/Makefile2
-rw-r--r--www/php-templates/Makefile2
-rw-r--r--www/siteframe/Makefile4
-rw-r--r--www/usermanager/Makefile2
-rw-r--r--www/xaraya/Makefile2
-rw-r--r--x11-toolkits/php-gtk/Makefile2
-rw-r--r--x11-toolkits/php-gtk2/Makefile2
42 files changed, 44 insertions, 43 deletions
diff --git a/benchmarks/sysbench/Makefile b/benchmarks/sysbench/Makefile
index 9bff95d3639b..bf103f20efb1 100644
--- a/benchmarks/sysbench/Makefile
+++ b/benchmarks/sysbench/Makefile
@@ -31,7 +31,7 @@ CONFIGURE_ARGS+= --with-mysql
.if defined(WITH_POSTGRESQL)
USE_PGSQL= yes
DEFAULT_PGSQL_VER?= 80
-BROKEN_WITH_PGSQL= 73 74
+IGNORE_WITH_PGSQL= 73 74
CONFIGURE_ARGS+= --with-pgsql
.else
CONFIGURE_ARGS+= --with-pgsql=no
diff --git a/databases/ip4r/Makefile b/databases/ip4r/Makefile
index 3fd955c5ca3e..847fae03954b 100644
--- a/databases/ip4r/Makefile
+++ b/databases/ip4r/Makefile
@@ -20,7 +20,7 @@ DEFAULT_PGSQL_VER= 81
# 74 is not strictly true, but requires extracting the appropriate
# postgresql-contrib tarball, and associated heavy lifting.
# In order to keep this port simple, we assume >= 8.0
-BROKEN_WITH_PGSQL= 73 74
+IGNORE_WITH_PGSQL= 73 74
MAKE_ARGS= USE_PGXS=1
diff --git a/databases/mysql-administrator/Makefile b/databases/mysql-administrator/Makefile
index c355e2875a96..1a1f4c900f91 100644
--- a/databases/mysql-administrator/Makefile
+++ b/databases/mysql-administrator/Makefile
@@ -28,7 +28,7 @@ CONFIGURE_ARGS+= --localstatedir=${PREFIX}/share/gnome
USE_ICONV= yes
USE_GNOME= libglade2 gnomehack
USE_MYSQL= yes
-BROKEN_WITH_MYSQL= 323
+IGNORE_WITH_MYSQL= 323
GNU_CONFIGURE= yes
GUI_CONFIG_COOKIE= ${WRKDIR}/.gui_configure_done
diff --git a/databases/mysql-connector-odbc/Makefile b/databases/mysql-connector-odbc/Makefile
index 5118f739005e..e77340871609 100644
--- a/databases/mysql-connector-odbc/Makefile
+++ b/databases/mysql-connector-odbc/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= sergey@network-asp.biz
COMMENT= ODBC driver for MySQL${MYSQL_VER} / ${DRIVER_MANAGER}
USE_MYSQL= yes
-BROKEN_WITH_MYSQL= 323
+IGNORE_WITH_MYSQL= 323
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15 libltdl:15
diff --git a/databases/mysql-query-browser/Makefile b/databases/mysql-query-browser/Makefile
index 05e6c567c6bc..7c4bf8ec5e65 100644
--- a/databases/mysql-query-browser/Makefile
+++ b/databases/mysql-query-browser/Makefile
@@ -36,7 +36,7 @@ USE_ICONV= yes
USE_GNOME= libglade2 gnomehack gtkhtml3 intltool
USE_MYSQL= yes
DEFAULT_MYSQL_VER= 50
-BROKEN_WITH_MYSQL= 323
+IGNORE_WITH_MYSQL= 323
GNU_CONFIGURE= yes
GUI_CONFIG_COOKIE= ${WRKDIR}/.gui_configure_done
diff --git a/databases/mysqlcc/Makefile b/databases/mysqlcc/Makefile
index 21743251d77a..ecbfeedc1221 100644
--- a/databases/mysqlcc/Makefile
+++ b/databases/mysqlcc/Makefile
@@ -19,7 +19,7 @@ COMMENT= A platform-independent GUI administration client for the MySQL server
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
USE_MYSQL= yes
-BROKEN_WITH_MYSQL=323
+IGNORE_WITH_MYSQL=323
GNU_CONFIGURE= yes
USE_QT_VER= 3
diff --git a/databases/pecl-paradox/Makefile b/databases/pecl-paradox/Makefile
index 3c6df868c0d1..dedc9a10e011 100644
--- a/databases/pecl-paradox/Makefile
+++ b/databases/pecl-paradox/Makefile
@@ -22,7 +22,7 @@ USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
DEFAULT_PHP_VER=5
-BROKEN_WITH_PHP=4
+IGNORE_WITH_PHP=4
PHP_MODNAME= paradox
CONFIGURE_ARGS+= --with-paradox=${LOCALBASE}
diff --git a/databases/pgadmin3/Makefile b/databases/pgadmin3/Makefile
index ed004fddc086..dfca2c259c29 100644
--- a/databases/pgadmin3/Makefile
+++ b/databases/pgadmin3/Makefile
@@ -16,7 +16,7 @@ COMMENT= PostgreSQL database design and management system
USE_GETTEXT= yes
USE_PGSQL= yes
-BROKEN_WITH_PGSQL= 73
+IGNORE_WITH_PGSQL= 73
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wx=${X11BASE} --with-wx-config=${WX_CONFIG}
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
@@ -32,7 +32,7 @@ post-install:
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= requires wchar_t
+IGNORE= cannot install: requires wchar_t
.endif
.include <bsd.port.post.mk>
diff --git a/deskutils/phprojekt/Makefile b/deskutils/phprojekt/Makefile
index df80082adf65..7b0136d965a0 100644
--- a/deskutils/phprojekt/Makefile
+++ b/deskutils/phprojekt/Makefile
@@ -16,7 +16,7 @@ COMMENT= An open source groupware suite
USE_PHP= yes
DEFAULT_PHP_VER=4
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
WANT_PHP_MOD= yes
NO_BUILD= yes
diff --git a/devel/bugzilla/Makefile b/devel/bugzilla/Makefile
index be171d80abd6..f8d4b78a7e8b 100644
--- a/devel/bugzilla/Makefile
+++ b/devel/bugzilla/Makefile
@@ -59,7 +59,7 @@ DATA_DIRS_LIST= images js skins/standard skins/standard/global \
.ifdef WITH_MYSQL
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
USE_MYSQL= yes
-BROKEN_WITH_MYSQL= 323
+IGNORE_WITH_MYSQL= 323
.endif
.ifdef WITH_PGSQL
diff --git a/devel/bugzilla2/Makefile b/devel/bugzilla2/Makefile
index be171d80abd6..f8d4b78a7e8b 100644
--- a/devel/bugzilla2/Makefile
+++ b/devel/bugzilla2/Makefile
@@ -59,7 +59,7 @@ DATA_DIRS_LIST= images js skins/standard skins/standard/global \
.ifdef WITH_MYSQL
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
USE_MYSQL= yes
-BROKEN_WITH_MYSQL= 323
+IGNORE_WITH_MYSQL= 323
.endif
.ifdef WITH_PGSQL
diff --git a/devel/bugzilla3/Makefile b/devel/bugzilla3/Makefile
index be171d80abd6..f8d4b78a7e8b 100644
--- a/devel/bugzilla3/Makefile
+++ b/devel/bugzilla3/Makefile
@@ -59,7 +59,7 @@ DATA_DIRS_LIST= images js skins/standard skins/standard/global \
.ifdef WITH_MYSQL
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
USE_MYSQL= yes
-BROKEN_WITH_MYSQL= 323
+IGNORE_WITH_MYSQL= 323
.endif
.ifdef WITH_PGSQL
diff --git a/devel/pear-PHPUnit2/Makefile b/devel/pear-PHPUnit2/Makefile
index d3efdd73e57f..883892967066 100644
--- a/devel/pear-PHPUnit2/Makefile
+++ b/devel/pear-PHPUnit2/Makefile
@@ -23,7 +23,7 @@ USE_PHP= dom pcre
NO_PACKAGE= "Conflicting dependences between PHP4 and PHP5"
DEFAULT_PHP_VER=5
-BROKEN_WITH_PHP=4
+IGNORE_WITH_PHP=4
CATEGORY= PHPUnit2
FILES= Extensions/ExceptionTestCase.php \
diff --git a/devel/pear-PHPUnit3/Makefile b/devel/pear-PHPUnit3/Makefile
index d3efdd73e57f..883892967066 100644
--- a/devel/pear-PHPUnit3/Makefile
+++ b/devel/pear-PHPUnit3/Makefile
@@ -23,7 +23,7 @@ USE_PHP= dom pcre
NO_PACKAGE= "Conflicting dependences between PHP4 and PHP5"
DEFAULT_PHP_VER=5
-BROKEN_WITH_PHP=4
+IGNORE_WITH_PHP=4
CATEGORY= PHPUnit2
FILES= Extensions/ExceptionTestCase.php \
diff --git a/devel/pear-PHP_Beautifier/Makefile b/devel/pear-PHP_Beautifier/Makefile
index fdb4ed3e7f79..2b67b87f85c3 100644
--- a/devel/pear-PHP_Beautifier/Makefile
+++ b/devel/pear-PHP_Beautifier/Makefile
@@ -20,7 +20,7 @@ USE_PHP= tokenizer
NO_PACKAGE= Conflicting dependences between PHP4 and PHP5
DEFAULT_PHP_VER=5
-BROKEN_WITH_PHP=4
+IGNORE_WITH_PHP=4
CATEGORY= PHP
FILES= Beautifier.php Beautifier/Filter.php Beautifier/Decorator.php \
diff --git a/devel/pecl-operator/Makefile b/devel/pecl-operator/Makefile
index ff2ef0f28835..38d4178c1957 100644
--- a/devel/pecl-operator/Makefile
+++ b/devel/pecl-operator/Makefile
@@ -20,7 +20,7 @@ COMMENT= PHP extension that provides operator overloading for PHP objects
USE_PHP= yes
USE_PHPEXT= yes
DEFAULT_PHP_VER= 5
-BROKEN_WITH_PHP= 4
+IGNORE_WITH_PHP= 4
PHP_MODNAME= ${PORTNAME}
post-extract::
diff --git a/graphics/jpgraph/Makefile b/graphics/jpgraph/Makefile
index 5b1a768f1a4c..11abcf093a60 100644
--- a/graphics/jpgraph/Makefile
+++ b/graphics/jpgraph/Makefile
@@ -18,7 +18,7 @@ NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/a//}
USE_PHP= gd
DEFAULT_PHP_VER=4
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
NO_CDROM= The free version cannot be used in a commercial context
diff --git a/lang/php4-extensions/Makefile b/lang/php4-extensions/Makefile
index f0b429dfb820..1e4766135b9a 100644
--- a/lang/php4-extensions/Makefile
+++ b/lang/php4-extensions/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ale@FreeBSD.org
COMMENT= A "meta-port" to install PHP extensions
DEFAULT_PHP_VER=4
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
USE_PHP_BUILD= yes
NO_BUILD= yes
diff --git a/lang/php5-extensions/Makefile b/lang/php5-extensions/Makefile
index 72aab611073f..e0e2a486cafc 100644
--- a/lang/php5-extensions/Makefile
+++ b/lang/php5-extensions/Makefile
@@ -17,7 +17,7 @@ MAINTAINER= ale@FreeBSD.org
COMMENT= A "meta-port" to install PHP extensions
DEFAULT_PHP_VER=5
-BROKEN_WITH_PHP=4
+IGNORE_WITH_PHP=4
USE_PHP_BUILD= yes
NO_BUILD= yes
diff --git a/net-p2p/torrentflux/Makefile b/net-p2p/torrentflux/Makefile
index d97471254858..d64ad3be029d 100644
--- a/net-p2p/torrentflux/Makefile
+++ b/net-p2p/torrentflux/Makefile
@@ -23,7 +23,7 @@ NO_PACKAGE= dependencies need manual installation, see ${FILESDIR}/install.txt.
USE_PHP= pcre session sqlite
WANT_PHP_WEB= yes
DEFAULT_PHP_VER?= 5
-BROKEN_WITH_PHP= 4
+IGNORE_WITH_PHP= 4
USE_PYTHON_RUN= yes
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-*
diff --git a/net/phpldapadmin/Makefile b/net/phpldapadmin/Makefile
index 2dc6257cb32c..6deebe0e9d6e 100644
--- a/net/phpldapadmin/Makefile
+++ b/net/phpldapadmin/Makefile
@@ -19,7 +19,7 @@ COMMENT= A set of PHP-scripts to administer LDAP over the web
NO_BUILD= yes
USE_PHP= gettext ldap openssl pcre session xml
PHP_VER= 5
-BROKEN_WITH_PHP= 4
+IGNORE_WITH_PHP= 4
.if defined(WITH_SUPHP)
diff --git a/print/phppdflib/Makefile b/print/phppdflib/Makefile
index b83612afadf3..944439ae6633 100644
--- a/print/phppdflib/Makefile
+++ b/print/phppdflib/Makefile
@@ -17,7 +17,7 @@ COMMENT= An easy to use API for creating PDF files dynamically
USE_PHP= yes
WANT_PHP_MOD= yes
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
WRKSRC= ${WRKDIR}/phppdflib
USE_BZIP2= yes
diff --git a/security/pecl-filter/Makefile b/security/pecl-filter/Makefile
index 274f237b1a3e..86650266ede1 100644
--- a/security/pecl-filter/Makefile
+++ b/security/pecl-filter/Makefile
@@ -24,7 +24,7 @@ USE_PHPEXT= yes
PHP_MODNAME= filter
DEFAULT_PHP_VER= 5
-BROKEN_WITH_VER= 4
+IGNORE_WITH_VER= 4
CONFIGURE_ARGS+= --with-pcre-dir=${LOCALBASE}
diff --git a/security/pfw/Makefile b/security/pfw/Makefile
index e0574f10d21e..eae4fb181288 100644
--- a/security/pfw/Makefile
+++ b/security/pfw/Makefile
@@ -21,7 +21,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_PHP= session pcre sqlite
WANT_PHP_WEB= yes
DEFAULT_PHP_VER=5
-BROKEN_WITH_PHP=4
+IGNORE_WITH_PHP=4
NO_BUILD= yes
PFW_PREFIX?= ${PREFIX}/www/pfw
diff --git a/security/php4-cryptopp/Makefile b/security/php4-cryptopp/Makefile
index 7cbcc4a274ee..8f0107c5ea6f 100644
--- a/security/php4-cryptopp/Makefile
+++ b/security/php4-cryptopp/Makefile
@@ -23,7 +23,7 @@ DOCSDIR= ${PREFIX}/share/doc/${PKGNAME}
USE_PERL5= yes
USE_PHP= yes
USE_PHPEXT= yes
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
DEFAULT_PHP_VER=4
CONFIGURE_ARGS= --with-cryptopp
diff --git a/shells/bush/Makefile b/shells/bush/Makefile
index e52cd1c953e6..46b60fab619b 100644
--- a/shells/bush/Makefile
+++ b/shells/bush/Makefile
@@ -30,7 +30,7 @@ MAKE_ENV= ADACFLAGS="${ADACFLAGS}"
MAKEFILE= GNUmakefile
USE_SDL= sdl image
USE_MYSQL= yes
-BROKEN_WITH_MYSQL= 323
+IGNORE_WITH_MYSQL= 323
REINPLACE_ARGS= -i ""
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/sysutils/dtc/Makefile b/sysutils/dtc/Makefile
index 5f64a488168a..657787b8b0c6 100644
--- a/sysutils/dtc/Makefile
+++ b/sysutils/dtc/Makefile
@@ -25,7 +25,7 @@ USE_PHP= mysql pcre session
.if defined(WITH_PHP5)
DEFAULT_PHP_VER=5
-BROKEN_WITH_PHP=4
+IGNORE_WITH_PHP=4
USE_PHP+= bz2 gd mbstring mcrypt mysql mysqli openssl pcre \
pear session sockets xml zlib
.endif
diff --git a/www/abcache/Makefile b/www/abcache/Makefile
index e308590dc316..42930f35bed5 100644
--- a/www/abcache/Makefile
+++ b/www/abcache/Makefile
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/bware_cache-${PORTVERSION}
USE_PHP= yes
USE_PHPIZE= yes
WITH_PHP_MOD= yes
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
DEFAULT_PHP_VER=4
CONFIGURE_ARGS+=--enable-bware_cache=shared
diff --git a/www/autoindex/Makefile b/www/autoindex/Makefile
index be4269317ea2..ad6611b9f47f 100644
--- a/www/autoindex/Makefile
+++ b/www/autoindex/Makefile
@@ -17,7 +17,7 @@ COMMENT= PHP 4.x script that makes a table that lists the files in a directory
WRKSRC= ${WRKDIR}/${PORTNAME}
-BROKEN_WITH_PHP= 5
+IGNORE_WITH_PHP= 5
USE_PHP= session
CONFLICTS= AutoIndex-2*
NO_BUILD= yes
diff --git a/www/autoindex2/Makefile b/www/autoindex2/Makefile
index f99efcebb066..07aced75da5a 100644
--- a/www/autoindex2/Makefile
+++ b/www/autoindex2/Makefile
@@ -18,7 +18,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_PHP= session
DEFAULT_PHP_VER= 5
-BROKEN_WITH_PHP= 4
+IGNORE_WITH_PHP= 4
CONFLICTS= AutoIndex-1*
LATEST_LINK= AutoIndex2
NO_BUILD= yes
diff --git a/www/campsite/Makefile b/www/campsite/Makefile
index 8c0b9eed7a73..6c9248dcfd73 100644
--- a/www/campsite/Makefile
+++ b/www/campsite/Makefile
@@ -32,7 +32,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_APACHE= YES
-BROKEN_WITH_PHP= 5
+IGNORE_WITH_PHP= 5
USE_PHP= mysql curl pcre xml xmlrpc
WANT_PHP_CLI= YES
USE_PHP_BUILD= YES
diff --git a/www/fluxcms/Makefile b/www/fluxcms/Makefile
index b244bb772484..bfedc6316322 100644
--- a/www/fluxcms/Makefile
+++ b/www/fluxcms/Makefile
@@ -28,6 +28,7 @@ OPTIONS= GD "Use GD support instead of ImageMagick" on \
USE_PHP= dom xml simplexml iconv mysql xsl session pcre
+IGNORE_WITH_PHP= 4
DEFAULT_PHP_VER= 5
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
diff --git a/www/mod_auth_cookie_mysql/Makefile b/www/mod_auth_cookie_mysql/Makefile
index ba90edb12d22..62aeca9cb7f2 100644
--- a/www/mod_auth_cookie_mysql/Makefile
+++ b/www/mod_auth_cookie_mysql/Makefile
@@ -18,7 +18,7 @@ COMMENT= Allows authentication against a MySQL database via a secure cookie
USE_MYSQL= YES
# If someone can test it with MySQL 4.1 ;-)
-BROKEN_WITH_MYSQL= 41
+IGNORE_WITH_MYSQL= 41
USE_APACHE= 13
diff --git a/www/mod_auth_cookie_mysql2/Makefile b/www/mod_auth_cookie_mysql2/Makefile
index 4c1d413d7bc9..e67e1ad65829 100644
--- a/www/mod_auth_cookie_mysql2/Makefile
+++ b/www/mod_auth_cookie_mysql2/Makefile
@@ -16,7 +16,7 @@ COMMENT= Allows authentication against a MySQL database via a secure cookie
USE_MYSQL= YES
# If someone can test it with MySQL 5.0 ;-)
-BROKEN_WITH_MYSQL= 50
+IGNORE_WITH_MYSQL= 50
USE_APACHE= 20+
diff --git a/www/php-dyn/Makefile b/www/php-dyn/Makefile
index 2c82aee6196a..94d8b5223151 100644
--- a/www/php-dyn/Makefile
+++ b/www/php-dyn/Makefile
@@ -19,7 +19,7 @@ COMMENT= A PHP Extension to help debugging a PHP script
USE_PHP= yes
USE_PHPIZE= yes
WITH_PHP_MOD= yes
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
DEFAULT_PHP_VER=4
CONFIGURE_ARGS= --enable-php_dyn=shared
diff --git a/www/php-screw/Makefile b/www/php-screw/Makefile
index 2ed9b53478f0..b6fd4afad6fd 100644
--- a/www/php-screw/Makefile
+++ b/www/php-screw/Makefile
@@ -22,7 +22,7 @@ CRYPTKEY?= 11152, 368, 192, 1281, 62
USE_PHP= yes
USE_PHPIZE= yes
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
DEFAULT_PHP_VER=4
CONFIGURE_ARGS+=--enable-php_screw=shared
diff --git a/www/php-templates/Makefile b/www/php-templates/Makefile
index b58b26789517..f1bcfcb3ce57 100644
--- a/www/php-templates/Makefile
+++ b/www/php-templates/Makefile
@@ -24,7 +24,7 @@ USE_DOS2UNIX= yes
USE_PHP= yes
USE_PHPIZE= yes
-BROKEN_WITH_PHP=5
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-templates=shared
diff --git a/www/siteframe/Makefile b/www/siteframe/Makefile
index 6beaf1499a90..6960fd2e9db0 100644
--- a/www/siteframe/Makefile
+++ b/www/siteframe/Makefile
@@ -19,10 +19,10 @@ USE_APACHE= yes
WITH_APACHE2= yes
USE_PHP= mysqli simplexml xml session gd
DEFAULT_PHP_VER= 5
-BROKEN_WITH_PHP= 4
+IGNORE_WITH_PHP= 4
USE_MYSQL= yes
DEFAULT_MYSQL_VER= 41
-BROKEN_WITH_MYSQL= 40
+IGNORE_WITH_MYSQL= 40
NO_PACKAGE= Conflicting Apache dependencies
diff --git a/www/usermanager/Makefile b/www/usermanager/Makefile
index 6fdf74777e65..2890c7a25f98 100644
--- a/www/usermanager/Makefile
+++ b/www/usermanager/Makefile
@@ -16,7 +16,7 @@ COMMENT= Easily create, change, or delete virtual PureFTPd users
WRKSRC= ${WRKDIR}/ftp
-BROKEN_WITH_PHP= 5
+IGNORE_WITH_PHP= 5
USE_PHP= mysql pcre posix session
NO_BUILD= yes
diff --git a/www/xaraya/Makefile b/www/xaraya/Makefile
index 7bbe86112428..e13a30277b14 100644
--- a/www/xaraya/Makefile
+++ b/www/xaraya/Makefile
@@ -22,7 +22,7 @@ USE_PHP= pgsql
.else
USE_PHP= mysql
.endif
-BROKEN_WITH_PHP= 5
+IGNORE_WITH_PHP= 5
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-1.0.0-rc3
diff --git a/x11-toolkits/php-gtk/Makefile b/x11-toolkits/php-gtk/Makefile
index d5c4980dc4c7..bc66e5edddbc 100644
--- a/x11-toolkits/php-gtk/Makefile
+++ b/x11-toolkits/php-gtk/Makefile
@@ -20,7 +20,7 @@ GNU_CONFIGURE= yes
USE_PHP= pcre
USE_PHP_BUILD= yes
WANT_PHP_CLI= yes
-BROKEN_WITH_PHP= 5
+IGNORE_WITH_PHP= 5
USE_GMAKE= yes
USE_PERL5_BUILD=yes
USE_GNOME= gtk12
diff --git a/x11-toolkits/php-gtk2/Makefile b/x11-toolkits/php-gtk2/Makefile
index d5c4980dc4c7..bc66e5edddbc 100644
--- a/x11-toolkits/php-gtk2/Makefile
+++ b/x11-toolkits/php-gtk2/Makefile
@@ -20,7 +20,7 @@ GNU_CONFIGURE= yes
USE_PHP= pcre
USE_PHP_BUILD= yes
WANT_PHP_CLI= yes
-BROKEN_WITH_PHP= 5
+IGNORE_WITH_PHP= 5
USE_GMAKE= yes
USE_PERL5_BUILD=yes
USE_GNOME= gtk12