aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--biology/lsysexp/Makefile2
-rw-r--r--deskutils/xpad/Makefile2
-rw-r--r--x11-toolkits/gnocl/Makefile2
3 files changed, 6 insertions, 0 deletions
diff --git a/biology/lsysexp/Makefile b/biology/lsysexp/Makefile
index 333d5c831b0d..1bf6691f5919 100644
--- a/biology/lsysexp/Makefile
+++ b/biology/lsysexp/Makefile
@@ -20,4 +20,6 @@ USE_X_PREFIX= yes
USE_GNOME= gtk20
GNU_CONFIGURE= yes
+BROKEN= "Does not build with gtk+-2.4"
+
.include <bsd.port.mk>
diff --git a/deskutils/xpad/Makefile b/deskutils/xpad/Makefile
index 54eb2b5285fd..932eb80d6c0b 100644
--- a/deskutils/xpad/Makefile
+++ b/deskutils/xpad/Makefile
@@ -28,6 +28,8 @@ CONFIGURE_ARGS= --prefix=${PREFIX}
MAN1= xpad.1
MANCOMPRESSED= no
+BROKEN= "Does not build with gtk+-2.4"
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/xpad ${PREFIX}/bin/
diff --git a/x11-toolkits/gnocl/Makefile b/x11-toolkits/gnocl/Makefile
index bfafae8b599b..059b7043fb5b 100644
--- a/x11-toolkits/gnocl/Makefile
+++ b/x11-toolkits/gnocl/Makefile
@@ -27,6 +27,8 @@ CFLAGS+= -I${LOCALBASE}/include/tcl8.4
USE_X_PREFIX= yes
USE_GNOME= gtk20
+BROKEN= "Does not build with gtk+-2.4"
+
.include <bsd.port.pre.mk>
.if ${ARCH} == amd64