aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/mod_php4/Makefile3
-rw-r--r--www/mod_php4/distinfo4
-rw-r--r--www/mod_php4/files/patch-aq72
-rw-r--r--www/mod_php4/scripts/configure.php4
-rw-r--r--www/mod_php5/Makefile3
-rw-r--r--www/mod_php5/distinfo4
-rw-r--r--www/mod_php5/files/patch-aq72
-rw-r--r--www/mod_php5/scripts/configure.php4
8 files changed, 12 insertions, 154 deletions
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index e24e54cd0e6c..d78f78e07974 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -20,7 +20,7 @@ MASTER_SITES= http://us.php.net/${PHP_DISTDIR}/ \
http://php3.globe.de/${PHP_DISTDIR}/
DISTNAME= php-${PORTVERSION}
-PATCHFILES= php_configure.3.diff
+PATCHFILES= patch-ext_gd_config.m4 patch-ext_gd_gd.c patch-ext_sybase_ct_config.m4
PATCH_SITES= http://www.physik.tu-berlin.de/~ibex/ports/distfiles/ \
${MASTER_SITE_LOCAL}/dirk/
@@ -35,6 +35,7 @@ PHP_DISTDIR= distributions
SLAVEDIRS= lang/php4
+USE_AUTOCONF= yes
USE_LIBTOOL= yes
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
diff --git a/www/mod_php4/distinfo b/www/mod_php4/distinfo
index e5a4849eb159..322819f1515f 100644
--- a/www/mod_php4/distinfo
+++ b/www/mod_php4/distinfo
@@ -1,3 +1,5 @@
MD5 (php-4.0.6.tar.gz) = 5f698521cf2b392cf9bfa87fc1a0fe90
MD5 (php4_mbregex-1.2.1.tar.gz) = 46d151afa9ab668df880a70cf786a2c2
-MD5 (php_configure.3.diff) = 7c67a6879505e44b6424ccbcdf7bcefe
+MD5 (patch-ext_gd_config.m4) = b4fb911d11e6bb4e8e712407de7600bb
+MD5 (patch-ext_gd_gd.c) = f83c2a0433c744c7b7b03fe2533ed7d9
+MD5 (patch-ext_sybase_ct_config.m4) = ec731e9b05af2eb3e8ac12a0231d9a8b
diff --git a/www/mod_php4/files/patch-aq b/www/mod_php4/files/patch-aq
deleted file mode 100644
index 690602617f98..000000000000
--- a/www/mod_php4/files/patch-aq
+++ /dev/null
@@ -1,72 +0,0 @@
---- configure.orig Mon Apr 30 15:47:59 2001
-+++ configure Fri May 4 00:14:24 2001
-@@ -45273,18 +45273,6 @@
- fi
-
-
-- case "cs" in
-- c|c_r|pthread*) ;;
-- *)
--
--
-- LIBS="-lcs $LIBS"
--
--
-- ;;
-- esac
--
--
- case "ct" in
- c|c_r|pthread*) ;;
- *)
-@@ -45296,31 +45284,7 @@
- ;;
- esac
-
--
-- case "comn" in
-- c|c_r|pthread*) ;;
-- *)
--
--
-- LIBS="-lcomn $LIBS"
--
--
-- ;;
-- esac
--
--
-- case "intl" in
-- c|c_r|pthread*) ;;
-- *)
--
--
-- LIBS="-lintl $LIBS"
--
--
-- ;;
-- esac
--
-- SYBASE_CT_LIBS="-lcs -lct -lcomn -lintl"
-+ SYBASE_CT_LIBS="-lct"
- old_LDFLAGS=$LDFLAGS
- LDFLAGS="$LDFLAGS -L$SYBASE_CT_LIBDIR"
- echo $ac_n "checking for netg_errstr in -ltcl""... $ac_c" 1>&6
-@@ -45372,17 +45336,6 @@
-
- else
- echo "$ac_t""no" 1>&6
--
-- case "sybtcl" in
-- c|c_r|pthread*) ;;
-- *)
--
--
-- LIBS="-lsybtcl $LIBS"
--
--
-- ;;
-- esac
-
- fi
-
diff --git a/www/mod_php4/scripts/configure.php b/www/mod_php4/scripts/configure.php
index a966efb2f5f3..fb4694e1e2da 100644
--- a/www/mod_php4/scripts/configure.php
+++ b/www/mod_php4/scripts/configure.php
@@ -240,9 +240,7 @@ POSTEXTRACT+= post-extract-mbregex
post-extract-mbregex:
[ -d \${WRKDIR}/mbregex ] && \\
(cd \${WRKSRC}; \\
- \${MV} ${WRKDIR}/mbregex ext; \\
- \${RM} configure; \\
- ./buildconf)
+ \${MV} ${WRKDIR}/mbregex ext)
EOF
;;
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index e24e54cd0e6c..d78f78e07974 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -20,7 +20,7 @@ MASTER_SITES= http://us.php.net/${PHP_DISTDIR}/ \
http://php3.globe.de/${PHP_DISTDIR}/
DISTNAME= php-${PORTVERSION}
-PATCHFILES= php_configure.3.diff
+PATCHFILES= patch-ext_gd_config.m4 patch-ext_gd_gd.c patch-ext_sybase_ct_config.m4
PATCH_SITES= http://www.physik.tu-berlin.de/~ibex/ports/distfiles/ \
${MASTER_SITE_LOCAL}/dirk/
@@ -35,6 +35,7 @@ PHP_DISTDIR= distributions
SLAVEDIRS= lang/php4
+USE_AUTOCONF= yes
USE_LIBTOOL= yes
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
diff --git a/www/mod_php5/distinfo b/www/mod_php5/distinfo
index e5a4849eb159..322819f1515f 100644
--- a/www/mod_php5/distinfo
+++ b/www/mod_php5/distinfo
@@ -1,3 +1,5 @@
MD5 (php-4.0.6.tar.gz) = 5f698521cf2b392cf9bfa87fc1a0fe90
MD5 (php4_mbregex-1.2.1.tar.gz) = 46d151afa9ab668df880a70cf786a2c2
-MD5 (php_configure.3.diff) = 7c67a6879505e44b6424ccbcdf7bcefe
+MD5 (patch-ext_gd_config.m4) = b4fb911d11e6bb4e8e712407de7600bb
+MD5 (patch-ext_gd_gd.c) = f83c2a0433c744c7b7b03fe2533ed7d9
+MD5 (patch-ext_sybase_ct_config.m4) = ec731e9b05af2eb3e8ac12a0231d9a8b
diff --git a/www/mod_php5/files/patch-aq b/www/mod_php5/files/patch-aq
deleted file mode 100644
index 690602617f98..000000000000
--- a/www/mod_php5/files/patch-aq
+++ /dev/null
@@ -1,72 +0,0 @@
---- configure.orig Mon Apr 30 15:47:59 2001
-+++ configure Fri May 4 00:14:24 2001
-@@ -45273,18 +45273,6 @@
- fi
-
-
-- case "cs" in
-- c|c_r|pthread*) ;;
-- *)
--
--
-- LIBS="-lcs $LIBS"
--
--
-- ;;
-- esac
--
--
- case "ct" in
- c|c_r|pthread*) ;;
- *)
-@@ -45296,31 +45284,7 @@
- ;;
- esac
-
--
-- case "comn" in
-- c|c_r|pthread*) ;;
-- *)
--
--
-- LIBS="-lcomn $LIBS"
--
--
-- ;;
-- esac
--
--
-- case "intl" in
-- c|c_r|pthread*) ;;
-- *)
--
--
-- LIBS="-lintl $LIBS"
--
--
-- ;;
-- esac
--
-- SYBASE_CT_LIBS="-lcs -lct -lcomn -lintl"
-+ SYBASE_CT_LIBS="-lct"
- old_LDFLAGS=$LDFLAGS
- LDFLAGS="$LDFLAGS -L$SYBASE_CT_LIBDIR"
- echo $ac_n "checking for netg_errstr in -ltcl""... $ac_c" 1>&6
-@@ -45372,17 +45336,6 @@
-
- else
- echo "$ac_t""no" 1>&6
--
-- case "sybtcl" in
-- c|c_r|pthread*) ;;
-- *)
--
--
-- LIBS="-lsybtcl $LIBS"
--
--
-- ;;
-- esac
-
- fi
-
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index a966efb2f5f3..fb4694e1e2da 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -240,9 +240,7 @@ POSTEXTRACT+= post-extract-mbregex
post-extract-mbregex:
[ -d \${WRKDIR}/mbregex ] && \\
(cd \${WRKSRC}; \\
- \${MV} ${WRKDIR}/mbregex ext; \\
- \${RM} configure; \\
- ./buildconf)
+ \${MV} ${WRKDIR}/mbregex ext)
EOF
;;