aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/links/Makefile3
-rw-r--r--www/links/distinfo2
-rw-r--r--www/links/files/patch-default.c44
-rw-r--r--www/links/files/patch-links.h8
4 files changed, 5 insertions, 52 deletions
diff --git a/www/links/Makefile b/www/links/Makefile
index bd68745e11a9..62433290a27a 100644
--- a/www/links/Makefile
+++ b/www/links/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= links
-PORTVERSION= 0.97.p9
+PORTVERSION= 0.97
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://artax.karlin.mff.cuni.cz/~mikulas/vyplody/links/download/ \
http://www.add.com.pl/links/download/ \
http://ice.dammit.lt/links/download/ \
http://links.sourceforge.net/download/
-DISTNAME= ${PORTNAME}-0.97pre7
MAINTAINER= demon@FreeBSD.org
diff --git a/www/links/distinfo b/www/links/distinfo
index c6115479e801..38fa1daa4f21 100644
--- a/www/links/distinfo
+++ b/www/links/distinfo
@@ -1 +1 @@
-MD5 (links-0.97pre7.tar.gz) = 67335b7d1938579932900e54219b868c
+MD5 (links-0.97.tar.gz) = 57d4ade86c49038b3d4bab66ad24c066
diff --git a/www/links/files/patch-default.c b/www/links/files/patch-default.c
index eb6440ef05d2..5ccd03bad611 100644
--- a/www/links/files/patch-default.c
+++ b/www/links/files/patch-default.c
@@ -1,6 +1,6 @@
---- default.c.orig Wed Jan 30 06:53:48 2002
-+++ default.c Fri Apr 26 09:12:21 2002
-@@ -265,7 +265,7 @@
+--- default.c.orig Sun May 19 20:12:20 2002
++++ default.c Sun May 19 20:12:23 2002
+@@ -267,7 +267,7 @@
get_system_name();
links_home = get_home(&first_use);
if (!links_home) {
@@ -9,41 +9,3 @@
sleep(3);
return;
}
-@@ -697,6 +697,11 @@
- anonymous = 1;
- return NULL;
- }
-+unsigned char *force_html_cmd(struct option *o, unsigned char ***argv, int *argc)
-+{
-+ force_html = 1;
-+ return NULL;
-+}
- unsigned char *dump_cmd(struct option *o, unsigned char ***argv, int *argc)
- {
- if (dmp != o->min && dmp) return "Can't use both -dump and -source";
-@@ -769,6 +774,9 @@
- is allowed, but user can't add or modify entries in\n\
- association table.\n\
- \n\
-+ -force-html\n\
-+ Treat file as if it had an .html extension.\n\
-+\n\
- -dump\n\
- Write a plain-text version of the given HTML document to\n\
- stdout.\n\
-@@ -826,6 +834,7 @@
- int no_connect = 0;
- int base_session = 0;
- int dmp = 0;
-+int force_html = 0;
-
- int async_lookup = 1;
- int download_utime = 0;
-@@ -877,6 +886,7 @@
- 1, no_connect_cmd, NULL, NULL, 0, 0, NULL, NULL, "no-connect",
- 1, anonymous_cmd, NULL, NULL, 0, 0, NULL, NULL, "anonymous",
- 1, gen_cmd, num_rd, NULL, 0, MAXINT, &base_session, NULL, "base-session",
-+ 1, force_html_cmd, NULL, NULL, 0, 0, NULL, NULL, "force-html",
- 1, dump_cmd, NULL, NULL, D_DUMP, 0, NULL, NULL, "dump",
- 1, dump_cmd, NULL, NULL, D_SOURCE, 0, NULL, NULL, "source",
- 1, gen_cmd, num_rd, num_wr, 0, 1, &async_lookup, "async_dns", "async-dns",
diff --git a/www/links/files/patch-links.h b/www/links/files/patch-links.h
deleted file mode 100644
index ce098ddeb897..000000000000
--- a/www/links/files/patch-links.h
+++ /dev/null
@@ -1,8 +0,0 @@
---- links.h.orig Sat Mar 2 05:35:30 2002
-+++ links.h Fri Apr 26 09:11:47 2002
-@@ -1984,4 +1984,5 @@
- extern int no_connect;
- extern int base_session;
-+extern int force_html;
-
- #define D_DUMP 1