aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/vmware-guestd/Makefile3
-rw-r--r--emulators/vmware-guestd3/Makefile3
-rw-r--r--emulators/vmware-guestd4/Makefile3
-rw-r--r--emulators/vmware-guestd5/Makefile3
-rw-r--r--emulators/vmware-guestd6/Makefile3
-rw-r--r--emulators/vmware-tools3/Makefile3
-rw-r--r--emulators/vmware-tools4/Makefile3
-rw-r--r--emulators/vmware-tools5/Makefile3
-rw-r--r--emulators/vmware-tools6/Makefile3
9 files changed, 27 insertions, 0 deletions
diff --git a/emulators/vmware-guestd/Makefile b/emulators/vmware-guestd/Makefile
index bbdb999babad..aa0049306b7b 100644
--- a/emulators/vmware-guestd/Makefile
+++ b/emulators/vmware-guestd/Makefile
@@ -23,6 +23,9 @@ ONLY_FOR_ARCHS= i386
NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
+.if defined(PACKAGE_BUILDING)
+FORBIDDEN= "Can't build this port since it requires VMware."
+.endif
VMWARE_VER= 3.1.1
BUILD_VER= 1790
diff --git a/emulators/vmware-guestd3/Makefile b/emulators/vmware-guestd3/Makefile
index bbdb999babad..aa0049306b7b 100644
--- a/emulators/vmware-guestd3/Makefile
+++ b/emulators/vmware-guestd3/Makefile
@@ -23,6 +23,9 @@ ONLY_FOR_ARCHS= i386
NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
+.if defined(PACKAGE_BUILDING)
+FORBIDDEN= "Can't build this port since it requires VMware."
+.endif
VMWARE_VER= 3.1.1
BUILD_VER= 1790
diff --git a/emulators/vmware-guestd4/Makefile b/emulators/vmware-guestd4/Makefile
index bbdb999babad..aa0049306b7b 100644
--- a/emulators/vmware-guestd4/Makefile
+++ b/emulators/vmware-guestd4/Makefile
@@ -23,6 +23,9 @@ ONLY_FOR_ARCHS= i386
NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
+.if defined(PACKAGE_BUILDING)
+FORBIDDEN= "Can't build this port since it requires VMware."
+.endif
VMWARE_VER= 3.1.1
BUILD_VER= 1790
diff --git a/emulators/vmware-guestd5/Makefile b/emulators/vmware-guestd5/Makefile
index bbdb999babad..aa0049306b7b 100644
--- a/emulators/vmware-guestd5/Makefile
+++ b/emulators/vmware-guestd5/Makefile
@@ -23,6 +23,9 @@ ONLY_FOR_ARCHS= i386
NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
+.if defined(PACKAGE_BUILDING)
+FORBIDDEN= "Can't build this port since it requires VMware."
+.endif
VMWARE_VER= 3.1.1
BUILD_VER= 1790
diff --git a/emulators/vmware-guestd6/Makefile b/emulators/vmware-guestd6/Makefile
index bbdb999babad..aa0049306b7b 100644
--- a/emulators/vmware-guestd6/Makefile
+++ b/emulators/vmware-guestd6/Makefile
@@ -23,6 +23,9 @@ ONLY_FOR_ARCHS= i386
NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
+.if defined(PACKAGE_BUILDING)
+FORBIDDEN= "Can't build this port since it requires VMware."
+.endif
VMWARE_VER= 3.1.1
BUILD_VER= 1790
diff --git a/emulators/vmware-tools3/Makefile b/emulators/vmware-tools3/Makefile
index 50e5d5ee8ecb..eee6600450fa 100644
--- a/emulators/vmware-tools3/Makefile
+++ b/emulators/vmware-tools3/Makefile
@@ -25,6 +25,9 @@ USE_X_PREFIX= yes
NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
+.if defined(PACKAGE_BUILDING)
+FORBIDDEN= "Can't build this port since it requires VMware."
+.endif
VMWARE_VER= 3.1.1
BUILD_VER= 1790
diff --git a/emulators/vmware-tools4/Makefile b/emulators/vmware-tools4/Makefile
index 50e5d5ee8ecb..eee6600450fa 100644
--- a/emulators/vmware-tools4/Makefile
+++ b/emulators/vmware-tools4/Makefile
@@ -25,6 +25,9 @@ USE_X_PREFIX= yes
NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
+.if defined(PACKAGE_BUILDING)
+FORBIDDEN= "Can't build this port since it requires VMware."
+.endif
VMWARE_VER= 3.1.1
BUILD_VER= 1790
diff --git a/emulators/vmware-tools5/Makefile b/emulators/vmware-tools5/Makefile
index 50e5d5ee8ecb..eee6600450fa 100644
--- a/emulators/vmware-tools5/Makefile
+++ b/emulators/vmware-tools5/Makefile
@@ -25,6 +25,9 @@ USE_X_PREFIX= yes
NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
+.if defined(PACKAGE_BUILDING)
+FORBIDDEN= "Can't build this port since it requires VMware."
+.endif
VMWARE_VER= 3.1.1
BUILD_VER= 1790
diff --git a/emulators/vmware-tools6/Makefile b/emulators/vmware-tools6/Makefile
index 50e5d5ee8ecb..eee6600450fa 100644
--- a/emulators/vmware-tools6/Makefile
+++ b/emulators/vmware-tools6/Makefile
@@ -25,6 +25,9 @@ USE_X_PREFIX= yes
NO_BUILD= yes
RESTRICTED= "Not sure if we can redistribute this."
+.if defined(PACKAGE_BUILDING)
+FORBIDDEN= "Can't build this port since it requires VMware."
+.endif
VMWARE_VER= 3.1.1
BUILD_VER= 1790