aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-HTML-Clean/Makefile24
-rw-r--r--www/p5-HTML-Clean/distinfo1
-rw-r--r--www/p5-HTML-Clean/pkg-comment1
-rw-r--r--www/p5-HTML-Clean/pkg-descr19
-rw-r--r--www/p5-HTML-Clean/pkg-plist9
6 files changed, 55 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index bb59042b11a3..903010f0399e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -168,6 +168,7 @@
SUBDIR += p5-FastCGI
SUBDIR += p5-GtkHTML
SUBDIR += p5-HTML
+ SUBDIR += p5-HTML-Clean
SUBDIR += p5-HTML-Embperl
SUBDIR += p5-HTML-Mason
SUBDIR += p5-HTML-Navigation
diff --git a/www/p5-HTML-Clean/Makefile b/www/p5-HTML-Clean/Makefile
new file mode 100644
index 000000000000..ec64f9ed4b60
--- /dev/null
+++ b/www/p5-HTML-Clean/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-HTML-Clean
+# Date created: March 30th 2001
+# Whom: Alex Kapranoff <kapr@crosswinds.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-Clean
+PORTVERSION= 0.8
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kapr@crosswinds.net
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= INSTALLMAN1DIR=${MANPREFIX}/man/man1
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= HTML::Clean.3
+MAN1= htmlclean.1
+
+.include <bsd.port.mk>
diff --git a/www/p5-HTML-Clean/distinfo b/www/p5-HTML-Clean/distinfo
new file mode 100644
index 000000000000..2fd1079385da
--- /dev/null
+++ b/www/p5-HTML-Clean/distinfo
@@ -0,0 +1 @@
+MD5 (HTML-Clean-0.8.tar.gz) = ee562703b7700c7fd4173f355e83ec2c
diff --git a/www/p5-HTML-Clean/pkg-comment b/www/p5-HTML-Clean/pkg-comment
new file mode 100644
index 000000000000..bb0ede031add
--- /dev/null
+++ b/www/p5-HTML-Clean/pkg-comment
@@ -0,0 +1 @@
+Cleans up HTML code for web browsers, not humans
diff --git a/www/p5-HTML-Clean/pkg-descr b/www/p5-HTML-Clean/pkg-descr
new file mode 100644
index 000000000000..125a6c900350
--- /dev/null
+++ b/www/p5-HTML-Clean/pkg-descr
@@ -0,0 +1,19 @@
+The majority of the web pages of the internet today are
+much larger than they need to be. The reason for this is
+that HTML tends to be stored in a human readable format, with
+indenting, newlines and comments.
+
+However, all of these comments, whitespace etc. are ignored by
+the browser, and needlessly lengthen download times.
+
+Second, many people are using WYSIWYG HTML editors these days.
+This makes creating content easy. However these editors can
+cause a number of compatibility problems by tying themselves to
+a particular browser or operating system.
+
+The HTML::Clean module encapsulates a number of HTML optimizations
+and cleanups. The end result is HTML that loads faster, displays
+properly in more browsers. Think of it as a compiler that
+translates HTML input into optimized machine readable code.
+
+-- Alex Kapranoff <kapr@crosswinds.net>
diff --git a/www/p5-HTML-Clean/pkg-plist b/www/p5-HTML-Clean/pkg-plist
new file mode 100644
index 000000000000..12e8f7250105
--- /dev/null
+++ b/www/p5-HTML-Clean/pkg-plist
@@ -0,0 +1,9 @@
+bin/htmlclean
+lib/perl5/site_perl/%%PERL_VER%%/HTML/Clean.pm
+@unexec rmdir lib/perl5/site_perl/%%PERL_VER%%/HTML 2>/dev/null || true
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML/Clean/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML/Clean
+@unexec rmdir lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/HTML 2>/dev/null|| true
+lib/perl5/site_perl/%%PERL_VER%%/auto/HTML/Clean/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/auto/HTML/Clean
+@unexec rmdir lib/perl5/site_perl/%%PERL_VER%%/auto/HTML 2>/dev/null || true