aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/yabause/Makefile16
-rw-r--r--emulators/yabause/distinfo4
-rw-r--r--emulators/yabause/files/patch-autogen.sh7
-rw-r--r--emulators/yabause/files/patch-src-gtk_Makefile.in10
-rw-r--r--emulators/yabause/files/patch-src-qt_Makefile.in10
-rw-r--r--emulators/yabause/pkg-plist1
6 files changed, 21 insertions, 27 deletions
diff --git a/emulators/yabause/Makefile b/emulators/yabause/Makefile
index c754183ddaf8..9cb834b9b4bc 100644
--- a/emulators/yabause/Makefile
+++ b/emulators/yabause/Makefile
@@ -6,16 +6,16 @@
#
PORTNAME= yabause
-PORTVERSION= 0.9.10
-PORTREVISION= 1
+PORTVERSION= 0.9.11.1
CATEGORIES= emulators
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:S/1.1/1/g}/
MAINTAINER= acm@FreeBSD.org
COMMENT= Sega Saturn system emulator
-LIB_DEPENDS= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext \
+LIB_DEPENDS= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+USE_AUTOTOOLS= automake:env autoconf:env aclocal:env
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GL= gl glu glut
@@ -39,6 +39,14 @@ USE_GNOME= gtk20
CONFIGURE_ARGS+= --with-port=gtk
.endif
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%ACLOCAL%%|${ACLOCAL}|g" -e "s|%%AUTOCONF%%|${AUTOCONF}|g" \
+ -e "s|%%AUTOMAKE%%|${AUTOMAKE}|g" ${WRKSRC}/autogen.sh
+ @${REINPLACE_CMD} -e "s|0.9.10|${PORTVERSION}|g" ${WRKSRC}/configure.in
+
+pre-configure:
+ @cd ${WRKSRC} && ${SH} autogen.sh
+
post-install:
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
diff --git a/emulators/yabause/distinfo b/emulators/yabause/distinfo
index 7f058f5cde87..4cb39e6e0373 100644
--- a/emulators/yabause/distinfo
+++ b/emulators/yabause/distinfo
@@ -1,2 +1,2 @@
-SHA256 (yabause-0.9.10.tar.gz) = 2f15ea32d4d1226fd1bebf6b107ae9faa71fe230608f01a5b0105c2b2faa78be
-SIZE (yabause-0.9.10.tar.gz) = 1376089
+SHA256 (yabause-0.9.11.1.tar.gz) = 42538eb31232f8bdd2e6e19ad797d556e6e787b57ac0a2a21e0fe7c407b32bca
+SIZE (yabause-0.9.11.1.tar.gz) = 1882934
diff --git a/emulators/yabause/files/patch-autogen.sh b/emulators/yabause/files/patch-autogen.sh
new file mode 100644
index 000000000000..5ee28379acbf
--- /dev/null
+++ b/emulators/yabause/files/patch-autogen.sh
@@ -0,0 +1,7 @@
+--- autogen.sh.orig 2012-03-25 20:41:13.000000000 -0500
++++ autogen.sh 2012-03-25 20:42:38.000000000 -0500
+@@ -1,2 +1,2 @@
+-aclocal && autoconf && automake --add-missing --copy
+-cd src/c68k && aclocal && autoconf && automake
++%%ACLOCAL%% && %%AUTOCONF%% && %%AUTOMAKE%% --add-missing --copy
++cd src/c68k && %%ACLOCAL%% && %%AUTOCONF%% && %%AUTOMAKE%%
diff --git a/emulators/yabause/files/patch-src-gtk_Makefile.in b/emulators/yabause/files/patch-src-gtk_Makefile.in
deleted file mode 100644
index c6ca2c4d5f41..000000000000
--- a/emulators/yabause/files/patch-src-gtk_Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/gtk/Makefile.in 2011-06-24 19:03:30.000000000 -0500
-+++ src/gtk/Makefile.in 2011-06-24 19:03:40.000000000 -0500
-@@ -900,7 +900,6 @@
-
- install-data-am: install-ApplicationsDATA install-pixmapDATA
- @$(NORMAL_INSTALL)
-- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
-
- install-dvi: install-dvi-recursive
-
diff --git a/emulators/yabause/files/patch-src-qt_Makefile.in b/emulators/yabause/files/patch-src-qt_Makefile.in
deleted file mode 100644
index cc9753230bc7..000000000000
--- a/emulators/yabause/files/patch-src-qt_Makefile.in
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/qt/Makefile.in 2011-06-24 19:20:24.000000000 -0500
-+++ src/qt/Makefile.in 2011-06-24 19:20:35.000000000 -0500
-@@ -521,7 +521,6 @@
-
- install-data-am: install-ApplicationsDATA install-pixmapDATA
- @$(NORMAL_INSTALL)
-- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
-
- install-dvi: install-dvi-recursive
-
diff --git a/emulators/yabause/pkg-plist b/emulators/yabause/pkg-plist
index b381824fc8dd..e808508dbb34 100644
--- a/emulators/yabause/pkg-plist
+++ b/emulators/yabause/pkg-plist
@@ -8,7 +8,6 @@ bin/yabause
%%DATADIR%%/yts/pt_BR.yts
%%DATADIR%%/yts/sv.yts
share/pixmaps/yabause.png
-share/applications/yabause.desktop
@dirrmtry share/yabause/yts
@dirrmtry share/yabause
@dirrmtry share/applications