aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-asciitree/Makefile20
-rw-r--r--graphics/py-asciitree/distinfo3
-rw-r--r--graphics/py-asciitree/pkg-descr3
4 files changed, 27 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 237e4e37088a..7b61f2889e0d 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -829,6 +829,7 @@
SUBDIR += py-PyOpenGL-accelerate
SUBDIR += py-actdiag
SUBDIR += py-altair
+ SUBDIR += py-asciitree
SUBDIR += py-beziers
SUBDIR += py-blockdiag
SUBDIR += py-blockdiagcontrib-cisco
diff --git a/graphics/py-asciitree/Makefile b/graphics/py-asciitree/Makefile
new file mode 100644
index 000000000000..c024f1bb8cff
--- /dev/null
+++ b/graphics/py-asciitree/Makefile
@@ -0,0 +1,20 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= asciitree
+PORTVERSION= 0.3.3
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Draws ASCII trees
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-asciitree/distinfo b/graphics/py-asciitree/distinfo
new file mode 100644
index 000000000000..9e263f0acbef
--- /dev/null
+++ b/graphics/py-asciitree/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1648681330
+SHA256 (asciitree-0.3.3.tar.gz) = 4aa4b9b649f85e3fcb343363d97564aa1fb62e249677f2e18a96765145cc0f6e
+SIZE (asciitree-0.3.3.tar.gz) = 3951
diff --git a/graphics/py-asciitree/pkg-descr b/graphics/py-asciitree/pkg-descr
new file mode 100644
index 000000000000..331029612c63
--- /dev/null
+++ b/graphics/py-asciitree/pkg-descr
@@ -0,0 +1,3 @@
+asciitree draws tree structures using characters.
+
+WWW: https://github.com/mbr/asciitree