aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--benchmarks/iperf/Makefile4
-rw-r--r--benchmarks/iperf/distinfo6
-rw-r--r--benchmarks/iperf/files/patch-compat-gettcpinfo.c9
3 files changed, 14 insertions, 5 deletions
diff --git a/benchmarks/iperf/Makefile b/benchmarks/iperf/Makefile
index d488a0a7fb9a..f15a8dc927d7 100644
--- a/benchmarks/iperf/Makefile
+++ b/benchmarks/iperf/Makefile
@@ -1,10 +1,10 @@
# Created by: Pete Fritchman <petef@databits.net>
PORTNAME= iperf
-PORTVERSION= 2.1.4
+PORTVERSION= 2.1.6
CATEGORIES= benchmarks
MASTER_SITES= SF/iperf2 \
- LOCAL/sunpoet/iperf/20210818
+ LOCAL/sunpoet/iperf/20211210
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Tool to measure maximum TCP and UDP bandwidth
diff --git a/benchmarks/iperf/distinfo b/benchmarks/iperf/distinfo
index c0f6b15a5ca9..3d604aedcd11 100644
--- a/benchmarks/iperf/distinfo
+++ b/benchmarks/iperf/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1632036844
-SHA256 (iperf-2.1.4.tar.gz) = 062b392e87b8e227aca74fef0a99b04fe0382d4518957041b508a56885b4d4f9
-SIZE (iperf-2.1.4.tar.gz) = 395909
+TIMESTAMP = 1641045782
+SHA256 (iperf-2.1.6.tar.gz) = 4a43e44439b95622aebeee55754a17d1c94076032e90620dfc1ab9908cb9e080
+SIZE (iperf-2.1.6.tar.gz) = 401258
diff --git a/benchmarks/iperf/files/patch-compat-gettcpinfo.c b/benchmarks/iperf/files/patch-compat-gettcpinfo.c
new file mode 100644
index 000000000000..4bdfaa118032
--- /dev/null
+++ b/benchmarks/iperf/files/patch-compat-gettcpinfo.c
@@ -0,0 +1,9 @@
+--- compat/gettcpinfo.c.orig 2021-12-11 04:24:44 UTC
++++ compat/gettcpinfo.c
+@@ -97,6 +97,4 @@ inline void gettcpinfo (SOCKET sock, struct ReportStru
+ sample->tcpstats.rtt = 1;
+ sample->tcpstats.isValid = false;
+ };
+-#else
+-inline void gettcpinfo (int sock, struct ReportStruct *sample) {
+ #endif