aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/p5-Math-GSL/Makefile6
-rw-r--r--math/p5-Math-GSL/distinfo6
-rw-r--r--math/p5-Math-GSL/files/patch-inc-GSLBuilder.pm6
-rw-r--r--math/p5-Math-GSL/files/patch-inc_Ver2Func.pm15
4 files changed, 9 insertions, 24 deletions
diff --git a/math/p5-Math-GSL/Makefile b/math/p5-Math-GSL/Makefile
index b4972fae9a3f..613fe171de9f 100644
--- a/math/p5-Math-GSL/Makefile
+++ b/math/p5-Math-GSL/Makefile
@@ -1,8 +1,7 @@
# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
PORTNAME= Math-GSL
-PORTVERSION= 0.42
-PORTREVISION= 1
+PORTVERSION= 0.43
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -13,7 +12,8 @@ COMMENT= Perl interface to GNU Scientific Library
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-PkgConfig>=0.07720:devel/p5-PkgConfig
+BUILD_DEPENDS= p5-PkgConfig>=0.07720:devel/p5-PkgConfig \
+ p5-Alien-GSL>=1.01:math/p5-Alien-GSL
LIB_DEPENDS= libgsl.so:math/gsl
TEST_DEPENDS= p5-Test-Class>=0.12:devel/p5-Test-Class \
p5-Test-Exception>=0.21:devel/p5-Test-Exception \
diff --git a/math/p5-Math-GSL/distinfo b/math/p5-Math-GSL/distinfo
index 6f0111a36541..fec8220a6fbc 100644
--- a/math/p5-Math-GSL/distinfo
+++ b/math/p5-Math-GSL/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1592299409
-SHA256 (Math-GSL-0.42.tar.gz) = e16c10c98e28ad4c6be38550711fa8a9c51984d4894801b29f2da8f20794bd62
-SIZE (Math-GSL-0.42.tar.gz) = 21584967
+TIMESTAMP = 1627708695
+SHA256 (Math-GSL-0.43.tar.gz) = 53dec85d1a22cc9060743580de22dfb0024d4700f9fc1d1bd2b82b9abb11c6a6
+SIZE (Math-GSL-0.43.tar.gz) = 23855115
diff --git a/math/p5-Math-GSL/files/patch-inc-GSLBuilder.pm b/math/p5-Math-GSL/files/patch-inc-GSLBuilder.pm
index a267d5119ecb..a69463c175a7 100644
--- a/math/p5-Math-GSL/files/patch-inc-GSLBuilder.pm
+++ b/math/p5-Math-GSL/files/patch-inc-GSLBuilder.pm
@@ -1,6 +1,6 @@
---- inc/GSLBuilder.pm.orig 2020-06-12 22:07:37 UTC
+--- inc/GSLBuilder.pm.orig 2021-07-26 16:28:55 UTC
+++ inc/GSLBuilder.pm
-@@ -279,7 +279,7 @@ sub link_c {
+@@ -280,7 +280,7 @@ sub link_c {
}
}
@@ -9,7 +9,7 @@
my @shrp = $self->split_like_shell($cf->{shrpenv});
my @ld = $self->split_like_shell($cf->{ld} || $Config{cc});
-@@ -311,7 +311,7 @@ sub compile_c {
+@@ -312,7 +312,7 @@ sub compile_c {
$cf->{installarchlib} = $Config{archlib};
diff --git a/math/p5-Math-GSL/files/patch-inc_Ver2Func.pm b/math/p5-Math-GSL/files/patch-inc_Ver2Func.pm
deleted file mode 100644
index 565e4804654b..000000000000
--- a/math/p5-Math-GSL/files/patch-inc_Ver2Func.pm
+++ /dev/null
@@ -1,15 +0,0 @@
---- inc/Ver2Func.pm.orig 2020-06-12 22:07:37 UTC
-+++ inc/Ver2Func.pm
-@@ -397,7 +397,12 @@ my @ver2func = (
- ^gsl_matrix_uint_scale_columns$
- /
- ]
-+ },
-+ "2.7" => {
-+ },
-+ "2.7.1" => {
- }
-+
- );
-
- my ( %index, @info, @versions );