aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/holotz-castle/Makefile13
-rw-r--r--games/holotz-castle/files/patch-JLib__JLib__Util__JFS.cpp (renamed from games/holotz-castle/files/patch-JLib-JLib-Util-JFS.cpp)4
-rw-r--r--games/holotz-castle/files/patch-JLib__Makefile (renamed from games/holotz-castle/files/patch-JLib-Makefile)4
-rw-r--r--games/holotz-castle/files/patch-src__Makefile (renamed from games/holotz-castle/files/patch-src-Makefile)4
4 files changed, 13 insertions, 12 deletions
diff --git a/games/holotz-castle/Makefile b/games/holotz-castle/Makefile
index 98e5da37ce91..664ec51cb0ab 100644
--- a/games/holotz-castle/Makefile
+++ b/games/holotz-castle/Makefile
@@ -18,13 +18,11 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
-MAKE_ARGS= HC_BASE=${STAGEDIR}${PREFIX}/share/${PORTNAME}/ \
- HC_BIN_DIR=${STAGEDIR}${PREFIX}/bin/
-MAKE_JOBS_UNSAFE= yes
-
-USES= gmake
+USES= gmake desthack
USE_GL= gl
USE_SDL= image mixer sdl ttf
+MAKE_ARGS= HC_BASE=${STAGEDIR}${PREFIX}/share/${PORTNAME}/
+MAKE_JOBS_UNSAFE= yes
INSTALLS_ICONS= yes
ICON_SIZES= 32x32 48x48 64x64 72x72 96x96 128x128
@@ -47,6 +45,9 @@ EXTRACT_ONLY+= ${PORTNAME}_solutions${EXTRACT_SUFX}
.endif
post-install:
+.for f in ${PORTNAME} ${PORTNAME}-editor
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${f} ${STAGEDIR}${PREFIX}/bin/)
+.endfor
.for s in ${ICON_SIZES}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
@@ -62,7 +63,7 @@ post-install:
${INSTALL_DATA} ${FILESDIR}/${PORTNAME}-solutions.desktop \
${STAGEDIR}${DESKTOPDIR}
@${MKDIR} ${STAGEDIR}${DATADIR}/solutions
- @(cd ${WRKDIR} ; ${INSTALL_DATA} *.avi ${STAGEDIR}${DATADIR}/solutions)
+ @(cd ${WRKDIR} && ${INSTALL_DATA} *.avi ${STAGEDIR}${DATADIR}/solutions)
.endif
.include <bsd.port.mk>
diff --git a/games/holotz-castle/files/patch-JLib-JLib-Util-JFS.cpp b/games/holotz-castle/files/patch-JLib__JLib__Util__JFS.cpp
index 3fd9b8589df5..fb3643e3cbf2 100644
--- a/games/holotz-castle/files/patch-JLib-JLib-Util-JFS.cpp
+++ b/games/holotz-castle/files/patch-JLib__JLib__Util__JFS.cpp
@@ -1,5 +1,5 @@
---- JLib/JLib/Util/JFS.cpp.orig 2008-08-23 22:36:06.000000000 +0400
-+++ JLib/JLib/Util/JFS.cpp 2008-08-25 17:58:54.000000000 +0400
+--- ./JLib/JLib/Util/JFS.cpp.orig 2009-05-02 11:17:15.000000000 +0200
++++ ./JLib/JLib/Util/JFS.cpp 2014-05-06 09:39:45.658916968 +0200
@@ -886,8 +886,8 @@
s32 n, k;
diff --git a/games/holotz-castle/files/patch-JLib-Makefile b/games/holotz-castle/files/patch-JLib__Makefile
index ad43f316d70a..f5dc7a4b9f7b 100644
--- a/games/holotz-castle/files/patch-JLib-Makefile
+++ b/games/holotz-castle/files/patch-JLib__Makefile
@@ -1,5 +1,5 @@
---- JLib/Makefile.orig 2008-08-23 22:36:06.000000000 +0400
-+++ JLib/Makefile 2008-08-25 18:00:54.000000000 +0400
+--- ./JLib/Makefile.orig 2009-05-02 11:17:15.000000000 +0200
++++ ./JLib/Makefile 2014-05-06 09:39:45.658916968 +0200
@@ -19,7 +19,7 @@
endif
diff --git a/games/holotz-castle/files/patch-src-Makefile b/games/holotz-castle/files/patch-src__Makefile
index 353cd45a6541..043a6523e380 100644
--- a/games/holotz-castle/files/patch-src-Makefile
+++ b/games/holotz-castle/files/patch-src__Makefile
@@ -1,5 +1,5 @@
---- src/Makefile.orig 2008-08-23 22:36:07.000000000 +0400
-+++ src/Makefile 2008-08-25 18:04:07.000000000 +0400
+--- ./src/Makefile.orig 2009-05-02 11:17:15.000000000 +0200
++++ ./src/Makefile 2014-05-06 09:47:06.888924553 +0200
@@ -21,12 +21,8 @@
# Edita estas l�neas para cambiar el directorio de instalaci�n de datos y del juego o bien
# comenta estas l�neas si no quieres instalar el juego (y descomenta las de arriba)