aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--Mk/bsd.wx.mk4
-rw-r--r--UPDATING11
-rw-r--r--cad/kicad-devel/Makefile5
-rw-r--r--cad/kicad/Makefile8
-rw-r--r--comms/gnuradio/Makefile6
-rw-r--r--databases/grass7/Makefile5
-rw-r--r--databases/grass8/Makefile5
-rw-r--r--graphics/py-mayavi/Makefile3
-rw-r--r--misc/pyobd/Makefile4
-rw-r--r--multimedia/photofilmstrip/Makefile4
-rw-r--r--textproc/py-enchant/Makefile3
-rw-r--r--x11-toolkits/py-wxPython4/Makefile (renamed from x11-toolkits/py-wxPython40/Makefile)7
-rw-r--r--x11-toolkits/py-wxPython4/distinfo3
-rw-r--r--x11-toolkits/py-wxPython4/files/patch-build.py (renamed from x11-toolkits/py-wxPython40/files/patch-build.py)0
-rw-r--r--x11-toolkits/py-wxPython4/files/patch-sip_cpp_sip__gridwxGridEvent.cpp13
-rw-r--r--x11-toolkits/py-wxPython4/pkg-descr (renamed from x11-toolkits/py-wxPython40/pkg-descr)0
-rw-r--r--x11-toolkits/py-wxPython40/distinfo3
-rw-r--r--x11-toolkits/py-wxPython40/files/patch-etg_propgridiface.py17
-rw-r--r--x11-toolkits/py-wxPython40/files/patch-sip_cpp_sip__propgridwxPGPropArgCls.cpp17
-rw-r--r--x11-toolkits/py-wxPython40/files/patch-sip_gen_propgridiface.sip17
-rw-r--r--x11-toolkits/wxgtk31/Makefile3
22 files changed, 61 insertions, 78 deletions
diff --git a/MOVED b/MOVED
index c68ca78ff3a5..4cdaaba2e6c0 100644
--- a/MOVED
+++ b/MOVED
@@ -16898,3 +16898,4 @@ math/coinmumps|math/coin-or-mumps|2022-02-23|Renamed into a more appropriate nam
www/py-weboob|www/py-woob|2022-02-24|Project renamed
www/py-weboob-qt|www/py-woob-qt|2022-02-24|Project renamed
math/py-pyipopt||2022-02-24|Removed: not compatible with the latest Ipopt-3.14.4 and abandoned upstream
+x11-toolkits/py-wxPython40|x11-toolkits/py-wxPython4|2022-02-25|Renamed to py-wxPython4
diff --git a/Mk/bsd.wx.mk b/Mk/bsd.wx.mk
index e3729cd0d744..e4d389e36622 100644
--- a/Mk/bsd.wx.mk
+++ b/Mk/bsd.wx.mk
@@ -137,8 +137,8 @@ _WX_LIB_contrib_2.8= wx_gtk2${_WX_UC}_fl-2.8
_WX_PORT_wx_3.0= x11-toolkits/wxgtk30@${_GTKFLAVOR}
_WX_LIB_wx_3.0= wx_baseu-3.0
-_WX_PORT_python_3.0= x11-toolkits/py-wxPython40@${PY_FLAVOR}
-_WX_FILE_python_3.0= ${PYTHON_SITELIBDIR}/wx/__init__.py
+_WX_PORT_python_3.1= x11-toolkits/py-wxPython4@${PY_FLAVOR}
+_WX_FILE_python_3.1= ${PYTHON_SITELIBDIR}/wx/__init__.py
# wxgtk 3.1
_WX_PORT_wx_3.1= x11-toolkits/wxgtk31
diff --git a/UPDATING b/UPDATING
index ee6f4d759bb5..5f71bb4aafa2 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,17 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20220225:
+ AFFECTS: users of x11-toolkits/py-wxPython40
+ AUTHOR: lbartoletti@FreeBSD.org
+
+ x11-toolkits/py-wxPython40 has been removed to be replaced by the 4.1
+ version.
+ However the new wxPython ports is now named x11-toolkits/py-wxPython4.
+
+ Depending on the tools you use, you may have to remove the port
+ before ports upgrade.
+
20220224:
AFFECTS: users of net-im/openfire
AUTHOR: nikita@druba.su
diff --git a/cad/kicad-devel/Makefile b/cad/kicad-devel/Makefile
index 5bb0db745f89..763cb611db17 100644
--- a/cad/kicad-devel/Makefile
+++ b/cad/kicad-devel/Makefile
@@ -2,7 +2,7 @@
PORTNAME= kicad
DISTVERSION= r${GIT_SRC_DATE}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= cad
PKGNAMESUFFIX= -devel
DIST_SUBDIR= ${PORTNAME}
@@ -31,7 +31,7 @@ GL_COMMIT= ${GIT_SRC_HASH}
CXXFLAGS+= --std=c++14 -I${WRKSRC} -I${WRKSRC}/include -I${LOCALBASE}/include
USE_GL= gl glew glu glut
-USE_WX= 3.0
+USE_WX= 3.1
WX_COMPS= wx python:lib
USE_GNOME= atk cairo # Required by libwx_gtk2_aui-2.8.so
USE_XORG+= ice pixman x11 xext
@@ -68,6 +68,7 @@ CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}" \
-DKICAD_SPICE=ON \
-DKICAD_USE_OCE=OFF \
-DKICAD_USE_OCC=ON \
+ -DKICAD_USE_EGL=ON \
-DOCC_INCLUDE_DIR=${LOCALBASE}/include/OpenCASCADE
USE_LDCONFIG= yes
diff --git a/cad/kicad/Makefile b/cad/kicad/Makefile
index 2c67582708a9..bf7e6221b4ee 100644
--- a/cad/kicad/Makefile
+++ b/cad/kicad/Makefile
@@ -2,6 +2,7 @@
PORTNAME= kicad
PORTVERSION= 6.0.2
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= cad
MASTER_SITES= https://gitlab.com/${PORTNAME}/code/${PORTNAME}/-/archive/${DISTVERSION}/
@@ -19,7 +20,8 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libTKernel.so:cad/opencascade \
libpixman-1.so:x11/pixman \
libpng.so:graphics/png \
- libcurl.so:ftp/curl
+ libcurl.so:ftp/curl \
+ libGLEW-wayland.so:graphics/glew-wayland
CONFLICTS_INSTALL= kicad-devel # bin/_cvpcb.kiface
@@ -30,7 +32,7 @@ SHEBANG_FILES= pcbnew/python/plugins/touch_slider_wizard.py
USE_XORG= ice x11 xext
USE_GL= gl glew glu glut
-USE_WX= 3.0
+USE_WX= 3.1
WX_COMPS= python:lib wx
USE_GNOME= atk cairo gdkpixbuf2 gtk30 pango
CXXFLAGS+= --std=c++11 -I${WRKSRC}/include -I${LOCALBASE}/include
@@ -39,6 +41,8 @@ CMAKE_ARGS= -DwxWidgets_CONFIG_EXECUTABLE=${WX_CONFIG} \
-DwxWidgets_wxrc_EXECUTABLE=${WXRC_CMD} \
-DKICAD_SCRIPTING_WXPYTHON=ON \
-DKICAD_USE_OCC=ON \
+ -DKICAD_USE_EGL=ON \
+ -DKICAD_USE_BUNDLED_GLEW=OFF \
-DOCC_INCLUDE_DIR=${LOCALBASE}/include/OpenCASCADE
USE_LDCONFIG= yes
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 2552c309d569..f73c53b6029c 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -1,7 +1,7 @@
PORTNAME= gnuradio
DISTVERSIONPREFIX= v
DISTVERSION= 3.8.4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms astro hamradio
MAINTAINER= hamradio@FreeBSD.org
@@ -69,9 +69,9 @@ CMAKE_ARGS+= -DCMAKE_INSTALL_RPATH:STRING="${LOCALBASE}/lib/gcc${_GCC_VER}" \
USE_CXXSTD= c++11
USE_GITHUB= yes
USE_PYQT= pyqt5
-USE_WX= 3.0
+USE_WX= 3.1
USE_QT= buildtools core gui xml qmake widgets
-WX_COMPS= wx wx:build wx:run python:build python:run
+WX_COMPS= wx python:run
USE_LDCONFIG= yes
LIBSTRIP_FILES= analog audio blocks channels digital dtv fec fft\
filter pmt qtgui runtime trellis video-sdl\
diff --git a/databases/grass7/Makefile b/databases/grass7/Makefile
index bc679d1c3b3a..51c5abffcabc 100644
--- a/databases/grass7/Makefile
+++ b/databases/grass7/Makefile
@@ -2,6 +2,7 @@
PORTNAME= grass
PORTVERSION= 7.8.6
+PORTREVISION= 1
CATEGORIES= databases geography
MASTER_SITES= https://grass.osgeo.org/%SUBDIR%/ \
http://grass.cict.fr/%SUBDIR%/ \
@@ -47,8 +48,8 @@ nviz_CMD= ${PREFIX}/${GRASS_INST_DIR}/bin/nviz
USE_XORG= sm ice x11 xext xi xmu xrender xt
USE_GL= gl glu
USE_GNOME= cairo
-USE_WX= 3.0
-WX_COMPS= wx:build python:run
+USE_WX= 3.1
+WX_COMPS= wx python:run
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
diff --git a/databases/grass8/Makefile b/databases/grass8/Makefile
index 9a6fd581f745..e1db1dbd5402 100644
--- a/databases/grass8/Makefile
+++ b/databases/grass8/Makefile
@@ -1,5 +1,6 @@
PORTNAME= grass
DISTVERSION= 8.0.0
+PORTREVISION= 1
CATEGORIES= databases geography
MASTER_SITES= https://grass.osgeo.org/%SUBDIR%/ \
http://grass.cict.fr/%SUBDIR%/ \
@@ -46,8 +47,8 @@ nviz_CMD= ${PREFIX}/${GRASS_INST_DIR}/bin/nviz
USE_XORG= sm ice x11 xext xi xmu xrender xt
USE_GL= gl glu
USE_GNOME= cairo
-USE_WX= 3.0
-WX_COMPS= wx:build python:run
+USE_WX= 3.1
+WX_COMPS= wx python:run
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-includes=${LOCALBASE}/include \
diff --git a/graphics/py-mayavi/Makefile b/graphics/py-mayavi/Makefile
index a9c0e38481ae..e9badc3718ce 100644
--- a/graphics/py-mayavi/Makefile
+++ b/graphics/py-mayavi/Makefile
@@ -2,6 +2,7 @@
PORTNAME= mayavi
DISTVERSION= 4.7.4
+PORTREVISION= 1
CATEGORIES= graphics science python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -38,7 +39,7 @@ RUN_DEPENDS= vtk9>0:math/vtk9 \
USES= python:3.6+ shebangfix
USE_PYTHON= noflavors distutils autoplist # noflavors to force python to be of the same version as in vtk9, which always has default python version
-USE_WX= 3.0+
+USE_WX= 3.1
WX_COMPS= python:run
SHEBANG_FILES= mayavi/tests/csv_files/csv_2_py
diff --git a/misc/pyobd/Makefile b/misc/pyobd/Makefile
index c7a1eca86b2e..c5035125cc80 100644
--- a/misc/pyobd/Makefile
+++ b/misc/pyobd/Makefile
@@ -1,6 +1,6 @@
PORTNAME= pyobd
DISTVERSION= 0.9.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= misc
MASTER_SITES= http://www.obdtester.com/download/
DISTNAME= pyobd_${PORTVERSION}
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyserial>0:comms/py-pyserial@${PY_FLAVOR}
USES= dos2unix gnome magick:6,build python shebangfix
DOS2UNIX_FILES= ${PORTNAME}.desktop
SHEBANG_FILES= ${PORTNAME}
-USE_WX= 3.0
+USE_WX= 3.1
WX_COMPS= python
NO_ARCH= yes
diff --git a/multimedia/photofilmstrip/Makefile b/multimedia/photofilmstrip/Makefile
index 54060a7f6153..cd8140b36e01 100644
--- a/multimedia/photofilmstrip/Makefile
+++ b/multimedia/photofilmstrip/Makefile
@@ -2,7 +2,7 @@
PORTNAME= photofilmstrip
PORTVERSION= 3.7.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia python
MASTER_SITES= SF/photostoryx/${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -21,7 +21,7 @@ RUN_DEPENDS= mencoder:multimedia/mencoder \
USES= python:3.6+ gettext
USE_GSTREAMER1= jpeg
USE_PYTHON= distutils
-USE_WX= 3.0+
+USE_WX= 3.1
WX_COMPS= python:lib
ALL_TARGET= compile
NO_ARCH= yes
diff --git a/textproc/py-enchant/Makefile b/textproc/py-enchant/Makefile
index 4ea4984c2988..b3cf4799da9a 100644
--- a/textproc/py-enchant/Makefile
+++ b/textproc/py-enchant/Makefile
@@ -2,6 +2,7 @@
PORTNAME= enchant
PORTVERSION= 3.2.2
+PORTREVISION= 1
CATEGORIES= textproc devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -27,7 +28,7 @@ USES= python:3.6+
USE_PYTHON= distutils py3kplist
NO_ARCH= yes
-WX_USE= WX=3.0+
+WX_USE= WX=3.1
WX_VARS= WX_COMPS=python:run
PLIST_SUB+= VER=${PORTVERSION}
diff --git a/x11-toolkits/py-wxPython40/Makefile b/x11-toolkits/py-wxPython4/Makefile
index 874be09f3c08..c69e0e30db46 100644
--- a/x11-toolkits/py-wxPython40/Makefile
+++ b/x11-toolkits/py-wxPython4/Makefile
@@ -1,10 +1,9 @@
PORTNAME= wxPython
-PORTVERSION= 4.0.7
-PORTREVISION= 2
+PORTVERSION= 4.1.1
CATEGORIES= x11-toolkits python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-PKGNAMESUFFIX= 40
+PKGNAMESUFFIX= 41
DIST_SUBDIR= python
MAINTAINER= python@FreeBSD.org
@@ -20,7 +19,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pathlib2>0:devel/py-pathlib2@${PY_FLAVOR}
USES= compiler:c++11-lib gl localbase pkgconfig python:3.6+
USE_GL= glu
-USE_WX= 3.0
+USE_WX= 3.1
USE_PYTHON= distutils autoplist
OPTIONS_DEFINE= NLS
diff --git a/x11-toolkits/py-wxPython4/distinfo b/x11-toolkits/py-wxPython4/distinfo
new file mode 100644
index 000000000000..a796f2046b3d
--- /dev/null
+++ b/x11-toolkits/py-wxPython4/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1643317997
+SHA256 (python/wxPython-4.1.1.tar.gz) = 00e5e3180ac7f2852f342ad341d57c44e7e4326de0b550b9a5c4a8361b6c3528
+SIZE (python/wxPython-4.1.1.tar.gz) = 66043287
diff --git a/x11-toolkits/py-wxPython40/files/patch-build.py b/x11-toolkits/py-wxPython4/files/patch-build.py
index 24b88f7e93ef..24b88f7e93ef 100644
--- a/x11-toolkits/py-wxPython40/files/patch-build.py
+++ b/x11-toolkits/py-wxPython4/files/patch-build.py
diff --git a/x11-toolkits/py-wxPython4/files/patch-sip_cpp_sip__gridwxGridEvent.cpp b/x11-toolkits/py-wxPython4/files/patch-sip_cpp_sip__gridwxGridEvent.cpp
new file mode 100644
index 000000000000..14a153c42943
--- /dev/null
+++ b/x11-toolkits/py-wxPython4/files/patch-sip_cpp_sip__gridwxGridEvent.cpp
@@ -0,0 +1,13 @@
+--- sip/cpp/sip_gridwxGridEvent.cpp.orig 2022-01-27 22:07:16 UTC
++++ sip/cpp/sip_gridwxGridEvent.cpp
+@@ -32,8 +32,8 @@ class sipwxGridEvent : public ::wxGridEvent (public)
+ * this class.
+ */
+ protected:
+- int GetRow() SIP_OVERRIDE;
+- int GetCol() SIP_OVERRIDE;
++ int GetRow();
++ int GetCol();
+ ::wxEvent* Clone() const SIP_OVERRIDE;
+ ::wxEventCategory GetEventCategory() const SIP_OVERRIDE;
+
diff --git a/x11-toolkits/py-wxPython40/pkg-descr b/x11-toolkits/py-wxPython4/pkg-descr
index 027967687f5c..027967687f5c 100644
--- a/x11-toolkits/py-wxPython40/pkg-descr
+++ b/x11-toolkits/py-wxPython4/pkg-descr
diff --git a/x11-toolkits/py-wxPython40/distinfo b/x11-toolkits/py-wxPython40/distinfo
deleted file mode 100644
index b510f058f78e..000000000000
--- a/x11-toolkits/py-wxPython40/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1575036483
-SHA256 (python/wxPython-4.0.7.tar.gz) = 3be608bfdede3063678cc703453850ab0a018b82bafd5ee057302250b18f0233
-SIZE (python/wxPython-4.0.7.tar.gz) = 68868838
diff --git a/x11-toolkits/py-wxPython40/files/patch-etg_propgridiface.py b/x11-toolkits/py-wxPython40/files/patch-etg_propgridiface.py
deleted file mode 100644
index 948012a6588a..000000000000
--- a/x11-toolkits/py-wxPython40/files/patch-etg_propgridiface.py
+++ /dev/null
@@ -1,17 +0,0 @@
-LLVM/CLANG cannot compile with reinterpret_cast.
-
-https://svnweb.freebsd.org/ports/head/x11-toolkits/py-wxPython30/files/patch-src_gtk_propgrid__wrap.cpp?revision=383979&view=markup
-https://github.com/wxWidgets/Phoenix/issues/1416#issuecomment-557263381
-https://github.com/wxWidgets/Phoenix/pull/1445
-
---- etg/propgridiface.py.orig 2019-05-21 23:12:12 UTC
-+++ etg/propgridiface.py
-@@ -89,7 +89,7 @@ def run():
- return sipGetState(sipTransferObj);
- }
- else if (sipPy == Py_None) {
-- *sipCppPtr = new wxPGPropArgCls(reinterpret_cast< wxPGProperty * >(NULL));
-+ *sipCppPtr = new wxPGPropArgCls(static_cast< wxPGProperty * >(NULL));
- return sipGetState(sipTransferObj);
- }
- else {
diff --git a/x11-toolkits/py-wxPython40/files/patch-sip_cpp_sip__propgridwxPGPropArgCls.cpp b/x11-toolkits/py-wxPython40/files/patch-sip_cpp_sip__propgridwxPGPropArgCls.cpp
deleted file mode 100644
index 4b980b84bd8c..000000000000
--- a/x11-toolkits/py-wxPython40/files/patch-sip_cpp_sip__propgridwxPGPropArgCls.cpp
+++ /dev/null
@@ -1,17 +0,0 @@
-LLVM/CLANG cannot compile with reinterpret_cast.
-
-https://svnweb.freebsd.org/ports/head/x11-toolkits/py-wxPython30/files/patch-src_gtk_propgrid__wrap.cpp?revision=383979&view=markup
-https://github.com/wxWidgets/Phoenix/issues/1416#issuecomment-557263381
-https://github.com/wxWidgets/Phoenix/pull/1445
-
---- sip/cpp/sip_propgridwxPGPropArgCls.cpp.orig 2019-05-22 02:14:14 UTC
-+++ sip/cpp/sip_propgridwxPGPropArgCls.cpp
-@@ -317,7 +317,7 @@ static int convertTo_wxPGPropArgCls(PyObject *sipPy,vo
- return sipGetState(sipTransferObj);
- }
- else if (sipPy == Py_None) {
-- *sipCppPtr = new wxPGPropArgCls(reinterpret_cast< wxPGProperty * >(NULL));
-+ *sipCppPtr = new wxPGPropArgCls(static_cast< wxPGProperty * >(NULL));
- return sipGetState(sipTransferObj);
- }
- else {
diff --git a/x11-toolkits/py-wxPython40/files/patch-sip_gen_propgridiface.sip b/x11-toolkits/py-wxPython40/files/patch-sip_gen_propgridiface.sip
deleted file mode 100644
index cf0bc5415327..000000000000
--- a/x11-toolkits/py-wxPython40/files/patch-sip_gen_propgridiface.sip
+++ /dev/null
@@ -1,17 +0,0 @@
-LLVM/CLANG cannot compile with reinterpret_cast.
-
-https://svnweb.freebsd.org/ports/head/x11-toolkits/py-wxPython30/files/patch-src_gtk_propgrid__wrap.cpp?revision=383979&view=markup
-https://github.com/wxWidgets/Phoenix/issues/1416#issuecomment-557263381
-https://github.com/wxWidgets/Phoenix/pull/1445
-
---- sip/gen/propgridiface.sip.orig 2019-05-22 02:13:01 UTC
-+++ sip/gen/propgridiface.sip
-@@ -108,7 +108,7 @@ class wxPGPropArgCls (public)
- return sipGetState(sipTransferObj);
- }
- else if (sipPy == Py_None) {
-- *sipCppPtr = new wxPGPropArgCls(reinterpret_cast< wxPGProperty * >(NULL));
-+ *sipCppPtr = new wxPGPropArgCls(static_cast< wxPGProperty * >(NULL));
- return sipGetState(sipTransferObj);
- }
- else {
diff --git a/x11-toolkits/wxgtk31/Makefile b/x11-toolkits/wxgtk31/Makefile
index 9bddc4af6a05..cefcb6eb14ee 100644
--- a/x11-toolkits/wxgtk31/Makefile
+++ b/x11-toolkits/wxgtk31/Makefile
@@ -49,7 +49,8 @@ CONFIGURE_ARGS= --with-libpng=sys \
--enable-backtrace \
--enable-ipv6 \
--enable-optimise \
- --enable-utf8 \
+ --enable-unicode \
+ --enable-std_string \
--enable-graphics_ctx \
--enable-compat28 \
--enable-compat30