aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/runwhen/Makefile4
-rw-r--r--sysutils/runwhen/files/patch-src_rw__scan.c9
2 files changed, 8 insertions, 5 deletions
diff --git a/sysutils/runwhen/Makefile b/sysutils/runwhen/Makefile
index 9bedabdc3f45..0baff384ead6 100644
--- a/sysutils/runwhen/Makefile
+++ b/sysutils/runwhen/Makefile
@@ -1,6 +1,6 @@
PORTNAME= runwhen
DISTVERSION= 2021.04.30
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= http://code.dogmap.org/runwhen/releases/
@@ -11,7 +11,7 @@ WWW= http://code.dogmap.org/runwhen/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/package/LICENSE
-BUILD_DEPENDS= skalibs>=2.13.1.1:devel/skalibs
+BUILD_DEPENDS= skalibs>=2.14.1.1:devel/skalibs
LIB_DEPENDS= libskarnet.so:devel/skalibs
USES= localbase tar:bzip2
diff --git a/sysutils/runwhen/files/patch-src_rw__scan.c b/sysutils/runwhen/files/patch-src_rw__scan.c
index 751572a1e3d1..f499207e8d87 100644
--- a/sysutils/runwhen/files/patch-src_rw__scan.c
+++ b/sysutils/runwhen/files/patch-src_rw__scan.c
@@ -1,14 +1,17 @@
---- src/rw_scan.c.orig 2022-08-10 16:08:50 UTC
+--- src/rw_scan.c.orig 2020-04-23 08:44:17 UTC
+++ src/rw_scan.c
-@@ -9,7 +9,7 @@
+@@ -9,9 +9,9 @@ extern char const* PROG;
extern char const* PROG;
-void rw_scan(tain_t* stamp, char const* text) {
+void rw_scan(tain* stamp, char const* text) {
unsigned int i, scale;
- uint64 u;
+- uint64 u;
++ uint64_t u;
char const* x;
+ switch (text[0]) {
+ case '$':
@@ -53,7 +53,7 @@ void rw_scan(tain_t* stamp, char const* text) {
tai_unix(tain_secp(stamp), u);
break;