aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/pgbouncer/Makefile31
-rw-r--r--databases/pgbouncer/distinfo6
2 files changed, 19 insertions, 18 deletions
diff --git a/databases/pgbouncer/Makefile b/databases/pgbouncer/Makefile
index 6bd8ba802d28..ab3b350ba183 100644
--- a/databases/pgbouncer/Makefile
+++ b/databases/pgbouncer/Makefile
@@ -1,7 +1,7 @@
# Created by: Sergey Skvortsov <skv@protey.ru>
PORTNAME= pgbouncer
-PORTVERSION= 1.16.1
+PORTVERSION= 1.17.0
CATEGORIES= databases
MASTER_SITES= https://pgbouncer.github.io/downloads/files/${PORTVERSION}/ \
http://pgbouncer.github.io/downloads/files/${PORTVERSION}/
@@ -13,36 +13,37 @@ LICENSE= BSD2CLAUSE
LIB_DEPENDS= libevent.so:devel/libevent
-USES= cpe gmake ssl pkgconfig
+USES= cpe gmake pkgconfig ssl
+USE_RC_SUBR= pgbouncer
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-evdns \
+ --with-libevent=${LOCALBASE}
+CONFIGURE_ENV+= PTHREAD_LIBS="-lpthread"
PORTSCOUT= site:https://pgbouncer.github.io/downloads/
+SUB_FILES= pkg-message
+SUB_LIST+= PGBOUNCER_RUNDIR="${PGBOUNCER_RUNDIR}"
USERS= pgbouncer
GROUPS= pgbouncer
-USE_RC_SUBR= pgbouncer
-GNU_CONFIGURE= yes
+PLIST_SUB+= PGBOUNCER_GROUP="${GROUPS}" \
+ PGBOUNCER_LOGDIR="${PGBOUNCER_LOGDIR}" \
+ PGBOUNCER_RUNDIR="${PGBOUNCER_RUNDIR}" \
+ PGBOUNCER_USER="${USERS}"
OPTIONS_DEFINE= CARES
+
CARES_LIB_DEPENDS= libcares.so:dns/c-ares
CARES_CONFIGURE_WITH= cares
-CONFIGURE_ARGS= --with-libevent=${LOCALBASE} --enable-evdns
-CONFIGURE_ENV+= PTHREAD_LIBS="-lpthread"
-
-PGBOUNCER_USER?= pgbouncer
PGBOUNCER_GROUP?= pgbouncer
+PGBOUNCER_USER?= pgbouncer
PGBOUNCER_RUNDIR?= /var/run/pgbouncer
PGBOUNCER_LOGDIR?= /var/log/pgbouncer
-PLIST_SUB+= PGBOUNCER_USER="${USERS}" \
- PGBOUNCER_GROUP="${GROUPS}" \
- PGBOUNCER_LOGDIR="${PGBOUNCER_LOGDIR}" \
- PGBOUNCER_RUNDIR="${PGBOUNCER_RUNDIR}"
-SUB_LIST+= PGBOUNCER_RUNDIR="${PGBOUNCER_RUNDIR}"
-SUB_FILES= pkg-message
-
post-patch:
@${REINPLACE_CMD} -e "s|= /etc/pgbouncer/userlist.txt|= ${PREFIX}/etc/pgbouncer.users|g" \
-e "s|= /var/log/pgbouncer/pgbouncer.log|= ${PGBOUNCER_LOGDIR}/pgbouncer.log|g" \
diff --git a/databases/pgbouncer/distinfo b/databases/pgbouncer/distinfo
index 592cb7e89c59..6ce4d09383d5 100644
--- a/databases/pgbouncer/distinfo
+++ b/databases/pgbouncer/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1644839246
-SHA256 (pgbouncer-1.16.1.tar.gz) = 087477e9e4766d032b04b7b006c0c8d64160a54141a7bfc2c6e5ae7ae11bf7fc
-SIZE (pgbouncer-1.16.1.tar.gz) = 591450
+TIMESTAMP = 1656273426
+SHA256 (pgbouncer-1.17.0.tar.gz) = 657309b7bc5c7a85cbf70a9a441b535f7824123081eabb7ba86d00349a256e23
+SIZE (pgbouncer-1.17.0.tar.gz) = 598294