aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/ghc/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 33351ea6b773..99f6013cc382 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -25,7 +25,6 @@ USE_PERL5= build
NO_CCACHE= yes
OPTIONS_SUB= yes
SHEBANG_FILES= boot
-PORTDOCS= *
OPTIONS_DEFINE?= DYNAMIC GMP PROFILE DOCS
OPTIONS_DEFAULT= DYNAMIC PROFILE GMP
@@ -96,6 +95,10 @@ BUILD_MK= DYNAMIC_GHC_PROGRAMS=${ENABLE_DYNAMIC} \
.include <bsd.port.pre.mk>
+.if ${SLAVE_PORT} != "yes"
+PORTDOCS= *
+.endif
+
GHC_ARCH= ${ARCH:S/amd64/x86_64/:C/armv.*/arm/}
CONFIGURE_TARGET= ${GHC_ARCH}-portbld-${OPSYS:tl}
BOOT_DIR= ${WRKDIR}/ghc-${BOOT_GHC_VERSION}-boot