aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-servers/xwayland/Makefile73
-rw-r--r--x11-servers/xwayland/distinfo9
-rw-r--r--x11-servers/xwayland/pkg-plist5
3 files changed, 64 insertions, 23 deletions
diff --git a/x11-servers/xwayland/Makefile b/x11-servers/xwayland/Makefile
index 5d0a02e9061c..35acc0194f96 100644
--- a/x11-servers/xwayland/Makefile
+++ b/x11-servers/xwayland/Makefile
@@ -1,36 +1,63 @@
PORTNAME= xwayland
-PORTREVISION= 0
+PORTVERSION= 22.1.2
+PORTEPOCH= 1
+CATEGORIES= x11-servers
+MASTER_SITES= XORG/individual/xserver
-COMMENT= X Clients under Wayland
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= 42e34498f87a.patch:-p1 # https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/432
+PATCHFILES+= 0d56c27582a2.patch:-p1 # https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/432
+PATCHFILES+= 1f7b28547011.patch:-p1 # https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/432
-LICENSE= MIT
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X11 server as Wayland Client
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/wayland-protocols.pc:graphics/wayland-protocols \
- ${LOCALBASE}/include/linux/input.h:devel/evdev-proto
-LIB_DEPENDS= libwayland-client.so:graphics/wayland \
- libinput.so:x11/libinput
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
+ ${LOCALBASE}/include/GL/internal/dri_interface.h:graphics/mesa-dri \
+ wayland-protocols>=1.18:graphics/wayland-protocols
+LIB_DEPENDS= libdrm.so:graphics/libdrm \
+ libepoxy.so:graphics/libepoxy \
+ libwayland-client.so:graphics/wayland \
+ libxcvt.so:x11/libxcvt
+RUN_DEPENDS= xkbcomp:x11/xkbcomp \
+ xkeyboard-config>0:x11/xkeyboard-config
CONFLICTS_INSTALL= ${PORTNAME}-devel
-MASTERDIR= ${.CURDIR}/../xorg-server
-DESCR= ${.CURDIR}/pkg-descr
-
-SLAVE_PORT= yes
-USE_XORG= x11 xext
-USE_GL+= egl gbm
-
-CONFIGURE_ARGS+=--disable-dmx --disable-xephyr --disable-xnest --disable-xvfb \
- --enable-xwayland --with-default-xkb-ruleset=evdev
-
-PLIST_FILES= bin/Xwayland
+USES= compiler:c11 gl meson pkgconfig xorg tar:xz
+USE_GL= egl gbm gl
+USE_XORG= pixman xau xfont2 xkbfile xshmfence xtrans
+
+MESON_ARGS= -Dxvfb=false \
+ -Dxdmcp=false \
+ -Dxcsecurity=false \
+ -Ddri3=true \
+ -Dglamor=true \
+ -Dsha1=libmd \
+ -Dipv6=true \
+ -Dxkb_dir=${LOCALBASE}/share/X11/xkb \
+ -Dxkb_output_dir=/var/lib/xkb \
+ -Ddefault_font_path="${DEFAULT_FONTPATH_LIST:ts,}"
+
+# Keep in sync with xorg-server
+FONTPATH_ROOT?= ${LOCALBASE}/share/fonts
+FONTPATHD?= ${PREFIX}/etc/X11/fontpath.d
+DEFAULT_FONTPATH_LIST= \
+ ${FONTPATH_ROOT}/misc/ \
+ ${FONTPATH_ROOT}/TTF/ \
+ ${FONTPATH_ROOT}/OTF/ \
+ ${FONTPATH_ROOT}/Type1/ \
+ ${FONTPATH_ROOT}/100dpi/ \
+ ${FONTPATH_ROOT}/75dpi/ \
+ catalogue:${FONTPATHD}
OPTIONS_DEFINE= NVIDIA
NVIDIA_DESC= EGLStream support for glamor on Xwayland
NVIDIA_BUILD_DEPENDS= egl-wayland>0:graphics/egl-wayland
-NVIDIA_CONFIGURE_ENABLE=xwayland-eglstream
-
-do-install:
- cd ${WRKSRC}/hw/xwayland; DESTDIR=${STAGEDIR} ${MAKE_CMD} install
+NVIDIA_MESON_TRUE= xwayland_eglstream
-.include "${MASTERDIR}/Makefile"
+.include <bsd.port.mk>
diff --git a/x11-servers/xwayland/distinfo b/x11-servers/xwayland/distinfo
new file mode 100644
index 000000000000..1ea5745c07df
--- /dev/null
+++ b/x11-servers/xwayland/distinfo
@@ -0,0 +1,9 @@
+TIMESTAMP = 1656586403
+SHA256 (xwayland-22.1.2.tar.xz) = 743c4d56cfc0818755e2281d625d51860b41a473c641e179649a4f41776d1fca
+SIZE (xwayland-22.1.2.tar.xz) = 1271848
+SHA256 (42e34498f87a.patch) = 64cd5eed076cdc575f1189e8491fb752054970032697445e6c192b4e63cac2a4
+SIZE (42e34498f87a.patch) = 10310
+SHA256 (0d56c27582a2.patch) = b7a53f6f52c197ac42ae521881c2d5e986f9983f5eb3640ecf1adb51356db40f
+SIZE (0d56c27582a2.patch) = 17463
+SHA256 (1f7b28547011.patch) = 483d5e636f011570953579a53814c45789958af94d003cda19cedd394df93ed8
+SIZE (1f7b28547011.patch) = 2472
diff --git a/x11-servers/xwayland/pkg-plist b/x11-servers/xwayland/pkg-plist
new file mode 100644
index 000000000000..76fbca053230
--- /dev/null
+++ b/x11-servers/xwayland/pkg-plist
@@ -0,0 +1,5 @@
+bin/Xwayland
+@comment lib/xorg/protocol.txt
+libdata/pkgconfig/xwayland.pc
+@comment man/man1/Xserver.1.gz
+man/man1/Xwayland.1.gz