aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/flex/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/textproc/flex/Makefile b/textproc/flex/Makefile
index 0d39fb3e4e4e..a4db6e07401b 100644
--- a/textproc/flex/Makefile
+++ b/textproc/flex/Makefile
@@ -16,7 +16,13 @@ USES= bison:alias gmake libtool makeinfo
GNU_CONFIGURE= yes
# install flex header to its own dir to avoid conflict with system flex.
CONFIGURE_ARGS= --includedir=${PREFIX}/include/flex --disable-shared
-CONFIGURE_ENV= MAKEINFO="${MAKEINFO} --no-split"
+CONFIGURE_ENV= MAKEINFO="${MAKEINFO} --no-split" \
+ CC_FOR_BUILD="${CC}" \
+ CFLAGS_FOR_BUILD="${CFLAGS}" \
+ CPPFLAGS_FOR_BUILD="${CPPFLAGS}" \
+ CXX_FOR_BUILD="${CXX}" \
+ CXXFLAGS_FOR_BUILD="${CXXFLAGS}" \
+ LDFLAGS_FOR_BUILD="${LDFLAGS}"
INSTALL_TARGET= install-strip
INFO= flex