aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hp48cc/Makefile29
-rw-r--r--devel/hp48cc/distinfo3
-rw-r--r--devel/hp48cc/pkg-descr7
-rw-r--r--devel/hp48cc/pkg-plist16
5 files changed, 56 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 816aa277c9df..16633dd9e956 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -388,6 +388,7 @@
SUBDIR += happydoc
SUBDIR += hapy
SUBDIR += hc12mem
+ SUBDIR += hp48cc
SUBDIR += hp48xgcc
SUBDIR += hptools
SUBDIR += hs-alex
diff --git a/devel/hp48cc/Makefile b/devel/hp48cc/Makefile
new file mode 100644
index 000000000000..75b1a45addf9
--- /dev/null
+++ b/devel/hp48cc/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: hp48cc
+# Date created: Sun Aug 12 04:33:37 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hp48cc
+PORTVERSION= 1.3
+PORTREVISION= 1
+CATEGORIES= devel lang
+MASTER_SITES= http://www.sigala.it/sandro/files/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= C-like compiler that translates input code to the HP48 RPN language
+
+USE_BISON= yes
+GNU_CONFIGURE= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
+
+MAN1= ${PORTNAME}.1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/hp48cc/distinfo b/devel/hp48cc/distinfo
new file mode 100644
index 000000000000..0c98b6ed69ab
--- /dev/null
+++ b/devel/hp48cc/distinfo
@@ -0,0 +1,3 @@
+MD5 (hp48cc-1.3.tar.gz) = 23f41a6168d3c17ea50537fe6ec2124a
+SHA256 (hp48cc-1.3.tar.gz) = 8c2af638d9e0ae25a2554348a2a44ba5f1425da7d7658d758795c815c3d297d5
+SIZE (hp48cc-1.3.tar.gz) = 39260
diff --git a/devel/hp48cc/pkg-descr b/devel/hp48cc/pkg-descr
new file mode 100644
index 000000000000..22dd0b852a42
--- /dev/null
+++ b/devel/hp48cc/pkg-descr
@@ -0,0 +1,7 @@
+hp48cc is a C-like compiler that translates the input code
+into the HP48 RPN language. The language recognized by the
+compiler is only a small subset of the C language, with
+some non-standard extensions, but powerful enough to write
+complex programs simply.
+
+WWW: http://www.sigala.it/sandro/software.php#hp48cc
diff --git a/devel/hp48cc/pkg-plist b/devel/hp48cc/pkg-plist
new file mode 100644
index 000000000000..7f726595da2a
--- /dev/null
+++ b/devel/hp48cc/pkg-plist
@@ -0,0 +1,16 @@
+bin/hp48cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/accuracy.hpc
+%%PORTDOCS%%%%EXAMPLESDIR%%/astro.hpc
+%%PORTDOCS%%%%EXAMPLESDIR%%/fact.hpc
+%%PORTDOCS%%%%EXAMPLESDIR%%/gcd.hpc
+%%PORTDOCS%%%%EXAMPLESDIR%%/hello.hpc
+%%PORTDOCS%%%%EXAMPLESDIR%%/inform.hpc
+%%PORTDOCS%%%%EXAMPLESDIR%%/pi1.hpc
+%%PORTDOCS%%%%EXAMPLESDIR%%/pi2.hpc
+%%PORTDOCS%%%%EXAMPLESDIR%%/sort.hpc
+%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial.hpc
+%%PORTDOCS%%%%EXAMPLESDIR%%/xcos.hpc
+%%PORTDOCS%%%%EXAMPLESDIR%%/xexp.hpc
+%%PORTDOCS%%%%EXAMPLESDIR%%/xsin.hpc
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%