aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/moodle310/Makefile8
-rw-r--r--www/moodle311/Makefile8
-rw-r--r--www/moodle39/Makefile8
3 files changed, 3 insertions, 21 deletions
diff --git a/www/moodle310/Makefile b/www/moodle310/Makefile
index dbb0e81a805b..1a1f11f3a583 100644
--- a/www/moodle310/Makefile
+++ b/www/moodle310/Makefile
@@ -16,7 +16,7 @@ CONFLICTS= moodle39-3.9.[0-9]* moodle311-3.11.[0-9]*
USES= cpe php:flavors tar:tgz
USE_PHP= ctype curl dom fileinfo filter gd hash iconv intl json mbstring \
opcache openssl pcre session simplexml soap spl tokenizer \
- xml xmlreader zip zlib
+ xml xmlreader xmlrpc zip zlib
WRKSRC= ${WRKDIR}/moodle
IGNORE_WITH_PHP= 80
@@ -41,12 +41,6 @@ SUB_LIST= MOODLEDIR=${MOODLEDIR} \
MOODLEDIR?= www/moodle
MOODLEDATADIR?= moodledata
-.include <bsd.port.options.mk>
-
-.if ${FLAVOR} != php80
-USE_PHP+= xmlrpc
-.endif
-
pre-install:
@${ECHO_CMD} "@owner ${WWWOWN}" >> ${PLIST}
@${ECHO_CMD} "@group ${WWWGRP}" >> ${PLIST}
diff --git a/www/moodle311/Makefile b/www/moodle311/Makefile
index 734365754cc6..0107636fd2a0 100644
--- a/www/moodle311/Makefile
+++ b/www/moodle311/Makefile
@@ -16,7 +16,7 @@ CONFLICTS= moodle39-3.9.[0-9]* moodle310-3.10.[0-9]*
USES= cpe php:flavors tar:tgz
USE_PHP= ctype curl dom fileinfo filter gd hash iconv intl json mbstring \
opcache openssl pcre session simplexml soap sodium spl tokenizer \
- xml xmlreader zip zlib
+ xml xmlreader xmlrpc zip zlib
WRKSRC= ${WRKDIR}/moodle
IGNORE_WITH_PHP= 80
@@ -41,12 +41,6 @@ SUB_LIST= MOODLEDIR=${MOODLEDIR} \
MOODLEDIR?= www/moodle
MOODLEDATADIR?= moodledata
-.include <bsd.port.options.mk>
-
-.if ${FLAVOR} != php80
-USE_PHP+= xmlrpc
-.endif
-
pre-install:
@${ECHO_CMD} "@owner ${WWWOWN}" >> ${PLIST}
@${ECHO_CMD} "@group ${WWWGRP}" >> ${PLIST}
diff --git a/www/moodle39/Makefile b/www/moodle39/Makefile
index bd24192e522e..8f50a16b79da 100644
--- a/www/moodle39/Makefile
+++ b/www/moodle39/Makefile
@@ -16,7 +16,7 @@ CONFLICTS= moodle310-3.10.[0-9]* moodle311-3.11.[0-9]*
USES= cpe php:flavors tar:tgz
USE_PHP= ctype curl dom fileinfo filter gd hash iconv intl json mbstring \
opcache openssl pcre session simplexml soap spl tokenizer \
- xml xmlreader zip zlib
+ xml xmlreader xmlrpc zip zlib
WRKSRC= ${WRKDIR}/moodle
IGNORE_WITH_PHP= 80
@@ -41,12 +41,6 @@ SUB_LIST= MOODLEDIR=${MOODLEDIR} \
MOODLEDIR?= www/moodle
MOODLEDATADIR?= moodledata
-.include <bsd.port.options.mk>
-
-.if ${FLAVOR} != php80
-USE_PHP+= xmlrpc
-.endif
-
pre-install:
@${ECHO_CMD} "@owner ${WWWOWN}" >> ${PLIST}
@${ECHO_CMD} "@group ${WWWGRP}" >> ${PLIST}