aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/apache-xml-security-c/Makefile3
-rw-r--r--security/openssh-portable/Makefile3
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/tengine/Makefile3
4 files changed, 11 insertions, 0 deletions
diff --git a/security/apache-xml-security-c/Makefile b/security/apache-xml-security-c/Makefile
index a9635e7969df..900b14c9d2ee 100644
--- a/security/apache-xml-security-c/Makefile
+++ b/security/apache-xml-security-c/Makefile
@@ -20,4 +20,7 @@ USES= gmake libtool tar:bzip2 ssl
USE_LDCONFIG= yes
CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= field has incomplete type HMAC_CTX (aka hmac_ctx_st)
+
.include <bsd.port.mk>
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 5fd07db8c05b..e7439332bff8 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -24,6 +24,9 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --with-md5-passwords \
--without-zlib-version-check --with-ssl-engine
ETCOLD= ${PREFIX}/etc
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= incomplete definition of type struct rsa_st
+
OPTIONS_DEFINE= PAM TCP_WRAPPERS LIBEDIT BSM \
HPN X509 KERB_GSSAPI \
OVERWRITE_BASE SCTP LDNS NONECIPHER
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 152a8d36b932..aac6d7273ef0 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -1162,6 +1162,8 @@ GROUPS?=${WWWGRP}
.if defined(NGINX_OPENSSL)
USES+= ssl
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= undefined reference to SSLeay_version
.endif
pre-everything::
diff --git a/www/tengine/Makefile b/www/tengine/Makefile
index 3933e8446f8d..82aa1b3d38f6 100644
--- a/www/tengine/Makefile
+++ b/www/tengine/Makefile
@@ -25,6 +25,9 @@ LIB_DEPENDS+= libluajit-5.1.so:lang/luajit \
libgd.so:graphics/gd \
libGeoIP.so:net/GeoIP
+BROKEN_SSL= openssl-devel
+BROKEN_SSL_REASON_openssl-devel= incomplete definition of type struct evp_pkey_st
+
NO_OPTIONS_SORT= yes
OPTIONS_DEFINE= \
DEBUG \