aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/postgresql10-server/Makefile4
-rw-r--r--databases/postgresql10-server/distinfo6
-rw-r--r--databases/postgresql10-server/files/patch-icu68254
-rw-r--r--databases/postgresql11-server/Makefile4
-rw-r--r--databases/postgresql11-server/distinfo6
-rw-r--r--databases/postgresql12-docs/Makefile44
-rw-r--r--databases/postgresql12-server/Makefile4
-rw-r--r--databases/postgresql12-server/distinfo6
-rw-r--r--databases/postgresql13-docs/Makefile44
-rw-r--r--databases/postgresql13-server/Makefile4
-rw-r--r--databases/postgresql13-server/distinfo6
-rw-r--r--databases/postgresql14-docs/Makefile4
-rw-r--r--databases/postgresql14-server/Makefile10
-rw-r--r--databases/postgresql14-server/distinfo6
-rw-r--r--databases/postgresql14-server/pkg-plist-client2
-rw-r--r--databases/postgresql14-server/pkg-plist-server4
-rw-r--r--databases/postgresql96-server/Makefile4
-rw-r--r--databases/postgresql96-server/distinfo6
18 files changed, 42 insertions, 376 deletions
diff --git a/databases/postgresql10-server/Makefile b/databases/postgresql10-server/Makefile
index 2b445cf8e2d6..5d8e31f09532 100644
--- a/databases/postgresql10-server/Makefile
+++ b/databases/postgresql10-server/Makefile
@@ -1,9 +1,9 @@
# Created by: Marc G. Fournier <scrappy@FreeBSD.org>
-DISTVERSION?= 10.17
+DISTVERSION?= 10.18
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
-PORTREVISION?= 2
+PORTREVISION?= 0
MAINTAINER?= pgsql@FreeBSD.org
diff --git a/databases/postgresql10-server/distinfo b/databases/postgresql10-server/distinfo
index aa0b98427f3f..4262635f68ad 100644
--- a/databases/postgresql10-server/distinfo
+++ b/databases/postgresql10-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620992064
-SHA256 (postgresql/postgresql-10.17.tar.bz2) = 5af28071606c9cd82212c19ba584657a9d240e1c4c2da28fc1f3998a2754b26c
-SIZE (postgresql/postgresql-10.17.tar.bz2) = 19153278
+TIMESTAMP = 1628577808
+SHA256 (postgresql/postgresql-10.18.tar.bz2) = 57477c2edc82c3f86a74747707b3babc1f301f389315ae14e819e025c0ba3801
+SIZE (postgresql/postgresql-10.18.tar.bz2) = 19197042
diff --git a/databases/postgresql10-server/files/patch-icu68 b/databases/postgresql10-server/files/patch-icu68
deleted file mode 100644
index bceb715029ff..000000000000
--- a/databases/postgresql10-server/files/patch-icu68
+++ /dev/null
@@ -1,254 +0,0 @@
-Regressed by https://github.com/unicode-org/icu/commit/c3fe7e09d844
-
-pg_collation.c:47:1: error: conflicting types for 'CollationCreate'
-CollationCreate(const char *collname, Oid collnamespace,
-^
-../../../src/include/catalog/pg_collation_fn.h:17:12: note: previous declaration is here
-extern Oid CollationCreate(const char *collname, Oid collnamespace,
- ^
-collationcmds.c:52:1: error: conflicting types for 'DefineCollation'
-DefineCollation(ParseState *pstate, List *names, List *parameters, bool if_not_exists)
-^
-../../../src/include/commands/collationcmds.h:21:22: note: previous declaration is here
-extern ObjectAddress DefineCollation(ParseState *pstate, List *names, List *parameters, bool if_not_exists);
- ^
-dbcommands.c:780:1: error: conflicting types for 'dropdb'
-dropdb(const char *dbname, bool missing_ok)
-^
-../../../src/include/commands/dbcommands.h:23:13: note: previous declaration is here
-extern void dropdb(const char *dbname, bool missing_ok);
- ^
-dbcommands.c:1397:1: error: conflicting types for 'AlterDatabase'
-AlterDatabase(ParseState *pstate, AlterDatabaseStmt *stmt, bool isTopLevel)
-^
-../../../src/include/commands/dbcommands.h:25:12: note: previous declaration is here
-extern Oid AlterDatabase(ParseState *pstate, AlterDatabaseStmt *stmt, bool isTopLevel);
- ^
-dbcommands.c:2009:1: error: conflicting types for 'get_database_oid'
-get_database_oid(const char *dbname, bool missing_ok)
-^
-../../../src/include/commands/dbcommands.h:29:12: note: previous declaration is here
-extern Oid get_database_oid(const char *dbname, bool missingok);
- ^
-indxpath.c:3003:1: error: conflicting types for 'relation_has_unique_index_for'
-relation_has_unique_index_for(PlannerInfo *root, RelOptInfo *rel,
-^
-../../../../src/include/optimizer/paths.h:71:13: note: previous declaration is here
-extern bool relation_has_unique_index_for(PlannerInfo *root, RelOptInfo *rel,
- ^
-indxpath.c:3174:1: error: conflicting types for 'indexcol_is_bool_constant_for_query'
-indexcol_is_bool_constant_for_query(IndexOptInfo *index, int indexcol)
-^
-../../../../src/include/optimizer/paths.h:74:13: note: previous declaration is here
-extern bool indexcol_is_bool_constant_for_query(IndexOptInfo *index,
- ^
-indxpath.c:3223:1: error: conflicting types for 'match_index_to_operand'
-match_index_to_operand(Node *operand,
-^
-../../../../src/include/optimizer/paths.h:76:13: note: previous declaration is here
-extern bool match_index_to_operand(Node *operand, int indexcol,
- ^
-indxpath.c:3867:1: error: conflicting types for 'adjust_rowcompare_for_index'
-adjust_rowcompare_for_index(RowCompareExpr *clause,
-^
-../../../../src/include/optimizer/paths.h:82:14: note: previous declaration is here
-extern Expr *adjust_rowcompare_for_index(RowCompareExpr *clause,
- ^
-regis.c:31:1: error: conflicting types for 'RS_isRegis'
-RS_isRegis(const char *str)
-^
-../../../src/include/tsearch/dicts/regis.h:41:7: note: previous declaration is here
-bool RS_isRegis(const char *str);
- ^
-regis.c:85:1: error: conflicting types for 'RS_compile'
-RS_compile(Regis *r, bool issuffix, const char *str)
-^
-../../../src/include/tsearch/dicts/regis.h:43:7: note: previous declaration is here
-void RS_compile(Regis *r, bool issuffix, const char *str);
- ^
-regis.c:218:1: error: conflicting types for 'RS_execute'
-RS_execute(Regis *r, char *str)
-^
-../../../src/include/tsearch/dicts/regis.h:47:7: note: previous declaration is here
-bool RS_execute(Regis *r, char *str);
- ^
-guc.c:433:7: error: redefinition of 'log_duration' with a different type: 'bool' vs 'bool' (aka 'char')
-bool log_duration = false;
- ^
-../../../../src/include/utils/guc.h:233:13: note: previous declaration is here
-extern bool log_duration;
- ^
-guc.c:434:7: error: redefinition of 'Debug_print_plan' with a different type: 'bool' vs 'bool' (aka 'char')
-bool Debug_print_plan = false;
- ^
-../../../../src/include/utils/guc.h:234:13: note: previous declaration is here
-extern bool Debug_print_plan;
- ^
-guc.c:435:7: error: redefinition of 'Debug_print_parse' with a different type: 'bool' vs 'bool' (aka 'char')
-bool Debug_print_parse = false;
- ^
-../../../../src/include/utils/guc.h:235:13: note: previous declaration is here
-extern bool Debug_print_parse;
- ^
-guc.c:436:7: error: redefinition of 'Debug_print_rewritten' with a different type: 'bool' vs 'bool' (aka 'char')
-bool Debug_print_rewritten = false;
- ^
-../../../../src/include/utils/guc.h:236:13: note: previous declaration is here
-extern bool Debug_print_rewritten;
- ^
-guc.c:437:7: error: redefinition of 'Debug_pretty_print' with a different type: 'bool' vs 'bool' (aka 'char')
-bool Debug_pretty_print = true;
- ^
-../../../../src/include/utils/guc.h:237:13: note: previous declaration is here
-extern bool Debug_pretty_print;
- ^
-guc.c:439:7: error: redefinition of 'log_parser_stats' with a different type: 'bool' vs 'bool' (aka 'char')
-bool log_parser_stats = false;
- ^
-../../../../src/include/utils/guc.h:239:13: note: previous declaration is here
-extern bool log_parser_stats;
- ^
-guc.c:440:7: error: redefinition of 'log_planner_stats' with a different type: 'bool' vs 'bool' (aka 'char')
-bool log_planner_stats = false;
- ^
-../../../../src/include/utils/guc.h:240:13: note: previous declaration is here
-extern bool log_planner_stats;
- ^
-guc.c:441:7: error: redefinition of 'log_executor_stats' with a different type: 'bool' vs 'bool' (aka 'char')
-bool log_executor_stats = false;
- ^
-../../../../src/include/utils/guc.h:241:13: note: previous declaration is here
-extern bool log_executor_stats;
- ^
-guc.c:442:7: error: redefinition of 'log_statement_stats' with a different type: 'bool' vs 'bool' (aka 'char')
-bool log_statement_stats = false; /* this is sort of all three above
- ^
-../../../../src/include/utils/guc.h:242:13: note: previous declaration is here
-extern bool log_statement_stats;
- ^
-guc.c:444:7: error: redefinition of 'log_btree_build_stats' with a different type: 'bool' vs 'bool' (aka 'char')
-bool log_btree_build_stats = false;
- ^
-../../../../src/include/utils/guc.h:243:13: note: previous declaration is here
-extern bool log_btree_build_stats;
- ^
-guc.c:448:7: error: redefinition of 'check_function_bodies' with a different type: 'bool' vs 'bool' (aka 'char')
-bool check_function_bodies = true;
- ^
-../../../../src/include/utils/guc.h:245:25: note: previous declaration is here
-extern PGDLLIMPORT bool check_function_bodies;
- ^
-guc.c:449:7: error: redefinition of 'default_with_oids' with a different type: 'bool' vs 'bool' (aka 'char')
-bool default_with_oids = false;
- ^
-../../../../src/include/utils/guc.h:246:13: note: previous declaration is here
-extern bool default_with_oids;
- ^
-guc.c:450:7: error: redefinition of 'session_auth_is_superuser' with a different type: 'bool' vs 'bool' (aka 'char')
-bool session_auth_is_superuser;
- ^
-../../../../src/include/utils/guc.h:247:13: note: previous declaration is here
-extern bool session_auth_is_superuser;
- ^
-guc.c:4707:1: error: conflicting types for 'SelectConfigFiles'
-SelectConfigFiles(const char *userDoption, const char *progname)
-^
-../../../../src/include/utils/guc.h:354:13: note: previous declaration is here
-extern bool SelectConfigFiles(const char *userDoption, const char *progname);
- ^
-guc.c:5097:1: error: conflicting types for 'AtEOXact_GUC'
-AtEOXact_GUC(bool isCommit, int nestLevel)
-^
-../../../../src/include/utils/guc.h:358:13: note: previous declaration is here
-extern void AtEOXact_GUC(bool isCommit, int nestLevel);
- ^
-guc.c:5515:1: error: conflicting types for 'parse_int'
-parse_int(const char *value, int *result, int flags, const char **hintmsg)
-^
-../../../../src/include/utils/guc.h:361:13: note: previous declaration is here
-extern bool parse_int(const char *value, int *result, int flags,
- ^
-guc.c:5601:1: error: conflicting types for 'parse_real'
-parse_real(const char *value, double *result)
-^
-../../../../src/include/utils/guc.h:363:13: note: previous declaration is here
-extern bool parse_real(const char *value, double *result);
- ^
-guc.c:5662:1: error: conflicting types for 'config_enum_lookup_by_name'
-config_enum_lookup_by_name(struct config_enum *record, const char *value,
-^
-../../../../src/include/utils/guc_tables.h:265:13: note: previous declaration is here
-extern bool config_enum_lookup_by_name(struct config_enum *record,
- ^
-guc.c:5930:1: error: conflicting types for 'set_config_option'
-set_config_option(const char *name, const char *value,
-^
-../../../../src/include/utils/guc.h:364:12: note: previous declaration is here
-extern int set_config_option(const char *name, const char *value,
- ^
-fatal error: too many errors emitted, stopping now [-ferror-limit=]
-
---- src/backend/catalog/pg_collation.c.orig 2020-08-10 21:19:16 UTC
-+++ src/backend/catalog/pg_collation.c
-@@ -14,6 +14,8 @@
- */
- #include "postgres.h"
-
-+#include <stdbool.h>
-+
- #include "access/genam.h"
- #include "access/heapam.h"
- #include "access/htup_details.h"
---- src/backend/commands/collationcmds.c.orig 2020-08-10 21:19:16 UTC
-+++ src/backend/commands/collationcmds.c
-@@ -14,6 +14,8 @@
- */
- #include "postgres.h"
-
-+#include <stdbool.h>
-+
- #include "access/heapam.h"
- #include "access/htup_details.h"
- #include "access/xact.h"
---- src/backend/commands/dbcommands.c.orig 2020-08-10 21:19:16 UTC
-+++ src/backend/commands/dbcommands.c
-@@ -19,6 +19,7 @@
- */
- #include "postgres.h"
-
-+#include <stdbool.h>
- #include <fcntl.h>
- #include <unistd.h>
- #include <sys/stat.h>
---- src/backend/optimizer/path/indxpath.c.orig 2020-08-10 21:19:16 UTC
-+++ src/backend/optimizer/path/indxpath.c
-@@ -15,6 +15,7 @@
- */
- #include "postgres.h"
-
-+#include <stdbool.h>
- #include <math.h>
-
- #include "access/stratnum.h"
---- src/backend/tsearch/regis.c.orig 2020-08-10 21:19:16 UTC
-+++ src/backend/tsearch/regis.c
-@@ -14,6 +14,8 @@
-
- #include "postgres.h"
-
-+#include <stdbool.h>
-+
- #include "tsearch/dicts/regis.h"
- #include "tsearch/ts_locale.h"
-
---- src/backend/utils/misc/guc.c.orig 2020-08-10 21:19:16 UTC
-+++ src/backend/utils/misc/guc.c
-@@ -16,6 +16,8 @@
- */
- #include "postgres.h"
-
-+#include <stdbool.h>
-+
- #include <ctype.h>
- #include <float.h>
- #include <math.h>
diff --git a/databases/postgresql11-server/Makefile b/databases/postgresql11-server/Makefile
index bfedcd0dad2e..9e51fac93938 100644
--- a/databases/postgresql11-server/Makefile
+++ b/databases/postgresql11-server/Makefile
@@ -1,9 +1,9 @@
# Created by: Marc G. Fournier <scrappy@FreeBSD.org>
-DISTVERSION?= 11.12
+DISTVERSION?= 11.13
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
-PORTREVISION?= 1
+PORTREVISION?= 0
MAINTAINER?= pgsql@FreeBSD.org
diff --git a/databases/postgresql11-server/distinfo b/databases/postgresql11-server/distinfo
index 3a87e1b91719..a921df317132 100644
--- a/databases/postgresql11-server/distinfo
+++ b/databases/postgresql11-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620991922
-SHA256 (postgresql/postgresql-11.12.tar.bz2) = 87f9d8b16b2b8ef71586f2ec76beac844819f64734b07fa33986755c2f53cb04
-SIZE (postgresql/postgresql-11.12.tar.bz2) = 20075485
+TIMESTAMP = 1628577840
+SHA256 (postgresql/postgresql-11.13.tar.bz2) = a0c3689ff7f565288002cbc138779d5121d74831a5e8341aea7aa86e99b6bc48
+SIZE (postgresql/postgresql-11.13.tar.bz2) = 20123787
diff --git a/databases/postgresql12-docs/Makefile b/databases/postgresql12-docs/Makefile
index 29d32bb29759..f977f2b8aeb4 100644
--- a/databases/postgresql12-docs/Makefile
+++ b/databases/postgresql12-docs/Makefile
@@ -1,45 +1,5 @@
# Created by: Palle Girgensohn <girgen@pingpong.net>
-PORTNAME= postgresql
-PORTREVISION= 0
-PKGNAMESUFFIX?= ${WANT_PGSQL_VER:S,.,,}-docs
+WANT_PGSQL_VER=12
-MAINTAINER= pgsql@FreeBSD.org
-COMMENT= The PostgreSQL documentation set
-
-MASTERDIR= ${.CURDIR}/../../databases/postgresql${WANT_PGSQL_VER:S/.//}-server
-WANT_PGSQL_VER?=12
-
-DISTV= ${DISTVERSION:R}
-
-SLAVE_ONLY= YES
-COMPONENT= -docs
-
-PGDOCSREL?= ${DOCSDIR_REL}/release-${PGSQL_VER}
-PGDOCSDIR?= ${PREFIX}/${PGDOCSREL}
-
-sgmldir= ${LOCALBASE}/share/sgml
-dbdir= ${sgmldir}/docbook
-
-BUILD_DEPENDS+= onsgmls:textproc/opensp \
- openjade:textproc/openjade \
- ${sgmldir}/iso8879/catalog:textproc/iso8879 \
- ${dbdir}/dsssl/modular/catalog:textproc/dsssl-docbook-modular \
- docbook-sgml>0:textproc/docbook-sgml
-CONFIGURE_ARGS= --without-readline
-NO_ARCH= yes
-
-do-build:
- ${MAKE_CMD} -C ${WRKSRC} html
-
-do-install:
- @ ${MKDIR} ${STAGEDIR}${PGDOCSDIR}
- ( cd ${WRKSRC}/doc/src/sgml/html && \
- ${COPYTREE_SHARE} . ${STAGEDIR}${PGDOCSDIR} )
-
-post-install:
- @(cd ${STAGEDIR}${PREFIX} && ${FIND} ${PGDOCSREL} -type f) >> ${TMPPLIST}
- @(cd ${STAGEDIR}${PREFIX} && ${FIND} ${PGDOCSREL} -type d) | ${SORT} -r | \
- ${SED} 's,.*,@unexec rmdir %D/& 2>/dev/null || true,' >>${TMPPLIST}
-
-.include "${MASTERDIR}/Makefile"
+.include "${.CURDIR}/../postgresql14-docs/Makefile"
diff --git a/databases/postgresql12-server/Makefile b/databases/postgresql12-server/Makefile
index f0168a4f7eb1..67a88c130ae5 100644
--- a/databases/postgresql12-server/Makefile
+++ b/databases/postgresql12-server/Makefile
@@ -1,9 +1,9 @@
# Created by: Marc G. Fournier <scrappy@FreeBSD.org>
-DISTVERSION?= 12.7
+DISTVERSION?= 12.8
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
-PORTREVISION?= 1
+PORTREVISION?= 0
MAINTAINER?= pgsql@FreeBSD.org
diff --git a/databases/postgresql12-server/distinfo b/databases/postgresql12-server/distinfo
index 76b4c494e32f..ebad7d7b460b 100644
--- a/databases/postgresql12-server/distinfo
+++ b/databases/postgresql12-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620992107
-SHA256 (postgresql/postgresql-12.7.tar.bz2) = 8490741f47c88edc8b6624af009ce19fda4dc9b31c4469ce2551d84075d5d995
-SIZE (postgresql/postgresql-12.7.tar.bz2) = 20819005
+TIMESTAMP = 1628577879
+SHA256 (postgresql/postgresql-12.8.tar.bz2) = e26401e090c34ccb15ffb33a111f340833833535a7b7c5cd11cd88ab57d9c62a
+SIZE (postgresql/postgresql-12.8.tar.bz2) = 20849478
diff --git a/databases/postgresql13-docs/Makefile b/databases/postgresql13-docs/Makefile
index 95607df48ed3..73c942af5cab 100644
--- a/databases/postgresql13-docs/Makefile
+++ b/databases/postgresql13-docs/Makefile
@@ -1,45 +1,5 @@
# Created by: Palle Girgensohn <girgen@pingpong.net>
-PORTNAME= postgresql
-PORTREVISION= 0
-PKGNAMESUFFIX?= ${WANT_PGSQL_VER:S,.,,}-docs
+WANT_PGSQL_VER=13
-MAINTAINER= pgsql@FreeBSD.org
-COMMENT= The PostgreSQL documentation set
-
-MASTERDIR= ${.CURDIR}/../../databases/postgresql${WANT_PGSQL_VER:S/.//}-server
-WANT_PGSQL_VER?=13
-
-DISTV= ${DISTVERSION:R}
-
-SLAVE_ONLY= YES
-COMPONENT= -docs
-
-PGDOCSREL?= ${DOCSDIR_REL}/release-${PGSQL_VER}
-PGDOCSDIR?= ${PREFIX}/${PGDOCSREL}
-
-sgmldir= ${LOCALBASE}/share/sgml
-dbdir= ${sgmldir}/docbook
-
-BUILD_DEPENDS+= onsgmls:textproc/opensp \
- openjade:textproc/openjade \
- ${sgmldir}/iso8879/catalog:textproc/iso8879 \
- ${dbdir}/dsssl/modular/catalog:textproc/dsssl-docbook-modular \
- docbook-sgml>0:textproc/docbook-sgml
-CONFIGURE_ARGS= --without-readline
-NO_ARCH= yes
-
-do-build:
- ${MAKE_CMD} -C ${WRKSRC} html
-
-do-install:
- @ ${MKDIR} ${STAGEDIR}${PGDOCSDIR}
- ( cd ${WRKSRC}/doc/src/sgml/html && \
- ${COPYTREE_SHARE} . ${STAGEDIR}${PGDOCSDIR} )
-
-post-install:
- @(cd ${STAGEDIR}${PREFIX} && ${FIND} ${PGDOCSREL} -type f) >> ${TMPPLIST}
- @(cd ${STAGEDIR}${PREFIX} && ${FIND} ${PGDOCSREL} -type d) | ${SORT} -r | \
- ${SED} 's,.*,@unexec rmdir %D/& 2>/dev/null || true,' >>${TMPPLIST}
-
-.include "${MASTERDIR}/Makefile"
+.include "${.CURDIR}/../postgresql14-docs/Makefile"
diff --git a/databases/postgresql13-server/Makefile b/databases/postgresql13-server/Makefile
index cf3d1a88a8e3..79503daa542f 100644
--- a/databases/postgresql13-server/Makefile
+++ b/databases/postgresql13-server/Makefile
@@ -1,9 +1,9 @@
# Created by: Marc G. Fournier <scrappy@FreeBSD.org>
-DISTVERSION?= 13.3
+DISTVERSION?= 13.4
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
-PORTREVISION?= 1
+PORTREVISION?= 0
MAINTAINER?= pgsql@FreeBSD.org
diff --git a/databases/postgresql13-server/distinfo b/databases/postgresql13-server/distinfo
index 9ac2c3dbf1f6..cc382c65db80 100644
--- a/databases/postgresql13-server/distinfo
+++ b/databases/postgresql13-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1620992128
-SHA256 (postgresql/postgresql-13.3.tar.bz2) = 3cd9454fa8c7a6255b6743b767700925ead1b9ab0d7a0f9dcb1151010f8eb4a1
-SIZE (postgresql/postgresql-13.3.tar.bz2) = 21119109
+TIMESTAMP = 1628577935
+SHA256 (postgresql/postgresql-13.4.tar.bz2) = ea93e10390245f1ce461a54eb5f99a48d8cabd3a08ce4d652ec2169a357bc0cd
+SIZE (postgresql/postgresql-13.4.tar.bz2) = 21157443
diff --git a/databases/postgresql14-docs/Makefile b/databases/postgresql14-docs/Makefile
index 7ed19a3704d4..93edc6e0a937 100644
--- a/databases/postgresql14-docs/Makefile
+++ b/databases/postgresql14-docs/Makefile
@@ -15,7 +15,7 @@ DISTV= ${DISTVERSION:R}
SLAVE_ONLY= YES
COMPONENT= -docs
-PGDOCSREL?= ${DOCSDIR_REL}/release-${PGSQL_VER}
+PGDOCSREL?= ${DOCSDIR_REL}/release-${WANT_PGSQL_VER}
PGDOCSDIR?= ${PREFIX}/${PGDOCSREL}
sgmldir= ${LOCALBASE}/share/sgml
@@ -39,7 +39,5 @@ do-install:
post-install:
@(cd ${STAGEDIR}${PREFIX} && ${FIND} ${PGDOCSREL} -type f) >> ${TMPPLIST}
- @(cd ${STAGEDIR}${PREFIX} && ${FIND} ${PGDOCSREL} -type d) | ${SORT} -r | \
- ${SED} 's,.*,@unexec rmdir %D/& 2>/dev/null || true,' >>${TMPPLIST}
.include "${MASTERDIR}/Makefile"
diff --git a/databases/postgresql14-server/Makefile b/databases/postgresql14-server/Makefile
index ad926e7d9199..ac090ad8ebbf 100644
--- a/databases/postgresql14-server/Makefile
+++ b/databases/postgresql14-server/Makefile
@@ -1,10 +1,10 @@
# Created by: Marc G. Fournier <scrappy@FreeBSD.org>
PORTNAME?= postgresql
-DISTVERSION?= 14beta2
+DISTVERSION?= 14beta3
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
-PORTREVISION?= 2
+PORTREVISION?= 0
CATEGORIES?= databases
MASTER_SITES= PGSQL/source/v${DISTVERSION}
PKGNAMESUFFIX?= ${PORTVERSION:R}${COMPONENT}
@@ -256,8 +256,8 @@ LLVM_PORT_SUFFIX= ${COMPILER_VERSION:C/.$//}
# sync LLVM to the preferred compiler if possible
# or else use a lower version compiler that is compatible
.if ${COMPILER_VERSION} > ${LLVM_DEFAULT_VERSION}
-# Highest LLVM version in ports:
-. if ${LLVM_PORT_SUFFIX} <= 11
+# LLVM versions in ports are, in order, 70, 80 90, 10, 11, 12... where 10 > 90. [sic]
+. if ${LLVM_PORT_SUFFIX} < 70
PG_LLVM_VERSION=${LLVM_PORT_SUFFIX}
PG_COMPILER_VERSION=${LLVM_PORT_SUFFIX}
. else
@@ -288,7 +288,7 @@ pre-build:
do-build:
@ cd ${WRKSRC}/src/backend && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} symlinks
@ for dir in ${BUILD_DIRS}; do \
- cd ${WRKSRC}/$${dir} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${_MAKE_JOBS}; \
+ cd ${WRKSRC}/$${dir} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ; \
done
. if exists(${FILESDIR}/pkg-message${COMPONENT}.in)
diff --git a/databases/postgresql14-server/distinfo b/databases/postgresql14-server/distinfo
index 7d9d0104fcbe..b0a3db8a2ae2 100644
--- a/databases/postgresql14-server/distinfo
+++ b/databases/postgresql14-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1624362482
-SHA256 (postgresql/postgresql-14beta2.tar.bz2) = ffe64a76f50a2363443c1c9dc2195138933e931e351b74fb35a7935eae7c60a5
-SIZE (postgresql/postgresql-14beta2.tar.bz2) = 22555641
+TIMESTAMP = 1628577978
+SHA256 (postgresql/postgresql-14beta3.tar.bz2) = 2ea265980193db70106576201a2fee5b2d72bf9890d3911ddd374d4830624bfa
+SIZE (postgresql/postgresql-14beta3.tar.bz2) = 22584314
diff --git a/databases/postgresql14-server/pkg-plist-client b/databases/postgresql14-server/pkg-plist-client
index ac1163fb493c..95ffef6fcd15 100644
--- a/databases/postgresql14-server/pkg-plist-client
+++ b/databases/postgresql14-server/pkg-plist-client
@@ -373,6 +373,7 @@ include/postgresql/server/executor/nodeIndexscan.h
include/postgresql/server/executor/nodeLimit.h
include/postgresql/server/executor/nodeLockRows.h
include/postgresql/server/executor/nodeMaterial.h
+include/postgresql/server/executor/nodeMemoize.h
include/postgresql/server/executor/nodeMergeAppend.h
include/postgresql/server/executor/nodeMergejoin.h
include/postgresql/server/executor/nodeModifyTable.h
@@ -381,7 +382,6 @@ include/postgresql/server/executor/nodeNestloop.h
include/postgresql/server/executor/nodeProjectSet.h
include/postgresql/server/executor/nodeRecursiveunion.h
include/postgresql/server/executor/nodeResult.h
-include/postgresql/server/executor/nodeResultCache.h
include/postgresql/server/executor/nodeSamplescan.h
include/postgresql/server/executor/nodeSeqscan.h
include/postgresql/server/executor/nodeSetOp.h
diff --git a/databases/postgresql14-server/pkg-plist-server b/databases/postgresql14-server/pkg-plist-server
index f4614a1219b4..f500adab3972 100644
--- a/databases/postgresql14-server/pkg-plist-server
+++ b/databases/postgresql14-server/pkg-plist-server
@@ -320,7 +320,7 @@ lib/postgresql/utf8_and_win.so
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeProjectSet.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeRecursiveunion.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeResult.bc
-%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeResultCache.bc
+%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeMemoize.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeSamplescan.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeSeqscan.bc
%%LLVM%%lib/postgresql/bitcode/postgres/executor/nodeSetOp.bc
@@ -791,6 +791,8 @@ lib/postgresql/utf8_and_win.so
%%NLS%%share/locale/el/LC_MESSAGES/pg_checksums-14.mo
%%NLS%%share/locale/el/LC_MESSAGES/pg_controldata-14.mo
%%NLS%%share/locale/el/LC_MESSAGES/pg_ctl-14.mo
+%%NLS%%share/locale/el/LC_MESSAGES/pg_resetwal-14.mo
+%%NLS%%share/locale/el/LC_MESSAGES/pg_rewind-14.mo
%%NLS%%share/locale/el/LC_MESSAGES/pg_test_fsync-14.mo
%%NLS%%share/locale/el/LC_MESSAGES/pg_test_timing-14.mo
%%NLS%%share/locale/el/LC_MESSAGES/pg_waldump-14.mo
diff --git a/databases/postgresql96-server/Makefile b/databases/postgresql96-server/Makefile
index 966cb459f73f..787639aa3c8b 100644
--- a/databases/postgresql96-server/Makefile
+++ b/databases/postgresql96-server/Makefile
@@ -1,9 +1,9 @@
# Created by: Marc G. Fournier <scrappy@FreeBSD.org>
-DISTVERSION?= 9.6.22
+DISTVERSION?= 9.6.23
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
-PORTREVISION?= 1
+PORTREVISION?= 0
PKGNAMESUFFIX?= ${PORTVERSION:R:S/.//}${COMPONENT}
MAINTAINER?= pgsql@FreeBSD.org
diff --git a/databases/postgresql96-server/distinfo b/databases/postgresql96-server/distinfo
index 70f9d8efd3f7..b199b580028d 100644
--- a/databases/postgresql96-server/distinfo
+++ b/databases/postgresql96-server/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1620992041
-SHA256 (postgresql/postgresql-9.6.22.tar.bz2) = 3d32cd101025a0556813397c69feff3df3d63736adb8adeaf365c522f39f2930
-SIZE (postgresql/postgresql-9.6.22.tar.bz2) = 19003741
+TIMESTAMP = 1628577739
+SHA256 (postgresql/postgresql-9.6.23.tar.bz2) = a849f798401ab8c6dfa653ebbcd853b43f2200b4e3bc1ea3cb5bec9a691947b9
+SIZE (postgresql/postgresql-9.6.23.tar.bz2) = 19013235
SHA256 (postgresql/pg-96b4-icu-2016-10-02.diff.gz) = 85f81baa0fc8f692bcf802c8645196d9e3afdef4f760cef712d940b87655486e
SIZE (postgresql/pg-96b4-icu-2016-10-02.diff.gz) = 5998