aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/lmms/Makefile6
-rw-r--r--audio/lmms/files/patch-plugins__zynaddsubfx__fltk__src__filename_list.cxx2
2 files changed, 2 insertions, 6 deletions
diff --git a/audio/lmms/Makefile b/audio/lmms/Makefile
index d7fbe03fed20..a292bf7601e0 100644
--- a/audio/lmms/Makefile
+++ b/audio/lmms/Makefile
@@ -12,7 +12,7 @@ PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rodrigo@bebik.net
COMMENT= An all-in-one sequencer, drum machine, sampler and more
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
@@ -54,10 +54,6 @@ MAN1= lmms.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 800501
-BROKEN= does not build
-.endif
-
.if defined(WITH_JACK)
LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
.else
diff --git a/audio/lmms/files/patch-plugins__zynaddsubfx__fltk__src__filename_list.cxx b/audio/lmms/files/patch-plugins__zynaddsubfx__fltk__src__filename_list.cxx
index 9b9c04bc7dff..c3d171ab07eb 100644
--- a/audio/lmms/files/patch-plugins__zynaddsubfx__fltk__src__filename_list.cxx
+++ b/audio/lmms/files/patch-plugins__zynaddsubfx__fltk__src__filename_list.cxx
@@ -16,7 +16,7 @@
#ifndef HAVE_SCANDIR
int n = scandir(d, list, 0, sort);
-#elif defined(__hpux) || defined(__CYGWIN__) || (__GLIBC__ >= 2 && __GLIBC_MINOR__ >= 10 )
-+#elif defined(__hpux) || defined(__CYGWIN__) || (__GLIBC__ >= 2 && __GLIBC_MINOR__ >= 10 ) || (defined(__FreeBSD__) && __FreeBSD_version >= 900006)
++#elif defined(__hpux) || defined(__CYGWIN__) || (__GLIBC__ >= 2 && __GLIBC_MINOR__ >= 10 ) || (defined(__FreeBSD__) && ( (__FreeBSD_version < 900000 && __FreeBSD_version >= 800501) || (__FreeBSD_version >= 900006)))
// HP-UX, Cygwin and POSIX (2008) define the comparison function like this:
int n = scandir(d, list, 0, (int(*)(const dirent **, const dirent **))sort);
#elif defined(__osf__)