aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/texworks/Makefile1
-rw-r--r--games/bubble-chains/Makefile1
-rw-r--r--games/tanglet/Makefile1
-rw-r--r--misc/qmetro/Makefile1
4 files changed, 4 insertions, 0 deletions
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index f310804eb78d..04282272fc98 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= poppler-qt4:${PORTSDIR}/graphics/poppler-qt4
USES= pkgconfig
USE_QT4= qmake_build gui corelib rcc_build moc_build uic_build \
dbus xml scripttools designer_build
+QMAKEFLAGS= QMAKE_LFLAGS="-lz"
QMAKE_ARGS= INSTALL_PREFIX=${PREFIX} \
DATA_DIR=${DATADIR} \
DOCS_DIR=${DOCSDIR} \
diff --git a/games/bubble-chains/Makefile b/games/bubble-chains/Makefile
index be8d994629d7..f7a541e0b292 100644
--- a/games/bubble-chains/Makefile
+++ b/games/bubble-chains/Makefile
@@ -25,6 +25,7 @@ USE_XORG= xrandr
USE_DOS2UNIX= *.pro *.cpp *.h *.ui *.ui *.rc *.htm *.dat *.css
USE_QT4= moc_build qmake_build rcc_build uic_build iconengines imageformats \
corelib svg xml opengl network
+QMAKEFLAGS= QMAKE_LFLAGS="-L${LOCALBASE}/lib -lX11 -lSDL-1.2"
PORTDOCS= README
diff --git a/games/tanglet/Makefile b/games/tanglet/Makefile
index 5896727d73eb..fe7baa9a01e3 100644
--- a/games/tanglet/Makefile
+++ b/games/tanglet/Makefile
@@ -16,6 +16,7 @@ LICENSE= GPLv3
USE_BZIP2= yes
USES= desktop-file-utils
USE_QT4= moc_build qmake_build rcc_build gui iconengines imageformats
+QMAKEFLAGS= QMAKE_LFLAGS="-lz"
INSTALLS_ICONS= yes
PORTDOCS= CREDITS ChangeLog NEWS
diff --git a/misc/qmetro/Makefile b/misc/qmetro/Makefile
index d09096d24130..a4b249c28514 100644
--- a/misc/qmetro/Makefile
+++ b/misc/qmetro/Makefile
@@ -15,6 +15,7 @@ USE_ZIP= yes
INSTALLS_ICONS= yes
USE_QT4= gui xml qmake_build uic_build moc_build multimedia \
rcc_build
+QMAKEFLAGS= QMAKE_LFLAGS="-lz"
USE_DOS2UNIX= rc/alarm.pri
NO_STAGE= yes