aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/libopenshot/Makefile33
-rw-r--r--multimedia/libopenshot/distinfo6
-rw-r--r--multimedia/libopenshot/pkg-plist10
3 files changed, 30 insertions, 19 deletions
diff --git a/multimedia/libopenshot/Makefile b/multimedia/libopenshot/Makefile
index 4ac8dd016f10..0a2938185c3f 100644
--- a/multimedia/libopenshot/Makefile
+++ b/multimedia/libopenshot/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libopenshot
DISTVERSIONPREFIX= v
-DISTVERSION= 0.2.6
+DISTVERSION= 0.2.7
CATEGORIES= multimedia
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,32 +17,37 @@ LIB_DEPENDS= libopenshot-audio.so:audio/libopenshot-audio \
libavformat.so:multimedia/ffmpeg \
libzmq.so:net/libzmq4
-USES= cmake pkgconfig python:3.5+ qt:5
-USE_LDCONFIG= yes
+USES= cmake pkgconfig python:3.6+ qt:5
USE_GITHUB= yes
GH_ACCOUNT= OpenShot
+USE_LDCONFIG= yes
USE_PYTHON= flavors
USE_QT= core gui network multimedia widgets qmake_build buildtools_build
-
-CMAKE_ON= USE_SYSTEM_JSONCPP DISABLE_BUNDLED_JSONCPP USE_HW_ACCEL\
- CMAKE_DISABLE_FIND_PACKAGE_Doxygen\
+CMAKE_ON= USE_SYSTEM_JSONCPP DISABLE_BUNDLED_JSONCPP\
+ USE_HW_ACCEL ENABLE_PYTHON\
+ CMAKE_DISABLE_FIND_PACKAGE_Catch2\
CMAKE_DISABLE_FIND_PACKAGE_Resvg\
CMAKE_DISABLE_FIND_PACKAGE_Ruby
-CMAKE_OFF= ENABLE_COVERAGE\
- ENABLE_DOCS\
- ENABLE_TESTS
-OPTIONS_DEFINE= IMAGEMAGICK OPENCV
+CMAKE_OFF= ENABLE_COVERAGE BUILD_TESTING ENABLE_TESTS\
+ ENABLE_RUBY
+
+OPTIONS_DEFINE= DOCS IMAGEMAGICK OPENCV
OPTIONS_DEFAULT= IMAGEMAGICK
OPTIONS_SUB= yes
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
+DOCS_CMAKE_BOOL= ENABLE_DOCS
+DOCS_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Doxygen
+DOCS_CMAKE_ON= -DCMAKE_INSTALL_DOCDIR:PATH=${DOCSDIR_REL:Q}
+DOCS_PORTDOCS= *
IMAGEMAGICK_LIB_DEPENDS= libMagick++-${IMAGEMAGICK_DEFAULT}.so:graphics/ImageMagick${IMAGEMAGICK_DEFAULT}
IMAGEMAGICK_CMAKE_BOOL= ENABLE_MAGICK
IMAGEMAGICK_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_ImageMagick
OPENCV_LIB_DEPENDS= libopencv_core.so:graphics/opencv \
libprotobuf.so:devel/protobuf
-OPENCV_CMAKE_ON= -DOpenCV_DIR:STRING=${LOCALBASE:Q}/cmake/opencv4
OPENCV_CMAKE_BOOL= ENABLE_OPENCV
OPENCV_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_OpenCV\
CMAKE_DISABLE_FIND_PACKAGE_Protobuf
+OPENCV_CMAKE_ON= -DOpenCV_DIR:STRING=${LOCALBASE:Q}/cmake/opencv4
.include <bsd.port.options.mk>
@@ -52,4 +57,10 @@ USES+= compiler:gcc-c++11-lib
USES+= compiler:c++11-lang
.endif
+do-build-DOCS-on:
+ @(cd ${BUILD_WRKSRC}; if ! ${DO_MAKE_BUILD} doc; then \
+ (${ECHO_CMD} "===> ${.TARGET} failed unexpectedly.") | ${FMT_80} ; \
+ ${FALSE}; \
+ fi)
+
.include <bsd.port.mk>
diff --git a/multimedia/libopenshot/distinfo b/multimedia/libopenshot/distinfo
index 0fd1042e94d2..f74f47beb684 100644
--- a/multimedia/libopenshot/distinfo
+++ b/multimedia/libopenshot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1629968400
-SHA256 (OpenShot-libopenshot-v0.2.6_GH0.tar.gz) = 3e6f60c86748ea814a9c0c48e5a59c5b04a5876a43b763258d0dd3f6ae84fde8
-SIZE (OpenShot-libopenshot-v0.2.6_GH0.tar.gz) = 22472140
+TIMESTAMP = 1633834800
+SHA256 (OpenShot-libopenshot-v0.2.7_GH0.tar.gz) = 568eab6d69d469c5f745f0e25387ca5e000f7c28be48417b0d7770577ac74a28
+SIZE (OpenShot-libopenshot-v0.2.7_GH0.tar.gz) = 22472544
diff --git a/multimedia/libopenshot/pkg-plist b/multimedia/libopenshot/pkg-plist
index a16c18b1a0c0..13aec344aa80 100644
--- a/multimedia/libopenshot/pkg-plist
+++ b/multimedia/libopenshot/pkg-plist
@@ -38,7 +38,7 @@ include/libopenshot/ImageWriter.h
include/libopenshot/Json.h
include/libopenshot/KeyFrame.h
include/libopenshot/MagickUtilities.h
-%%OPENCV%%include/libopenshot/OpenCVUtilities.h
+include/libopenshot/OpenCVUtilities.h
include/libopenshot/OpenMPUtilities.h
include/libopenshot/OpenShot.h
include/libopenshot/OpenShotVersion.h
@@ -102,11 +102,11 @@ include/libopenshot/effects/Wave.h
include/libopenshot/sort_filter/Hungarian.h
include/libopenshot/sort_filter/KalmanTracker.h
lib/libopenshot.so
-lib/libopenshot.so.0.2.6
-lib/libopenshot.so.20
+lib/libopenshot.so.0.2.7
+lib/libopenshot.so.21
%%OPENCV%%lib/libopenshot_protobuf.so
-%%OPENCV%%lib/libopenshot_protobuf.so.0.2.6
-%%OPENCV%%lib/libopenshot_protobuf.so.20
+%%OPENCV%%lib/libopenshot_protobuf.so.0.2.7
+%%OPENCV%%lib/libopenshot_protobuf.so.21
%%PYTHON_SITELIBDIR%%/_openshot.so
%%PYTHON_SITELIBDIR%%/openshot.py
%%NO_OPENCV%%@dir include/libopenshot/protobuf_messages