aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--GIDs2
-rw-r--r--UIDs2
-rw-r--r--net/Makefile1
-rw-r--r--net/jotta-cli/Makefile42
-rw-r--r--net/jotta-cli/distinfo5
-rwxr-xr-xnet/jotta-cli/files/jottad.in18
-rw-r--r--net/jotta-cli/files/pkg-message.in17
-rw-r--r--net/jotta-cli/pkg-descr23
-rw-r--r--net/jotta-cli/pkg-plist8
9 files changed, 116 insertions, 2 deletions
diff --git a/GIDs b/GIDs
index 0f002106d485..79c7b72b24a2 100644
--- a/GIDs
+++ b/GIDs
@@ -234,7 +234,7 @@ pydio:*:291:
sftpgo:*:292:
biboumi:*:293:
krill:*:294:
-# free: 295
+jottad:*:295:
# free: 296
# free: 297
# free: 298
diff --git a/UIDs b/UIDs
index acfb094bada4..9ce3d2737a13 100644
--- a/UIDs
+++ b/UIDs
@@ -239,7 +239,7 @@ pydio:*:291:291::0:0:pydio cells user:/var/pydio:/bin/sh
sftpgo:*:292:292::0:0:SFTPGo user:/nonexistent:/usr/sbin/nologin
biboumi:*:293:293::0:0:biboumi:/nonexistent:/usr/sbin/nologin
krill:*:294:294::0:0:krill Pseudo User:/nonexistent:/usr/sbin/nologin
-# free: 295
+jottad:*:295:295::0:0:Jotta Cloud Daemon:/nonexisten:/usr/sbin/nologin
# free: 296
# free: 297
# free: 298
diff --git a/net/Makefile b/net/Makefile
index f20d9de3e26b..381111a08ac7 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -292,6 +292,7 @@
SUBDIR += jicmp
SUBDIR += jicmp6
SUBDIR += jose
+ SUBDIR += jotta-cli
SUBDIR += jrdesktop
SUBDIR += jsch
SUBDIR += jumpgate
diff --git a/net/jotta-cli/Makefile b/net/jotta-cli/Makefile
new file mode 100644
index 000000000000..aa4d37dfc2ca
--- /dev/null
+++ b/net/jotta-cli/Makefile
@@ -0,0 +1,42 @@
+# Created by: Trenton Schulz <trueos@norwegianrockcat.com>
+
+PORTNAME= jotta-cli
+PORTVERSION= 0.11.44593
+CATEGORIES= net
+MASTER_SITES= https://repo.jotta.us/archives/freebsd/${ARCH:S|amd64|amd64|:S|i386|386|}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}_freebsd_${ARCH:S|amd64|amd64|:S|i386|386|}
+
+MAINTAINER= trueos@norwegianrockcat.com
+COMMENT= Jotta Cloud Daemon and Command-Line Interface
+
+LICENSE= UNKNOWN
+LICENSE_NAME= "Jottacloud Terms and Service"
+LICENSE_TEXT= "JottaCloud has its own terms and conditions available at https://www.jottacloud.com/en/terms.html"
+LICENSE_PERMS= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
+
+RESTRICTED= yes
+
+ONLY_FOR_ARCHS= amd64 i386
+
+RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
+
+USE_RC_SUBR= jottad
+
+NO_BUILD= yes
+SUB_FILES= pkg-message \
+ jottad
+
+USERS= jottad
+GROUPS= jottad
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/jottad
+ ${INSTALL_SCRIPT} ${WRKDIR}/jottad ${STAGEDIR}${PREFIX}/etc/rc.d/jottad
+ ${INSTALL_PROGRAM} ${WRKDIR}/usr/bin/jotta-cli ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKDIR}/usr/bin/jottad ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKDIR}/etc/jottad/config.ini ${STAGEDIR}${PREFIX}/etc/jottad/config.ini.sample
+
+post-install:
+ ${MKDIR} ${STAGEDIR}/var/lib/jottad
+
+.include <bsd.port.mk>
diff --git a/net/jotta-cli/distinfo b/net/jotta-cli/distinfo
new file mode 100644
index 000000000000..cbadc966aed9
--- /dev/null
+++ b/net/jotta-cli/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1624294110
+SHA256 (jotta-cli-0.11.44593_freebsd_amd64.tar.gz) = d8e0ca6619cca4669556e35577601e88009a3993fc3e82009993e218fe4b4c9e
+SIZE (jotta-cli-0.11.44593_freebsd_amd64.tar.gz) = 11731054
+SHA256 (jotta-cli-0.11.44593_freebsd_386.tar.gz) = a4b0593383c11d22ebc22d3bccef558bd92400820aff630711c7b31675beda17
+SIZE (jotta-cli-0.11.44593_freebsd_386.tar.gz) = 11082905
diff --git a/net/jotta-cli/files/jottad.in b/net/jotta-cli/files/jottad.in
new file mode 100755
index 000000000000..847f5f736f14
--- /dev/null
+++ b/net/jotta-cli/files/jottad.in
@@ -0,0 +1,18 @@
+#!/bin/sh
+# PROVIDE: jottad
+# REQUIRE: DAEMON FILESYSTEMS netif
+# KEYWORD:
+
+# Heavily copied from user gt2416 on the FreeNAS forums
+# Thread: https://www.ixsystems.com/community/threads/jottacloud-install-guide.69086/
+
+. /etc/rc.subr
+
+name=jottad
+jottad_user=jottad
+rcvar=jottad_enable
+command_args="datadir %%PREFIX%%/etc/jottad &"
+command="%%PREFIX%%/sbin/${name}"
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/net/jotta-cli/files/pkg-message.in b/net/jotta-cli/files/pkg-message.in
new file mode 100644
index 000000000000..5c15e445a4ec
--- /dev/null
+++ b/net/jotta-cli/files/pkg-message.in
@@ -0,0 +1,17 @@
+[
+{ type: install
+ message: <<EOM
+To use the Jottacloud CLI, you must first start the jottad
+
+# service jottad onestart
+
+You can make this happen at start up by setting the jottad_enable variable.
+
+# sysrc jottad_enable=YES
+
+Instructions for using the Jottacloud CLI is available at:
+
+ https://docs.jottacloud.com/en/articles/1437248-login-and-basic-use-with-jottacloud-cli
+
+}
+]
diff --git a/net/jotta-cli/pkg-descr b/net/jotta-cli/pkg-descr
new file mode 100644
index 000000000000..b24472f33039
--- /dev/null
+++ b/net/jotta-cli/pkg-descr
@@ -0,0 +1,23 @@
+From the Jottacloud website:
+
+The Jottacloud Command-line Tool or Command-line Client is a
+Command-line tool for Jottacloud users.
+
+The command-line client (CLI) is capable of running on most devices
+with Windows, OS X and linux systems such as desktops, servers, NAS
+devices, and even Raspberry Pi.
+
+Note: The command-line client a special software designed for running
+on servers or headless systems. It is not meant to control the
+Jottacloud Desktop Client.
+
+Features
+
+* Automatic folder backup
+* Archive files
+* Custom scan interval
+* Ignore files and folders with simple gitignore style pattern
+* Simple webhooks
+* Manage remote hosts
+
+WWW: http://www.jottacloud.com
diff --git a/net/jotta-cli/pkg-plist b/net/jotta-cli/pkg-plist
new file mode 100644
index 000000000000..d1d4447d456d
--- /dev/null
+++ b/net/jotta-cli/pkg-plist
@@ -0,0 +1,8 @@
+bin/jotta-cli
+sbin/jottad
+@dir etc/rc.d
+@owner jottad
+@group jottad
+@sample(jottad,jottad,644) etc/jottad/config.ini.sample
+@dir /var/lib/jottad
+@dir /var/lib