aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/kexi/Makefile2
-rw-r--r--databases/kexi/files/patch-gentoo-glib-2.6840
-rw-r--r--databases/kexi/files/patch-gentoo-postgresql-9.1224
3 files changed, 65 insertions, 1 deletions
diff --git a/databases/kexi/Makefile b/databases/kexi/Makefile
index 6396d984d8d0..261295c2ead4 100644
--- a/databases/kexi/Makefile
+++ b/databases/kexi/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kexi
DISTVERSION= 3.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases kde
MASTER_SITES= KDE/stable/${PORTNAME}/src
DIST_SUBDIR= KDE/${PORTNAME}
diff --git a/databases/kexi/files/patch-gentoo-glib-2.68 b/databases/kexi/files/patch-gentoo-glib-2.68
new file mode 100644
index 000000000000..67efb82a3e77
--- /dev/null
+++ b/databases/kexi/files/patch-gentoo-glib-2.68
@@ -0,0 +1,40 @@
+From 73d3fa8e7a1028c89b20c74f6444a76a722d8041 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heiko.becker@kde.org>
+Date: Sun, 18 Apr 2021 11:47:30 +0200
+Subject: [PATCH] Include <glib.h> outside of the extern block
+
+This fixes the build with glib >= 2.68. It's caused by [1] and glib
+upstream did not want to include a workaround because the fixes
+downstream seem trivial [2][3].
+
+[1] https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1715
+[2] https://gitlab.gnome.org/GNOME/glib/-/issues/2331
+[3] https://gitlab.gnome.org/GNOME/glib/-/merge_requests/1935
+---
+ src/migration/mdb/3rdparty/mdbtools/include/mdbtools.h | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/migration/mdb/3rdparty/mdbtools/include/mdbtools.h b/src/migration/mdb/3rdparty/mdbtools/include/mdbtools.h
+index 31f48c171..56276e2d6 100644
+--- src/migration/mdb/3rdparty/mdbtools/include/mdbtools.h
++++ src/migration/mdb/3rdparty/mdbtools/include/mdbtools.h
+@@ -18,6 +18,8 @@
+ #ifndef _mdbtools_h_
+ #define _mdbtools_h_
+
++#include <glib.h>
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
+@@ -32,7 +34,6 @@
+ #endif
+ #include <ctype.h>
+ #include <string.h>
+-#include <glib.h>
+
+ #ifdef HAVE_ICONV
+ #include <iconv.h>
+--
+GitLab
+
diff --git a/databases/kexi/files/patch-gentoo-postgresql-9.12 b/databases/kexi/files/patch-gentoo-postgresql-9.12
new file mode 100644
index 000000000000..0e1acc2c5ce3
--- /dev/null
+++ b/databases/kexi/files/patch-gentoo-postgresql-9.12
@@ -0,0 +1,24 @@
+From 88ac2b4a1386bc05f0e3965f31949039eaf4d3ff Mon Sep 17 00:00:00 2001
+From: Pino Toscano <pino@kde.org>
+Date: Sat, 25 May 2019 07:12:17 +0200
+Subject: cmake: find PostgreSQL 12
+
+---
+ cmake/modules/FindPostgreSQL.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/modules/FindPostgreSQL.cmake b/cmake/modules/FindPostgreSQL.cmake
+index 56e6e56..1579be0 100644
+--- cmake/modules/FindPostgreSQL.cmake
++++ cmake/modules/FindPostgreSQL.cmake
+@@ -86,7 +86,7 @@ set(PostgreSQL_LIBRARY_DIR_MESSAGE "Set the PostgreSQL_LIBRARY_DIR cmake cache e
+ set(PostgreSQL_ROOT_DIR_MESSAGE "Set the PostgreSQL_ROOT system variable to where PostgreSQL is found on the machine E.g C:/Program Files/PostgreSQL/8.4")
+
+ set(PostgreSQL_KNOWN_VERSIONS ${PostgreSQL_ADDITIONAL_VERSIONS}
+- "11" "10" "9.6" "9.5" "9.4" "9.3" "9.2" "9.1" "9.0" "8.4" "8.3" "8.2" "8.1" "8.0")
++ "12" "11" "10" "9.6" "9.5" "9.4" "9.3" "9.2" "9.1" "9.0" "8.4" "8.3" "8.2" "8.1" "8.0")
+
+ # Define additional search paths for root directories.
+ foreach (suffix ${PostgreSQL_KNOWN_VERSIONS} )
+--
+cgit v1.1