aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/openexr/Makefile4
-rw-r--r--graphics/openexr/files/patch-lib_OpenEXRCore_internal__cpuid.h24
2 files changed, 25 insertions, 3 deletions
diff --git a/graphics/openexr/Makefile b/graphics/openexr/Makefile
index 12db2091f998..e6d3800dec07 100644
--- a/graphics/openexr/Makefile
+++ b/graphics/openexr/Makefile
@@ -1,6 +1,6 @@
PORTNAME= openexr
PORTVERSION= 3.1.10
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= graphics devel
MAINTAINER= mandree@FreeBSD.org
@@ -23,8 +23,6 @@ CPPFLAGS+= -I.
# must be linked with -l{thr|pthread} explicitly
LDFLAGS+= -lpthread
-PATCH_STRIP= -p1
-
_MAJORVER= 3_1
_VER= 30
_MINVER= 10
diff --git a/graphics/openexr/files/patch-lib_OpenEXRCore_internal__cpuid.h b/graphics/openexr/files/patch-lib_OpenEXRCore_internal__cpuid.h
new file mode 100644
index 000000000000..342cf10762d9
--- /dev/null
+++ b/graphics/openexr/files/patch-lib_OpenEXRCore_internal__cpuid.h
@@ -0,0 +1,24 @@
+https://github.com/AcademySoftwareFoundation/openexr/pull/1507/files
+
+--- src/lib/OpenEXRCore/internal_cpuid.h.orig 2023-07-31 18:17:50 UTC
++++ src/lib/OpenEXRCore/internal_cpuid.h
+@@ -39,14 +39,16 @@ static inline void check_for_x86_simd (int *f16c, int
+ *f16c = 0;
+ # endif
+
+-#elif OPENEXR_ENABLE_X86_SIMD_CHECK
++#elif defined(__AVX__) && defined(__F16C__)
+
+ // shortcut if everything is turned on / compiled in
+-# if defined(__AVX__) && defined(__F16C__)
+ *f16c = 1;
+ *avx = 1;
+ *sse2 = 1;
+-# elif defined(_MSC_VER) && defined(_WIN32)
++
++#elif OPENEXR_ENABLE_X86_SIMD_CHECK
++
++# if defined(_MSC_VER) && defined(_WIN32)
+ int regs[4], osxsave;
+
+ __cpuid (regs, 0);