aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/pycharm-ce/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/devel/pycharm-ce/Makefile b/devel/pycharm-ce/Makefile
index aaa306fd88b1..42bcd93e62ad 100644
--- a/devel/pycharm-ce/Makefile
+++ b/devel/pycharm-ce/Makefile
@@ -24,6 +24,20 @@ SHEBANG_FILES= plugins/python-ce/helpers/pycodestyle-2.10.0.py \
plugins/python-ce/helpers/pycodestyle.py \
plugins/python-ce/helpers/typeshed/scripts/sync_tensorflow_protobuf_stubs.sh
+# Remove the bundled native Pty4J support libraries, they are replaced by java/jetbrains-pty4j
+# Remove bundled linux-only JRE
+EXTRACT_AFTER_ARGS= --exclude ${DISTNAME}/bin/*fsnotifier* \
+ --exclude ${DISTNAME}/bin/*.so \
+ --exclude ${DISTNAME}/bin/repair \
+ --exclude ${DISTNAME}/bin/restarter \
+ --exclude ${DISTNAME}/lib/*.so \
+ --exclude ${DISTNAME}/plugins/*.so \
+ --exclude ${DISTNAME}/plugins/cwm-plugin/quiche-native \
+ --exclude ${DISTNAME}/plugins/python-ce/helpers/pydev/pydevd_attach_to_process \
+ --exclude ${DISTNAME}/lib/pty4j \
+ --exclude ${DISTNAME}/jbr \
+ --no-same-owner --no-same-permissions
+
NO_BUILD= yes
.include "${.CURDIR}/../../java/intellij/common.mk"
@@ -33,15 +47,7 @@ SUB_LIST+= IDEA_HOME=${IDEA_HOME}
# Remove non-native binaries
post-extract:
- @${RM} ${WRKSRC}/bin/*fsnotifier* ${WRKSRC}/bin/*.so ${WRKSRC}/bin/repair ${WRKSRC}/bin/restarter
- @${FIND} ${WRKSRC}/lib ${WRKSRC}/plugins -name '*.so' -delete
@${FIND} ${WRKSRC}/lib ${WRKSRC}/plugins -type d -empty -delete
- @${RM} -r ${WRKSRC}/plugins/cwm-plugin/quiche-native
- @${RM} -r ${WRKSRC}/plugins/python-ce/helpers/pydev/pydevd_attach_to_process
-# Remove the bundled native Pty4J support libraries, they are replaced by java/jetbrains-pty4j
- @${RM} -r ${WRKSRC}/lib/pty4j
-# Remove bundled linux-only JRE
- @${RM} -r ${WRKSRC}/jbr
# TODO: Remove and enable fsnotifier when devel/libinotify is fixed
# Disable filewatcher warning message on IDEA startup
${ECHO} "idea.filewatcher.disabled=true" >> ${WRKSRC}/bin/idea.properties