aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/py-matrix-synapse/Makefile6
-rw-r--r--net-im/py-matrix-synapse/files/patch-pyproject.toml17
2 files changed, 15 insertions, 8 deletions
diff --git a/net-im/py-matrix-synapse/Makefile b/net-im/py-matrix-synapse/Makefile
index d90b38eab66e..e9367d6616ae 100644
--- a/net-im/py-matrix-synapse/Makefile
+++ b/net-im/py-matrix-synapse/Makefile
@@ -12,9 +12,8 @@ WWW= https://www.matrix.org
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.1.0<=1.6.1:devel/py-poetry-core@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}setuptools-rust>=1.3:devel/py-setuptools-rust@${PY_FLAVOR}
-
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.1.0<1.7.0_99:devel/py-poetry-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools-rust>=1.3<1.7.0_99:devel/py-setuptools-rust@${PY_FLAVOR}
# Keep the RUN_DEPENDS layout similar to the pyproject.toml file
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0.0:devel/py-jsonschema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}immutabledict>=2.0:devel/py-immutabledict@${PY_FLAVOR} \
@@ -46,7 +45,6 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0.0:devel/py-jsonschema@${PY_F
${PYTHON_PKGNAMEPREFIX}pydantic>=1.7.4:devel/py-pydantic@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pysaml2>=4.5.0:security/py-pysaml2@${PY_FLAVOR} \
${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
-
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}virtualenv>=15.0:devel/py-virtualenv@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tox>=2.3.1:devel/py-tox@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
diff --git a/net-im/py-matrix-synapse/files/patch-pyproject.toml b/net-im/py-matrix-synapse/files/patch-pyproject.toml
index 5686b1433743..ffcc044afac2 100644
--- a/net-im/py-matrix-synapse/files/patch-pyproject.toml
+++ b/net-im/py-matrix-synapse/files/patch-pyproject.toml
@@ -1,8 +1,8 @@
---- pyproject.toml.orig 2023-05-09 16:38:29 UTC
+--- pyproject.toml.orig 2023-07-04 15:35:46 UTC
+++ pyproject.toml
-@@ -209,17 +209,6 @@ importlib_metadata = { version = ">=1.4", python = "<3
- # This is the most recent version of Pydantic with available on common distros.
- pydantic = ">=1.7.4"
+@@ -210,17 +210,6 @@ importlib_metadata = { version = ">=1.4", python = "<3
+ # We are currently incompatible with >=2.0.0: (https://github.com/matrix-org/synapse/issues/15858)
+ pydantic = "^1.7.4"
-# This is for building the rust components during "poetry install", which
-# currently ignores the `build-system.requires` directive (c.f.
@@ -18,3 +18,12 @@
# Optional Dependencies
# ---------------------
matrix-synapse-ldap3 = { version = ">=0.1", optional = true }
+@@ -370,7 +359,7 @@ furo = ">=2022.12.7,<2024.0.0"
+ # system changes.
+ # We are happy to raise these upper bounds upon request,
+ # provided we check that it's safe to do so (i.e. that CI passes).
+-requires = ["poetry-core>=1.1.0,<=1.6.0", "setuptools_rust>=1.3,<=1.6.0"]
++requires = ["poetry-core>=1.1.0,<=1.7.0", "setuptools_rust>=1.3,<=1.7.0"]
+ build-backend = "poetry.core.masonry.api"
+
+