aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/py-apscheduler/Makefile2
-rw-r--r--devel/py-apscheduler/files/patch-tzlocal-1.214
2 files changed, 1 insertions, 15 deletions
diff --git a/devel/py-apscheduler/Makefile b/devel/py-apscheduler/Makefile
index c9a354edd9d6..81633196258a 100644
--- a/devel/py-apscheduler/Makefile
+++ b/devel/py-apscheduler/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.4.0:devel/py-six@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}tzlocal>=1.2<3:devel/py-tzlocal@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}tzlocal>=4:devel/py-tzlocal@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-asyncio>0:devel/py-pytest-asyncio@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-tornado>0:devel/py-pytest-tornado@${PY_FLAVOR}
diff --git a/devel/py-apscheduler/files/patch-tzlocal-1.2 b/devel/py-apscheduler/files/patch-tzlocal-1.2
deleted file mode 100644
index 2093667aed5d..000000000000
--- a/devel/py-apscheduler/files/patch-tzlocal-1.2
+++ /dev/null
@@ -1,14 +0,0 @@
-Partially revert https://github.com/agronholm/apscheduler/commit/b773c79ac505
-until devel/py-tzlocal is updated to 2.1
-
---- setup.py.orig 2021-10-24 20:17:02 UTC
-+++ setup.py
-@@ -41,7 +41,7 @@ setup(
- 'setuptools >= 0.7',
- 'six >= 1.4.0',
- 'pytz',
-- 'tzlocal >= 2.0, != 3.*'
-+ 'tzlocal >= 1.2, != 3.*'
- ],
- extras_require={
- ':python_version == "2.7"': ['futures'],