aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--science/octopus/Makefile2
-rw-r--r--science/octopus/files/patch-testsuite_oct-run__testsuite.sh.in13
2 files changed, 14 insertions, 1 deletions
diff --git a/science/octopus/Makefile b/science/octopus/Makefile
index 67b68df43580..ac90982394a2 100644
--- a/science/octopus/Makefile
+++ b/science/octopus/Makefile
@@ -42,7 +42,7 @@ LDFLAGS+= -lsymspg
FCFLAGS+= -I${LOCALBASE}/include -ffree-line-length-none
INSTALL_TARGET= install-strip
-TEST_TARGET= check-short # tests fail: https://gitlab.com/octopus-code/octopus/-/issues/536
+TEST_TARGET= check-short # some tests fail
OPTIONS_DEFINE= OPENMP
OPTIONS_DEFAULT= OPENMP
diff --git a/science/octopus/files/patch-testsuite_oct-run__testsuite.sh.in b/science/octopus/files/patch-testsuite_oct-run__testsuite.sh.in
new file mode 100644
index 000000000000..11d7827d709c
--- /dev/null
+++ b/science/octopus/files/patch-testsuite_oct-run__testsuite.sh.in
@@ -0,0 +1,13 @@
+- backport of https://gitlab.com/octopus-code/octopus/-/merge_requests/1598
+
+--- testsuite/oct-run_testsuite.sh.in.orig 2022-01-06 16:59:24 UTC
++++ testsuite/oct-run_testsuite.sh.in
+@@ -141,7 +141,7 @@ function checkqueue {
+ break;
+ fi
+ done
+- sleep 0.1s;
++ sleep 0.1;
+ done
+
+ logfile=`basename $test_name .test`.log