aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/py-topologic/Makefile37
-rw-r--r--math/py-topologic/distinfo3
-rw-r--r--math/py-topologic/pkg-descr5
4 files changed, 46 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index e96e08300c18..b49285e80d97 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -944,6 +944,7 @@
SUBDIR += py-symcxx
SUBDIR += py-sympy
SUBDIR += py-theano
+ SUBDIR += py-topologic
SUBDIR += py-triangle
SUBDIR += py-uncertainties
SUBDIR += py-unyt
diff --git a/math/py-topologic/Makefile b/math/py-topologic/Makefile
new file mode 100644
index 000000000000..6b4bd28035df
--- /dev/null
+++ b/math/py-topologic/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= topologic
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.5.0-21
+DISTVERSIONSUFFIX= -gae5ad5d
+CATEGORIES= math
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= -space-modeling-library
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library for topological representations of architectural spaces
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/../LICENSE
+
+LIB_DEPENDS= libTopologicCore.so:math/topologic \
+ libTKernel.so:cad/opencascade
+
+USES= cmake compiler:c++17-lang localbase:ldflags python
+
+USE_GITHUB= yes
+GH_ACCOUNT= wassimj
+GH_PROJECT= Topologic
+
+WRKSRC_SUBDIR= Python-Bindings
+
+CXXFLAGS+= -I${LOCALBASE}/include/OpenCASCADE
+
+PLIST_FILES= ${PYTHON_SITELIBDIR}/topologic${PYTHON_EXT_SUFFIX}.so
+
+do-install: # workaround for https://github.com/wassimj/Topologic/issues/34
+ ${MKDIR} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+ ${INSTALL_LIB} ${BUILD_WRKSRC}/topologic.cpython-38.so ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+do-test: install
+ ${PYTHON_CMD} ${WRKSRC}/test/topologictest01.py
+
+.include <bsd.port.mk>
diff --git a/math/py-topologic/distinfo b/math/py-topologic/distinfo
new file mode 100644
index 000000000000..c08d12fe35f8
--- /dev/null
+++ b/math/py-topologic/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1643537818
+SHA256 (wassimj-Topologic-v0.5.0-21-gae5ad5d_GH0.tar.gz) = 00df6ecdcef44d632d7eedbcfb02d4388f93d8679f7000bf821ce9675dd4a19e
+SIZE (wassimj-Topologic-v0.5.0-21-gae5ad5d_GH0.tar.gz) = 335006
diff --git a/math/py-topologic/pkg-descr b/math/py-topologic/pkg-descr
new file mode 100644
index 000000000000..533d401bc722
--- /dev/null
+++ b/math/py-topologic/pkg-descr
@@ -0,0 +1,5 @@
+Topologic is a software modelling library enabling hierarchical and
+topological representations of architectural spaces, buildings and
+artefacts through non-manifold topology.
+
+WWW: https://topologic.app/