aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 574860414da0..d8738c83dba3 100644
--- a/Makefile
+++ b/Makefile
@@ -53,11 +53,11 @@ PORTSTOP= yes
index:
@rm -f ${.CURDIR}/INDEX
- @make ${.CURDIR}/INDEX
+ @cd ${.CURDIR} && make ${.CURDIR}/INDEX
${.CURDIR}/INDEX:
@echo -n "Generating INDEX - please wait.."
- @make describe ECHO_MSG="echo > /dev/null" | \
+ @cd ${.CURDIR} && make describe ECHO_MSG="echo > /dev/null" | \
perl ${.CURDIR}/Tools/make_index > ${.CURDIR}/INDEX
.if !defined(INDEX_NOSORT)
@sed -e 's./..g' ${.CURDIR}/INDEX | \