aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index cbe2396182c5..f0cbd3d7a464 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -729,6 +729,8 @@ MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
.include "${PORTSDIR}/Mk/bsd.ruby.mk"
.endif
+.include "${PORTSDIR}/Mk/bsd.gnome.mk"
+
# defaults to 3.3.6; will be changed to 4.0 when it is ready
XFREE86_VERSION?= 3
@@ -793,6 +795,7 @@ BUILD_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
.endif
.if defined(USE_GMAKE)
BUILD_DEPENDS+= gmake:${PORTSDIR}/devel/gmake
+CONFIGURE_ENV+= MAKE=${GMAKE}
.endif
.if defined(USE_AUTOMAKE)
USE_AUTOCONF= yes
@@ -918,6 +921,8 @@ LIB_DEPENDS+= X11.6:${PORTSDIR}/x11/XFree86-4-libraries
.endif
.endif
+.include "${PORTSDIR}/Mk/bsd.gnome.mk"
+
.if exists(${PORTSDIR}/../Makefile.inc)
.include "${PORTSDIR}/../Makefile.inc"
.endif
@@ -2209,6 +2214,15 @@ post-${name}:
.endfor
+.if defined(GNOME_OPTION_MSG) && (!defined(PACKAGE_BUILDING) || !defined(BATCH))
+pre-everything:: echo-gnome-option-msg
+
+echo-gnome-option-msg:
+ @for m in ${GNOME_OPTION_MSG}; do \
+ ${ECHO_MSG} $$m; \
+ done
+.endif
+
# Patch-libtool
#
# Special target to automatically make libtool using ports use the